summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2007-04-01 17:42:43 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2007-04-01 17:42:43 +0000
commitfd751d001847c7ab0827381225520076e30f5a84 (patch)
tree1291862591cd7284173a793507282d00a4ef8b7b /net-analyzer/ipband
parentVersion bump. Most of the code is re-written, and lots of extra features and (diff)
downloadgentoo-2-fd751d001847c7ab0827381225520076e30f5a84.tar.gz
gentoo-2-fd751d001847c7ab0827381225520076e30f5a84.tar.bz2
gentoo-2-fd751d001847c7ab0827381225520076e30f5a84.zip
Mark 0.8 x86 stable. Use emake instead of make, minor cosmetic fixes.
(Portage version: 2.1.2.2)
Diffstat (limited to 'net-analyzer/ipband')
-rw-r--r--net-analyzer/ipband/ChangeLog5
-rw-r--r--net-analyzer/ipband/ipband-0.8.ebuild14
2 files changed, 11 insertions, 8 deletions
diff --git a/net-analyzer/ipband/ChangeLog b/net-analyzer/ipband/ChangeLog
index 530b5d50eaaf..cd3e4adbd209 100644
--- a/net-analyzer/ipband/ChangeLog
+++ b/net-analyzer/ipband/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-analyzer/ipband
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ipband/ChangeLog,v 1.1 2007/02/03 21:15:51 mjolnir Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ipband/ChangeLog,v 1.2 2007/04/01 17:42:43 vanquirius Exp $
+
+ 01 Apr 2007; Marcelo Goes <vanquirius@gentoo.org> ipband-0.8.ebuild:
+ Mark 0.8 x86 stable. Use emake instead of make, minor cosmetic fixes.
*ipband-0.8 (03 Feb 2007)
diff --git a/net-analyzer/ipband/ipband-0.8.ebuild b/net-analyzer/ipband/ipband-0.8.ebuild
index 38d1a02383e1..d6cec8b0b1b5 100644
--- a/net-analyzer/ipband/ipband-0.8.ebuild
+++ b/net-analyzer/ipband/ipband-0.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ipband/ipband-0.8.ebuild,v 1.1 2007/02/03 21:15:51 mjolnir Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ipband/ipband-0.8.ebuild,v 1.2 2007/04/01 17:42:43 vanquirius Exp $
inherit eutils
@@ -10,28 +10,28 @@ SRC_URI="http://ipband.sourceforge.net/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="x86"
IUSE=""
DEPEND=">=net-libs/libpcap-0.4"
-
src_unpack() {
unpack ${A}
# Provide a postfix MTA string in the author's ipband.conf example
- sed -rie 's:(#mtastring.*):# Sendmail\n\1\n# Postfix\n#mtastring "/usr/sbin/sendmail -t":g' ${S}/ipband.sample.conf
+ sed -rie 's:(#mtastring.*):# Sendmail\n\1\n# Postfix\n#mtastring "/usr/sbin/sendmail -t":g' \
+ "${S}"/ipband.sample.conf
}
src_compile() {
- make || die "Compile problem"
+ emake || die "Compile problem"
}
src_install() {
doman ipband.1
- dodoc CHANGELOG COPYING INSTALL README
+ dodoc CHANGELOG README
exeinto /usr/bin ; doexe ipband
- exeinto /etc/init.d ; newexe ${FILESDIR}/ipband-init ipband
+ exeinto /etc/init.d ; newexe "${FILESDIR}"/ipband-init ipband
insinto /etc/ ; newins ipband.sample.conf ipband.conf
}