summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2007-03-01 07:02:07 +0000
committerPeter Volkov <pva@gentoo.org>2007-03-01 07:02:07 +0000
commit525b2ff62176266b17bc1d2643faf12759b9c449 (patch)
tree262ca200cfb691607a0647753bfcbc3fc861a520 /net-analyzer/ipac-ng/ipac-ng-1.31-r2.ebuild
parenttweak grepping of moduledb to avoid errors when moduledb hasnt actually been ... (diff)
downloadgentoo-2-525b2ff62176266b17bc1d2643faf12759b9c449.tar.gz
gentoo-2-525b2ff62176266b17bc1d2643faf12759b9c449.tar.bz2
gentoo-2-525b2ff62176266b17bc1d2643faf12759b9c449.zip
Fixed compilation problem reported by Nick Soveiko <gentoo-bugzilla AT alerik.org> in bug #168067. Fixed || ( use? ( ) ) constructs bug #168179.
(Portage version: 2.1.2-r9)
Diffstat (limited to 'net-analyzer/ipac-ng/ipac-ng-1.31-r2.ebuild')
-rw-r--r--net-analyzer/ipac-ng/ipac-ng-1.31-r2.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/net-analyzer/ipac-ng/ipac-ng-1.31-r2.ebuild b/net-analyzer/ipac-ng/ipac-ng-1.31-r2.ebuild
index a7638df9dfb0..8c8c0509a89e 100644
--- a/net-analyzer/ipac-ng/ipac-ng-1.31-r2.ebuild
+++ b/net-analyzer/ipac-ng/ipac-ng-1.31-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ipac-ng/ipac-ng-1.31-r2.ebuild,v 1.6 2006/11/01 14:24:22 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ipac-ng/ipac-ng-1.31-r2.ebuild,v 1.7 2007/03/01 07:02:07 pva Exp $
inherit eutils
@@ -14,10 +14,9 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc x86"
IUSE="gd sqlite postgres"
-RDEPEND="virtual/libc
- || ( sqlite? ( =dev-db/sqlite-2* )
- postgres? ( dev-db/postgresql )
- sys-libs/gdbm )"
+RDEPEND="postgres? ( dev-db/postgresql )
+ !postgres? ( sqlite? ( =dev-db/sqlite-2* )
+ !sqlite? ( sys-libs/gdbm ) )"
DEPEND="${RDEPEND}
sys-devel/bison
sys-devel/flex"
@@ -36,8 +35,10 @@ pkg_setup() {
src_unpack() {
unpack ${A}
cd "${S}"
+
epatch "${WORKDIR}"/${P}-iptables-1.3.1.patch
epatch "${WORKDIR}"/ipcop-${P}-fetchcounter.patch
+ epatch "${FILESDIR}"/${P}-lable-at-the-end-of-compound.patch
}
src_compile() {