summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-06-02 11:51:00 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-06-02 11:51:00 +0000
commit56d3cc9dd6c882834c2164c82ab5f7d25f6422f3 (patch)
treecfb2656ecb7c24e98ccb8f5a112d36e5fa0c5d60 /net-analyzer/ifstatus
parentnetbeans-6.7_rc1: Fixed compilation error when jvyamlb.jar was missing (diff)
downloadgentoo-2-56d3cc9dd6c882834c2164c82ab5f7d25f6422f3.tar.gz
gentoo-2-56d3cc9dd6c882834c2164c82ab5f7d25f6422f3.tar.bz2
gentoo-2-56d3cc9dd6c882834c2164c82ab5f7d25f6422f3.zip
Add patch to fix --as-needed by Kevin Pyle, close bug #247928. Remove -j1 from emake (builds fine at -j12), die on failed install.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/ifstatus')
-rw-r--r--net-analyzer/ifstatus/ChangeLog7
-rw-r--r--net-analyzer/ifstatus/files/ifstatus-1.1.0-asneeded.patch21
-rw-r--r--net-analyzer/ifstatus/ifstatus-1.1.0.ebuild10
3 files changed, 33 insertions, 5 deletions
diff --git a/net-analyzer/ifstatus/ChangeLog b/net-analyzer/ifstatus/ChangeLog
index 720b05fe5a6a..4d614e89c9bb 100644
--- a/net-analyzer/ifstatus/ChangeLog
+++ b/net-analyzer/ifstatus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/ifstatus
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ifstatus/ChangeLog,v 1.6 2009/05/29 17:10:42 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ifstatus/ChangeLog,v 1.7 2009/06/02 11:51:00 flameeyes Exp $
+
+ 02 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
+ ifstatus-1.1.0.ebuild, +files/ifstatus-1.1.0-asneeded.patch:
+ Add patch to fix --as-needed by Kevin Pyle, close bug #247928. Remove -j1
+ from emake (builds fine at -j12), die on failed install.
29 May 2009; Steve Dibb <beandog@gentoo.org> ifstatus-1.1.0.ebuild:
amd64 stable
diff --git a/net-analyzer/ifstatus/files/ifstatus-1.1.0-asneeded.patch b/net-analyzer/ifstatus/files/ifstatus-1.1.0-asneeded.patch
new file mode 100644
index 000000000000..0b95a6163259
--- /dev/null
+++ b/net-analyzer/ifstatus/files/ifstatus-1.1.0-asneeded.patch
@@ -0,0 +1,21 @@
+diff -ru a/Makefile b/Makefile
+--- a/Makefile 2009-01-23 22:23:43.000000000 -0600
++++ b/Makefile 2009-01-23 22:27:06.000000000 -0600
+@@ -1,7 +1,7 @@
+ # Makefile for IFStatus
+ # Gabriel Montenegro
+
+-LDFLAGS = -lncurses
++LDLIBS = -lncurses
+
+ BIN = ifstatus
+ OBJ = BorderDecorator.o\
+@@ -28,7 +28,7 @@
+ all : ifstatus printdone
+
+ ifstatus : $(OBJ)
+- $(CXX) $(CXXFLAGS) $(LDFLAGS) $^ -o $@
++ $(LINK.cc) $^ $(LDLIBS) -o $@
+
+ printdone:
+ @if [ -e "./${BIN}" ]; then echo "Compiled.."; else echo "Error compiling!"; fi
diff --git a/net-analyzer/ifstatus/ifstatus-1.1.0.ebuild b/net-analyzer/ifstatus/ifstatus-1.1.0.ebuild
index b205e4b99acc..ea68f21cd2e5 100644
--- a/net-analyzer/ifstatus/ifstatus-1.1.0.ebuild
+++ b/net-analyzer/ifstatus/ifstatus-1.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ifstatus/ifstatus-1.1.0.ebuild,v 1.7 2009/05/29 17:10:42 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ifstatus/ifstatus-1.1.0.ebuild,v 1.8 2009/06/02 11:51:00 flameeyes Exp $
inherit eutils toolchain-funcs
@@ -27,15 +27,17 @@ src_unpack() {
-e 's/GCC/CXX/g' \
-e 's/CFLAGS/CXXFLAGS/g' \
Makefile || die "sed failed"
+
+ epatch "${FILESDIR}/${P}-asneeded.patch"
}
src_compile() {
- emake -j1 CXX=$(tc-getCXX) || die "emake failed"
+ emake CXX=$(tc-getCXX) || die "emake failed"
}
src_install() {
- dobin ifstatus
- dodoc AUTHORS README
+ dobin ifstatus || die
+ dodoc AUTHORS README || die
}
pkg_postinst() {