summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEldad Zack <eldad@gentoo.org>2004-08-20 13:51:44 +0000
committerEldad Zack <eldad@gentoo.org>2004-08-20 13:51:44 +0000
commitc6fccc606853a1a08dfb7b1988cb29c3b08844a1 (patch)
treeef4804e73afd17f5c0f4dad28ca5cdbca7945d13 /net-analyzer/hping
parentclosing bug #60767 (Manifest recommit) (diff)
downloadgentoo-2-c6fccc606853a1a08dfb7b1988cb29c3b08844a1.tar.gz
gentoo-2-c6fccc606853a1a08dfb7b1988cb29c3b08844a1.tar.bz2
gentoo-2-c6fccc606853a1a08dfb7b1988cb29c3b08844a1.zip
Ethernet bridge interface fix, closes bug 59534
Diffstat (limited to 'net-analyzer/hping')
-rw-r--r--net-analyzer/hping/ChangeLog9
-rw-r--r--net-analyzer/hping/Manifest3
-rw-r--r--net-analyzer/hping/files/digest-hping-2.0.0_rc3-r11
-rw-r--r--net-analyzer/hping/files/hping-bridge.patch12
-rw-r--r--net-analyzer/hping/hping-2.0.0_rc3-r1.ebuild41
5 files changed, 65 insertions, 1 deletions
diff --git a/net-analyzer/hping/ChangeLog b/net-analyzer/hping/ChangeLog
index f2005d96724a..6af972fad271 100644
--- a/net-analyzer/hping/ChangeLog
+++ b/net-analyzer/hping/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/hping
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/hping/ChangeLog,v 1.26 2004/08/08 16:49:35 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/hping/ChangeLog,v 1.27 2004/08/20 13:51:44 eldad Exp $
+
+*hping-2.0.0_rc3-r1 (20 Aug 2004)
+
+ 20 Aug 2004; Eldad Zack <eldad@gentoo.org> +files/hping-bridge.patch,
+ +hping-2.0.0_rc3-r1.ebuild:
+ Ethernet bridge interface fix: patch contributed by Nathan
+ <nathan.stocks@gmail.com>. Closes #59534.
08 Aug 2004; Bryan Østergaard <kloeri@gentoo.org> hping-2.0.0_rc3.ebuild:
Stable on alpha.
diff --git a/net-analyzer/hping/Manifest b/net-analyzer/hping/Manifest
index 810a16fab0f9..25c7388e492c 100644
--- a/net-analyzer/hping/Manifest
+++ b/net-analyzer/hping/Manifest
@@ -1,12 +1,15 @@
MD5 e51f6f95cc0e65a374df53d0e0639010 hping-2.0.0_rc3.ebuild 982
+MD5 befac2f9e81fd1e07fe2e8a732f7f517 hping-2.0.0_rc3-r1.ebuild 1025
MD5 31ba38fdee4250040b5f035028891abf hping-2.0.0_rc2-r1.ebuild 903
MD5 00b97cbd98b3326baa875697173d1501 hping-2.0.0_rc2.ebuild 835
MD5 b81df8eb3d394f37bbb9837346907224 hping-2.0.0_rc1.ebuild 960
MD5 2b5e2c8777bddce6fad9f7c94f9836c9 ChangeLog 3414
MD5 51334b67d2cbed22e0efec4143bc6ff0 metadata.xml 245
MD5 eef05cbe61a0adf5b65aced19f629085 files/digest-hping-2.0.0_rc2-r1 66
+MD5 f72fc3b23f30d84ba7210390cf3b4b57 files/digest-hping-2.0.0_rc3-r1 66
MD5 704f5fd266e6ab22f0eed2acb3aa621b files/digest-hping-2.0.0_rc1 65
MD5 eef05cbe61a0adf5b65aced19f629085 files/digest-hping-2.0.0_rc2 66
MD5 f72fc3b23f30d84ba7210390cf3b4b57 files/digest-hping-2.0.0_rc3 66
MD5 9d855cb52e43027b417ebb95dbad5c72 files/bytesex.h.patch 623
MD5 cca06082ed7613b5803b6c7ff62a31bf files/wlan-header-fix.patch 848
+MD5 b14544690b9c931e61b28dd0f6544f48 files/hping-bridge.patch 359
diff --git a/net-analyzer/hping/files/digest-hping-2.0.0_rc3-r1 b/net-analyzer/hping/files/digest-hping-2.0.0_rc3-r1
new file mode 100644
index 000000000000..d75f5d972d90
--- /dev/null
+++ b/net-analyzer/hping/files/digest-hping-2.0.0_rc3-r1
@@ -0,0 +1 @@
+MD5 029bf240f2e0545b664b2f8b9118d9e8 hping2.0.0-rc3.tar.gz 124573
diff --git a/net-analyzer/hping/files/hping-bridge.patch b/net-analyzer/hping/files/hping-bridge.patch
new file mode 100644
index 000000000000..004b6470ae23
--- /dev/null
+++ b/net-analyzer/hping/files/hping-bridge.patch
@@ -0,0 +1,12 @@
+--- getlhs.c.old 2004-08-05 09:20:35.320759304 -0600
++++ getlhs.c 2004-08-05 09:12:40.330968728 -0600
+@@ -93,6 +93,9 @@
+ } else if ( strstr(ifname, "eth") ) {
+ linkhdr_size = ETHHDR_SIZE;
+ return 0;
++ } else if ( strstr(ifname, "br") ) {
++ linkhdr_size = ETHHDR_SIZE;
++ return 0;
+ } else if (strstr(ifname, "ets")) {
+ linkhdr_size = 0;
+ return 0;
diff --git a/net-analyzer/hping/hping-2.0.0_rc3-r1.ebuild b/net-analyzer/hping/hping-2.0.0_rc3-r1.ebuild
new file mode 100644
index 000000000000..c5932bcd9ec3
--- /dev/null
+++ b/net-analyzer/hping/hping-2.0.0_rc3-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/hping/hping-2.0.0_rc3-r1.ebuild,v 1.1 2004/08/20 13:51:44 eldad Exp $
+
+inherit eutils
+
+MY_P="${PN}${PV//_/-}"
+DESCRIPTION="A ping-like TCP/IP packet assembler/analyzer"
+HOMEPAGE="http://www.hping.org"
+SRC_URI="http://www.hping.org/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~hppa ~ia64 ~amd64 ~alpha"
+IUSE="debug"
+
+DEPEND="net-libs/libpcap"
+
+S="${WORKDIR}/${MY_P//\.[0-9]}"
+
+src_compile() {
+ ./configure || die
+ epatch ${FILESDIR}/bytesex.h.patch
+ epatch ${FILESDIR}/hping-bridge.patch
+
+ if use debug
+ then
+ make CCOPT="${CFLAGS}" || die
+ else
+ make CCOPT="${CFLAGS}" DEBUG="" || die
+ fi
+}
+
+src_install () {
+ dodir /usr/sbin
+ dosbin hping2
+ dosym /usr/sbin/hping2 /usr/sbin/hping
+
+ doman docs/hping2.8
+ dodoc INSTALL KNOWN-BUGS NEWS README TODO AUTHORS BUGS CHANGES COPYING docs/AS-BACKDOOR docs/HPING2-IS-OPEN docs/MORE-FUN-WITH-IPID docs/*.txt
+}