summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMalcolm Lashley <malc@gentoo.org>2004-07-27 20:48:32 +0000
committerMalcolm Lashley <malc@gentoo.org>2004-07-27 20:48:32 +0000
commit746a829b4c006267b53e3a6c6a817bb22b999a13 (patch)
tree0a71e6cb60cae53412c0ff254cb710ab3ef173d9 /net-analyzer/hping
parentoh! a new ebuild (Manifest recommit) (diff)
downloadgentoo-2-746a829b4c006267b53e3a6c6a817bb22b999a13.tar.gz
gentoo-2-746a829b4c006267b53e3a6c6a817bb22b999a13.tar.bz2
gentoo-2-746a829b4c006267b53e3a6c6a817bb22b999a13.zip
Teach bytesex.h to know __x86_64__ fix bug #57834
Diffstat (limited to 'net-analyzer/hping')
-rw-r--r--net-analyzer/hping/ChangeLog5
-rw-r--r--net-analyzer/hping/files/amd64-header-fix.patch10
-rw-r--r--net-analyzer/hping/hping-2.0.0_rc3.ebuild3
3 files changed, 16 insertions, 2 deletions
diff --git a/net-analyzer/hping/ChangeLog b/net-analyzer/hping/ChangeLog
index f3398c4c5713..8de585637eca 100644
--- a/net-analyzer/hping/ChangeLog
+++ b/net-analyzer/hping/ChangeLog
@@ -1,10 +1,13 @@
# ChangeLog for net-analyzer/hping
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/hping/ChangeLog,v 1.23 2004/07/23 01:10:26 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/hping/ChangeLog,v 1.24 2004/07/27 20:48:32 malc Exp $
22 Jul 2004; Jason Wever <weeve@gentoo.org> hping-2.0.0_rc3.ebuild:
Stable on sparc.
+ 27 Jul 2004; <malc@gentoo.org> hping-2.0.0_rc3.ebuild:
+ Teach bytesex.h to know __x86_64__ fixes bug #57834
+
11 Jul 2004; Eldad Zack <eldad@gentoo.org> hping-2.0.0_rc3.ebuild:
marked x86 stable
diff --git a/net-analyzer/hping/files/amd64-header-fix.patch b/net-analyzer/hping/files/amd64-header-fix.patch
new file mode 100644
index 000000000000..af176dfe1741
--- /dev/null
+++ b/net-analyzer/hping/files/amd64-header-fix.patch
@@ -0,0 +1,10 @@
+--- bytesex.h 2003-07-28 10:00:55.000000000 +0100
++++ /tmp/bytesex.h 2004-07-27 21:40:30.502635352 +0100
+@@ -9,6 +9,7 @@
+
+ #if defined(__i386__) \
+ || defined(__alpha__) \
++ || defined(__x86_64__) \
+ || (defined(__mips__) && (defined(MIPSEL) || defined (__MIPSEL__)))
+ #define BYTE_ORDER_LITTLE_ENDIAN
+ #elif defined(__mc68000__) \
diff --git a/net-analyzer/hping/hping-2.0.0_rc3.ebuild b/net-analyzer/hping/hping-2.0.0_rc3.ebuild
index 8bbc3757057e..94557d45aad7 100644
--- a/net-analyzer/hping/hping-2.0.0_rc3.ebuild
+++ b/net-analyzer/hping/hping-2.0.0_rc3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/hping/hping-2.0.0_rc3.ebuild,v 1.8 2004/07/23 01:10:26 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/hping/hping-2.0.0_rc3.ebuild,v 1.9 2004/07/27 20:48:32 malc Exp $
inherit eutils
@@ -20,6 +20,7 @@ S="${WORKDIR}/${MY_P//\.[0-9]}"
src_compile() {
./configure || die
+ epatch ${FILESDIR}/amd64-header-fix.patch
if use debug
then