summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-02-12 16:08:09 +0000
committerJeroen Roovers <jer@gentoo.org>2010-02-12 16:08:09 +0000
commitaaa600906d7283109a978ddcfafc92ff153572ae (patch)
treec3c118c7d28bfd6c2022f7445a8733ea12944921 /net-analyzer/gnu-netcat
parentFix timestamp output thanks to Mirek Kratochvil and Oleg Gawriloff (bug #2494... (diff)
downloadgentoo-2-aaa600906d7283109a978ddcfafc92ff153572ae.tar.gz
gentoo-2-aaa600906d7283109a978ddcfafc92ff153572ae.tar.bz2
gentoo-2-aaa600906d7283109a978ddcfafc92ff153572ae.zip
Describe --close option in man page thanks to Christopher Head (bug #252227).
(Portage version: 2.2_rc62/cvs/Linux i686)
Diffstat (limited to 'net-analyzer/gnu-netcat')
-rw-r--r--net-analyzer/gnu-netcat/ChangeLog11
-rw-r--r--net-analyzer/gnu-netcat/files/gnu-netcat-close.patch16
-rw-r--r--net-analyzer/gnu-netcat/gnu-netcat-0.7.1-r2.ebuild39
3 files changed, 64 insertions, 2 deletions
diff --git a/net-analyzer/gnu-netcat/ChangeLog b/net-analyzer/gnu-netcat/ChangeLog
index fea3d7048cfc..592bdf641e6b 100644
--- a/net-analyzer/gnu-netcat/ChangeLog
+++ b/net-analyzer/gnu-netcat/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/gnu-netcat
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/gnu-netcat/ChangeLog,v 1.18 2009/09/23 18:18:55 patrick Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/gnu-netcat/ChangeLog,v 1.19 2010/02/12 16:08:08 jer Exp $
+
+*gnu-netcat-0.7.1-r2 (12 Feb 2010)
+
+ 12 Feb 2010; Jeroen Roovers <jer@gentoo.org> +gnu-netcat-0.7.1-r2.ebuild,
+ +files/gnu-netcat-close.patch:
+ Describe --close option in man page thanks to Christopher Head (bug
+ #252227).
23 Sep 2009; Patrick Lauer <patrick@gentoo.org>
gnu-netcat-0.7.1-r1.ebuild:
diff --git a/net-analyzer/gnu-netcat/files/gnu-netcat-close.patch b/net-analyzer/gnu-netcat/files/gnu-netcat-close.patch
new file mode 100644
index 000000000000..5c3e4fae136d
--- /dev/null
+++ b/net-analyzer/gnu-netcat/files/gnu-netcat-close.patch
@@ -0,0 +1,16 @@
+--- netcat-0.7.1.org/doc/netcat.1 2004-01-11 21:48:18.000000000 +0100
++++ netcat-0.7.1/doc/netcat.1 2010-02-12 17:03:02.000000000 +0100
+@@ -256,6 +256,13 @@
+ source address for the connecting socket.
+ .Sh "Advanced Options"
+ .IX Subsection "Advanced Options"
++.IP "\fB\-c" 4
++.IX Item "-c"
++.PD 0
++.IP "\fB\-\-close" 4
++.IX Item "--close"
++.PD
++closes connection on EOF from stdin.
+ .IP "\fB\-i \s-1SECS\s0\fR" 4
+ .IX Item "-i SECS"
+ .PD 0
diff --git a/net-analyzer/gnu-netcat/gnu-netcat-0.7.1-r2.ebuild b/net-analyzer/gnu-netcat/gnu-netcat-0.7.1-r2.ebuild
new file mode 100644
index 000000000000..0a5372f5fab6
--- /dev/null
+++ b/net-analyzer/gnu-netcat/gnu-netcat-0.7.1-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/gnu-netcat/gnu-netcat-0.7.1-r2.ebuild,v 1.1 2010/02/12 16:08:08 jer Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="the GNU network swiss army knife"
+HOMEPAGE="http://netcat.sourceforge.net/"
+SRC_URI="mirror://sourceforge/netcat/netcat-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="nls debug"
+
+DEPEND=""
+
+S=${WORKDIR}/netcat-${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-flagcount.patch
+ epatch "${FILESDIR}"/${PN}-close.patch
+}
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable debug) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "emake install failed"
+ rm "${D}"/usr/bin/nc
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}