summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-05-29 20:03:14 +0000
committerTim Harder <radhermit@gentoo.org>2012-05-29 20:03:14 +0000
commit52be68a4e3de474fe406c0e84c2e8cae1bdf42d3 (patch)
treec098938dd3fdb0ffb959f052e204893c2b51017f /net-analyzer/fping
parentMarking pyro-3.16 ppc for bug 416255 (diff)
downloadgentoo-2-52be68a4e3de474fe406c0e84c2e8cae1bdf42d3.tar.gz
gentoo-2-52be68a4e3de474fe406c0e84c2e8cae1bdf42d3.tar.bz2
gentoo-2-52be68a4e3de474fe406c0e84c2e8cae1bdf42d3.zip
Re-add fping-2.4 for net-analyzer/zabbix.
(Portage version: 2.2.0_alpha108/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'net-analyzer/fping')
-rw-r--r--net-analyzer/fping/ChangeLog6
-rw-r--r--net-analyzer/fping/files/fping-2.4_beta2_p161-min-time.patch47
-rw-r--r--net-analyzer/fping/fping-2.4_beta2_p161-r1.ebuild59
3 files changed, 111 insertions, 1 deletions
diff --git a/net-analyzer/fping/ChangeLog b/net-analyzer/fping/ChangeLog
index 300ba5ca7019..af2320c0fd47 100644
--- a/net-analyzer/fping/ChangeLog
+++ b/net-analyzer/fping/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/fping
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fping/ChangeLog,v 1.49 2012/05/29 10:35:16 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fping/ChangeLog,v 1.50 2012/05/29 20:03:14 radhermit Exp $
+
+ 29 May 2012; Tim Harder <radhermit@gentoo.org>
+ +fping-2.4_beta2_p161-r1.ebuild, +files/fping-2.4_beta2_p161-min-time.patch:
+ Re-add fping-2.4 for net-analyzer/zabbix.
29 May 2012; Tim Harder <radhermit@gentoo.org>
-fping-2.4_beta2_p161-r1.ebuild, -files/fping-2.4_beta2_p161-min-time.patch,
diff --git a/net-analyzer/fping/files/fping-2.4_beta2_p161-min-time.patch b/net-analyzer/fping/files/fping-2.4_beta2_p161-min-time.patch
new file mode 100644
index 000000000000..5e5ccd40fc2a
--- /dev/null
+++ b/net-analyzer/fping/files/fping-2.4_beta2_p161-min-time.patch
@@ -0,0 +1,47 @@
+--- old/fping.c 2010-08-24 16:59:38.947000447 +0100
++++ new/fping.c 2010-08-24 16:55:52.101000443 +0100
+@@ -25,6 +25,7 @@
+ * Original author: Roland Schemers <schemers@stanford.edu>
+ * IPv6 Support: Jeroen Massar <jeroen@unfix.org / jeroen@ipng.nl>
+ * Bugfixes, byte order & senseful seq.-numbers: Stephan Fuhrmann (stephan.fuhrmann AT 1und1.de)
++ * Fixes: min_reply_i in splits and compiler warning. Alex Ghoth (alex AT ghoth.net)
+ *
+ *
+ * RCS header information no longer used. It has been moved to the
+@@ -743,7 +744,7 @@
+
+ if( ( ping_data_size > MAX_PING_DATA ) || ( ping_data_size < MIN_PING_DATA ) )
+ {
+- fprintf( stderr, "%s: data size %u not valid, must be between %u and %u\n",
++ fprintf( stderr, "%s: data size %u not valid, must be between %lu and %u\n",
+ prog, ping_data_size, MIN_PING_DATA, MAX_PING_DATA );
+ usage();
+
+@@ -1112,7 +1113,7 @@
+ ht = timeval_diff( &current_time, &cursor->last_send_time );
+
+ if( report_interval && ( loop_flag || count_flag ) &&
+- ( timeval_diff ( &current_time, &last_report_time ) > report_interval ) )
++ ( timeval_diff ( &current_time, &last_report_time ) >= report_interval ) )
+ {
+ print_per_system_splits();
+ gettimeofday( &current_time, &tz );
+@@ -1487,8 +1488,8 @@
+ }/* IF */
+
+ fprintf( stderr, "\n" );
+- h->num_sent_i = h->num_recv_i = h->max_reply_i =
+- h->min_reply_i = h->total_time_i = 0;
++ h->num_sent_i = h->num_recv_i = h->max_reply_i = h->total_time_i = 0;
++ h->min_reply_i = 10000000;
+
+ }/* FOR */
+
+@@ -2377,6 +2378,7 @@
+ p->timeout = timeout;
+ p->running = 1;
+ p->min_reply = 10000000;
++ p->min_reply_i = 10000000;
+
+ if( strlen( p->host ) > max_hostname_len )
+ max_hostname_len = strlen( p->host );
diff --git a/net-analyzer/fping/fping-2.4_beta2_p161-r1.ebuild b/net-analyzer/fping/fping-2.4_beta2_p161-r1.ebuild
new file mode 100644
index 000000000000..107f0686ef9e
--- /dev/null
+++ b/net-analyzer/fping/fping-2.4_beta2_p161-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fping/fping-2.4_beta2_p161-r1.ebuild,v 1.9 2012/05/29 20:03:14 radhermit Exp $
+
+EAPI="2"
+
+inherit autotools eutils flag-o-matic
+
+DESCRIPTION="A utility to ping multiple hosts at once"
+SRC_URI="
+ mirror://debian/pool/main/f/${PN}/${PN}_2.4b2-to-ipv6.orig.tar.gz
+ mirror://debian/pool/main/f/${PN}/${PN}_2.4b2-to-ipv6-16.1.diff.gz
+ "
+HOMEPAGE="http://fping.sourceforge.net/ http://packages.qa.debian.org/f/fping.html"
+
+SLOT="0"
+LICENSE="fping"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="ipv6"
+
+S="${WORKDIR}/fping-2.4b2_to-ipv6"
+
+src_prepare() {
+ epatch \
+ "${WORKDIR}"/fping_2.4b2-to-ipv6-16.1.diff \
+ "${FILESDIR}"/${P}-min-time.patch
+ eautoreconf
+
+ if use ipv6; then
+ cp -a "${S}" "${S}-6"
+ fi
+}
+
+src_configure() {
+ econf || die "econf failed"
+ if use ipv6; then
+ cd "${S}-6"
+ append-flags -DIPV6
+ econf || die "econf failed"
+ fi
+}
+
+src_compile() {
+ emake || die "econf failed"
+ if use ipv6; then
+ cd "${S}-6"
+ emake || die "econf failed"
+ fi
+}
+
+src_install () {
+ dosbin "${S}"/${PN} || die "Failed to install fping."
+ if use ipv6; then
+ newsbin "${S}"-6/fping fping6 || die "Failed to install fping."
+ fi
+ fperms 4555 /usr/sbin/fping /usr/sbin/fping6 #241930
+ doman fping.8
+ dodoc ChangeLog README
+}