summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaphaël Marichez <falco@gentoo.org>2007-07-05 22:49:55 +0000
committerRaphaël Marichez <falco@gentoo.org>2007-07-05 22:49:55 +0000
commitf529502d2d6d802f2efa1e1fc15c9d9b37638301 (patch)
treea98c6e44a0ce161d14067621f110a6c1a6bc7e1b /net-analyzer/fail2ban
parentStable on amd64 wrt bug #174939 (diff)
downloadgentoo-2-f529502d2d6d802f2efa1e1fc15c9d9b37638301.tar.gz
gentoo-2-f529502d2d6d802f2efa1e1fc15c9d9b37638301.tar.bz2
gentoo-2-f529502d2d6d802f2efa1e1fc15c9d9b37638301.zip
Conditional elogs for upgrading from 0.6 to 0.8, bug 183743
(Portage version: 2.1.2.7)
Diffstat (limited to 'net-analyzer/fail2ban')
-rw-r--r--net-analyzer/fail2ban/ChangeLog6
-rw-r--r--net-analyzer/fail2ban/fail2ban-0.8.0-r1.ebuild24
-rw-r--r--net-analyzer/fail2ban/fail2ban-0.8.0.ebuild24
3 files changed, 31 insertions, 23 deletions
diff --git a/net-analyzer/fail2ban/ChangeLog b/net-analyzer/fail2ban/ChangeLog
index d73c2b137d59..561e497d6b74 100644
--- a/net-analyzer/fail2ban/ChangeLog
+++ b/net-analyzer/fail2ban/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/fail2ban
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/ChangeLog,v 1.33 2007/06/23 19:19:32 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/ChangeLog,v 1.34 2007/07/05 22:49:55 falco Exp $
+
+ 05 Jul 2007; Raphael Marichez <falco@gentoo.org> fail2ban-0.8.0.ebuild,
+ fail2ban-0.8.0-r1.ebuild:
+ Conditional elogs for upgrading from 0.6 to 0.8, bug 183743
23 Jun 2007; Christoph Mende <angelos@gentoo.org>
fail2ban-0.8.0-r1.ebuild:
diff --git a/net-analyzer/fail2ban/fail2ban-0.8.0-r1.ebuild b/net-analyzer/fail2ban/fail2ban-0.8.0-r1.ebuild
index d67af0d4ff33..c347f3239888 100644
--- a/net-analyzer/fail2ban/fail2ban-0.8.0-r1.ebuild
+++ b/net-analyzer/fail2ban/fail2ban-0.8.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/fail2ban-0.8.0-r1.ebuild,v 1.5 2007/06/23 19:19:32 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/fail2ban-0.8.0-r1.ebuild,v 1.6 2007/07/05 22:49:55 falco Exp $
inherit distutils
@@ -32,16 +32,18 @@ src_install() {
}
pkg_postinst() {
- elog
- elog "Configuration files are now in /etc/fail2ban/"
- elog "You probably have to manually update your configuration"
- elog "files before restarting Fail2ban!"
- elog
- elog "Fail2ban is not installed under /usr/lib anymore. The"
- elog "new location is under /usr/share."
- elog
- elog "If you are upgrading from version 0.6.x see:"
- elog "http://www.fail2ban.org/wiki/index.php/HOWTO_Upgrade_from_0.6_to_0.8"
+ if has_version '<net-analyzer/fail2ban-0.7' ; then
+ elog
+ elog "Configuration files are now in /etc/fail2ban/"
+ elog "You probably have to manually update your configuration"
+ elog "files before restarting Fail2ban!"
+ elog
+ elog "Fail2ban is not installed under /usr/lib anymore. The"
+ elog "new location is under /usr/share."
+ elog
+ elog "You are upgrading from version 0.6.x, please see:"
+ elog "http://www.fail2ban.org/wiki/index.php/HOWTO_Upgrade_from_0.6_to_0.8"
+ fi
}
pkg_setup() {
diff --git a/net-analyzer/fail2ban/fail2ban-0.8.0.ebuild b/net-analyzer/fail2ban/fail2ban-0.8.0.ebuild
index e950e7e6da68..acc21b243c7c 100644
--- a/net-analyzer/fail2ban/fail2ban-0.8.0.ebuild
+++ b/net-analyzer/fail2ban/fail2ban-0.8.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/fail2ban-0.8.0.ebuild,v 1.2 2007/06/18 12:34:52 falco Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/fail2ban-0.8.0.ebuild,v 1.3 2007/07/05 22:49:55 falco Exp $
inherit distutils
@@ -26,16 +26,18 @@ src_install() {
}
pkg_postinst() {
- elog
- elog "Configuration files are now in /etc/fail2ban/"
- elog "You probably have to manually update your configuration"
- elog "files before restarting Fail2ban!"
- elog
- elog "Fail2ban is not installed under /usr/lib anymore. The"
- elog "new location is under /usr/share."
- elog
- elog "If you are upgrading from version 0.6.x see:"
- elog "http://www.fail2ban.org/wiki/index.php/HOWTO_Upgrade_from_0.6_to_0.8"
+ if has_version '<net-analyzer/fail2ban-0.7' ; then
+ elog
+ elog "Configuration files are now in /etc/fail2ban/"
+ elog "You probably have to manually update your configuration"
+ elog "files before restarting Fail2ban!"
+ elog
+ elog "Fail2ban is not installed under /usr/lib anymore. The"
+ elog "new location is under /usr/share."
+ elog
+ elog "You are upgrading from version 0.6.x, please see:"
+ elog "http://www.fail2ban.org/wiki/index.php/HOWTO_Upgrade_from_0.6_to_0.8"
+ fi
}
pkg_setup() {