summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2007-04-12 19:32:37 +0000
committerMarkus Ullmann <jokey@gentoo.org>2007-04-12 19:32:37 +0000
commite588cbccf2172b63e09f92b678f8cda65ed7eab9 (patch)
treee19f2c69357a9eec85b24d75bbfaebd314ccac0a /net-analyzer/echoping/echoping-6.0.1.ebuild
parentia64 + x86 stable wrt bug 174216 (diff)
downloadgentoo-2-e588cbccf2172b63e09f92b678f8cda65ed7eab9.tar.gz
gentoo-2-e588cbccf2172b63e09f92b678f8cda65ed7eab9.tar.bz2
gentoo-2-e588cbccf2172b63e09f92b678f8cda65ed7eab9.zip
Version bump wrt bug #172453 thanks to Stephane Bortzmeyer
(Portage version: 2.1.2.3)
Diffstat (limited to 'net-analyzer/echoping/echoping-6.0.1.ebuild')
-rw-r--r--net-analyzer/echoping/echoping-6.0.1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/net-analyzer/echoping/echoping-6.0.1.ebuild b/net-analyzer/echoping/echoping-6.0.1.ebuild
new file mode 100644
index 000000000000..076e5aa8b1f5
--- /dev/null
+++ b/net-analyzer/echoping/echoping-6.0.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/echoping/echoping-6.0.1.ebuild,v 1.1 2007/04/12 19:32:37 jokey Exp $
+
+inherit eutils
+
+DESCRIPTION="echoping is a small program to test performances of remote servers"
+HOMEPAGE="http://echoping.sourceforge.net/"
+SRC_URI="mirror://sourceforge/echoping/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnutls http icp idn priority smtp ssl tos postgres ldap"
+
+DEPEND="gnutls? ( >=net-libs/gnutls-1.0.17 )
+ ssl? ( >=dev-libs/openssl-0.9.7d )
+ idn? ( net-dns/libidn )
+ postgres? ( dev-db/postgresql )
+ ldap? ( net-nds/openldap )"
+
+pkg_setup() {
+ # bug 141782 - conflicting USE flags - ssl and gnutls
+ if use ssl && use gnutls ; then
+ eerror "You cannot emerge net-analyzer/echoping with both"
+ eerror "ssl and gnutls USE flags set. Please choose one."
+ die "echoping cannot use both ssl and gnutls at once"
+ fi
+}
+
+src_compile() {
+ econf \
+ --config-cache \
+ --disable-ttcp \
+ $(use_with gnutls) \
+ $(use_enable http) \
+ $(use_enable icp) \
+ $(use_with idn libidn) \
+ $(use_enable smtp) \
+ $(use_enable tos) \
+ $(use_enable priority) \
+ $(use_with ssl) || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+
+ # They are not installed by make install
+ dodoc README AUTHORS ChangeLog DETAILS NEWS TODO
+}