summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2005-04-02 22:06:01 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2005-04-02 22:06:01 +0000
commit2c7c8a0d5360d9e153854121e319683ff3d502bf (patch)
treea0920ab0159ab1f8daceb9d10556b519adab76c8 /net-analyzer/cheops-ng
parentdev-java/oro moved to dev-java/jakarta-oro (diff)
downloadgentoo-2-2c7c8a0d5360d9e153854121e319683ff3d502bf.tar.gz
gentoo-2-2c7c8a0d5360d9e153854121e319683ff3d502bf.tar.bz2
gentoo-2-2c7c8a0d5360d9e153854121e319683ff3d502bf.zip
better gcc-3.4 fix
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-analyzer/cheops-ng')
-rw-r--r--net-analyzer/cheops-ng/ChangeLog9
-rw-r--r--net-analyzer/cheops-ng/Manifest3
-rw-r--r--net-analyzer/cheops-ng/cheops-ng-0.1.13-r1.ebuild65
-rw-r--r--net-analyzer/cheops-ng/files/cheops-ng-0.1.13-printf.diff69
-rw-r--r--net-analyzer/cheops-ng/files/digest-cheops-ng-0.1.13-r11
5 files changed, 146 insertions, 1 deletions
diff --git a/net-analyzer/cheops-ng/ChangeLog b/net-analyzer/cheops-ng/ChangeLog
index f5a23f2b86cf..c7754e295e57 100644
--- a/net-analyzer/cheops-ng/ChangeLog
+++ b/net-analyzer/cheops-ng/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/cheops-ng
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cheops-ng/ChangeLog,v 1.2 2005/03/31 22:12:17 vanquirius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cheops-ng/ChangeLog,v 1.3 2005/04/02 22:06:01 vanquirius Exp $
+
+*cheops-ng-0.1.13-r1 (02 Apr 2005)
+
+ 02 Apr 2005; Marcelo Goes <vanquirius@gentoo.org>
+ +files/cheops-ng-0.1.13-printf.diff, +cheops-ng-0.1.13-r1.ebuild:
+ Nicer fix to allow gcc-3.4 to work without discarding debug messages. Thanks
+ to dragonheart for pointing out this issue and how to solve it.
31 Mar 2005; Marcelo Goes <vanquirius@gentoo.org> +metadata.xml,
cheops-ng-0.1.13.ebuild:
diff --git a/net-analyzer/cheops-ng/Manifest b/net-analyzer/cheops-ng/Manifest
index 2175d07803a8..52357602d224 100644
--- a/net-analyzer/cheops-ng/Manifest
+++ b/net-analyzer/cheops-ng/Manifest
@@ -1,5 +1,8 @@
MD5 02dc61cfada1a07f16394594e574cf4f cheops-ng-0.1.13.ebuild 1853
MD5 84849986e14e3f220b1969371f8daa75 ChangeLog 1076
MD5 5731c4fdc13f68a2dccaacfbc4fbc611 metadata.xml 257
+MD5 9ecfe6d0f1a8d5bac5f4d66f571dbc78 cheops-ng-0.1.13-r1.ebuild 1786
+MD5 1bd20cac4d709f4fd39d7c308daad7ab files/cheops-ng-0.1.13-printf.diff 2328
MD5 76b3ed702ddc4890c7035d83a27aa42b files/adns-gcc34.patch 433
+MD5 777b8b1d7bdb5928dd24e00509312c01 files/digest-cheops-ng-0.1.13-r1 65
MD5 777b8b1d7bdb5928dd24e00509312c01 files/digest-cheops-ng-0.1.13 65
diff --git a/net-analyzer/cheops-ng/cheops-ng-0.1.13-r1.ebuild b/net-analyzer/cheops-ng/cheops-ng-0.1.13-r1.ebuild
new file mode 100644
index 000000000000..951efa2fe49d
--- /dev/null
+++ b/net-analyzer/cheops-ng/cheops-ng-0.1.13-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cheops-ng/cheops-ng-0.1.13-r1.ebuild,v 1.1 2005/04/02 22:06:01 vanquirius Exp $
+
+inherit eutils
+
+DESCRIPTION="Cheops-ng is a Network management tool for mapping and monitoring your network"
+HOMEPAGE="http://cheops-ng.sourceforge.net/"
+SRC_URI="mirror://sourceforge/cheops-ng/${P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="debug"
+DEPEND=">=net-analyzer/nmap-3.27-r1
+ =x11-libs/gtk+-1.2*
+ >=dev-libs/libxml-1.8.17-r2
+ >=gnome-base/gnome-libs-1.4.2
+ >=media-libs/imlib-1.9.14-r1
+ >=dev-libs/glib-1.2.10-r5
+ media-libs/libpng"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-printf.diff
+ cd adns-1.0
+ epatch ${FILESDIR}/adns-gcc34.patch
+}
+
+src_compile() {
+ # disable/enable debug
+ if use debug; then
+ sed -i -e 's/^\/\/#define DEBUG/#define DEBUG/g' ./*.c || die "sed failed"
+ sed -i -e 's/^\/\/#define DEBUG/#define DEBUG/g' ./*.h || die "sed failed"
+
+ else
+ # we need to disable the noisy nmap debug and any other
+ sed -i -e 's/^#define DEBUG/\/\/#define DEBUG/g' ./*.c || die "sed failed"
+ sed -i -e 's/^#define DEBUG/\/\/#define DEBUG/g' ./*.h || die "sed failed"
+ fi
+
+ # First we need to configure adns
+ cd adns-1.0
+ econf || die
+ cd ..
+ # Now we configure cheops-ng
+ econf || die
+
+ # Fix for the gpl.c file that adds \ at the end of COPYING puts the result
+ # in toto and change the reference to the file in Makefile.
+ sed \
+ -e 's/$/ \\/g' \
+ -e 's/"/""/g' \
+ COPYING > toto || die "sed failed"
+ sed -i \
+ -e '146s/\\""/\\"\\\\"/g' \
+ -e 's/COPYING/toto/g' \
+ Makefile || die "sed failed"
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ dodoc AUTHORS COPYING README NEWS ReleaseNotes doc/*.txt
+}
diff --git a/net-analyzer/cheops-ng/files/cheops-ng-0.1.13-printf.diff b/net-analyzer/cheops-ng/files/cheops-ng-0.1.13-printf.diff
new file mode 100644
index 000000000000..06ea9c7dd006
--- /dev/null
+++ b/net-analyzer/cheops-ng/files/cheops-ng-0.1.13-printf.diff
@@ -0,0 +1,69 @@
+--- agent-nmapxml.c~ 2005-04-02 18:41:38.000000000 -0300
++++ agent-nmapxml.c 2005-04-02 18:47:44.000000000 -0300
+@@ -466,7 +466,7 @@
+ strcat(cmd, " -p ");
+ strcat(cmd, port_range);
+ }
+- DEBUG(printf(__FUNCTION__ "(): scanning %s using '%s'\n", ip, cmd));
++ DEBUG(printf("%s(): scanning %s using '%s'\n", __FUNCTION__, ip, cmd));
+ pfp = popen(cmd, "r");
+ if(pfp == NULL)
+ {
+--- cheops-monitoring.c~ 2005-04-02 18:41:56.000000000 -0300
++++ cheops-monitoring.c 2005-04-02 18:52:43.000000000 -0300
+@@ -143,7 +143,7 @@
+ {
+ if(monitoring_node_find_toplevel(m->id))
+ {
+- DEBUG(printf(__FUNCTION__"(): monitoring node id=%d already in list\n", m->id));
++ DEBUG(printf("%s(): monitoring node id=%d already in list\n", __FUNCTION__, m->id));
+ return(1);
+ }
+ sprintf(buffer, "%d", m->id);
+@@ -168,7 +168,7 @@
+ {
+ if(monitoring_node_find(parent, child->id))
+ {
+- DEBUG(printf(__FUNCTION__"(): monitoring node (%d) already in parent's (%d) list\n", child->id, parent->id));
++ DEBUG(printf("%s(): monitoring node (%d) already in parent's (%d) list\n", __FUNCTION__, child->id, parent->id));
+ return(1);
+ }
+ sprintf(buffer, "%s.%d", parent->path, child->id);
+--- gui-settings.c~ 2005-04-02 18:44:28.000000000 -0300
++++ gui-settings.c 2005-04-02 18:51:40.000000000 -0300
+@@ -229,7 +229,7 @@
+ options_os_scan_flags |= OS_SCAN_OPTION_STEALTH_NULL;
+ else
+ {
+- printf(__FUNCTION__"(): you should not see this message!\n");
++ printf("%s(): you should not see this message!\n", __FUNCTION__);
+ options_os_scan_flags |= OS_SCAN_OPTION_TCP_CONNECT_SCAN;
+ }
+
+@@ -250,7 +250,7 @@
+ options_os_scan_flags |= OS_SCAN_OPTION_TIMIMG_INSANE;
+ else
+ {
+- printf(__FUNCTION__"(TIMING): you should not see this message!\n");
++ printf("%s(TIMING): you should not see this message!\n", __FUNCTION__);
+ options_os_scan_flags |= OS_SCAN_OPTION_TIMIMG_NORMAL;
+ }
+
+@@ -347,7 +347,7 @@
+ ;
+ else
+ {
+- printf(__FUNCTION__"(): you should not see this message!\n");
++ printf("%s(): you should not see this message!\n", __FUNCTION__);
+ temp = TCP_SCAN_DEFAULT;
+ }
+
+@@ -368,7 +368,7 @@
+ ;
+ else
+ {
+- printf(__FUNCTION__"(): you should not see this message!\n");
++ printf("%s(): you should not see this message!\n", __FUNCTION__);
+ temp = TIMING_SCAN_DEFAULT;
+ }
+
diff --git a/net-analyzer/cheops-ng/files/digest-cheops-ng-0.1.13-r1 b/net-analyzer/cheops-ng/files/digest-cheops-ng-0.1.13-r1
new file mode 100644
index 000000000000..e89972fd22a0
--- /dev/null
+++ b/net-analyzer/cheops-ng/files/digest-cheops-ng-0.1.13-r1
@@ -0,0 +1 @@
+MD5 31686c9c3abeddd90f113df4b7c9a400 cheops-ng-0.1.13.tgz 694326