summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2005-06-16 03:14:29 +0000
committerNed Ludd <solar@gentoo.org>2005-06-16 03:14:29 +0000
commitfa20fbdea049faee6d88c7a775a0b9ece6da3bfa (patch)
tree5a09fda09c837b34192e45166616ec549a018b89 /net-analyzer/cacti
parentInitial commit, BSD version of tar, usable also on Linux. Faster and simpler,... (diff)
downloadgentoo-2-fa20fbdea049faee6d88c7a775a0b9ece6da3bfa.tar.gz
gentoo-2-fa20fbdea049faee6d88c7a775a0b9ece6da3bfa.tar.bz2
gentoo-2-fa20fbdea049faee6d88c7a775a0b9ece6da3bfa.zip
- added cacti-0.8.6e but masked by request.
Diffstat (limited to 'net-analyzer/cacti')
-rw-r--r--net-analyzer/cacti/ChangeLog7
-rw-r--r--net-analyzer/cacti/Manifest14
-rw-r--r--net-analyzer/cacti/cacti-0.8.6e.ebuild59
-rw-r--r--net-analyzer/cacti/files/digest-cacti-0.8.6e1
4 files changed, 69 insertions, 12 deletions
diff --git a/net-analyzer/cacti/ChangeLog b/net-analyzer/cacti/ChangeLog
index b50527870b18..5e152fe2a372 100644
--- a/net-analyzer/cacti/ChangeLog
+++ b/net-analyzer/cacti/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/cacti
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.43 2005/05/02 11:23:48 eldad Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.44 2005/06/16 03:14:29 solar Exp $
+
+*cacti-0.8.6e (15 Jun 2005)
+
+ 15 Jun 2005; <solar@gentoo.org> +cacti-0.8.6e.ebuild:
+ - added cacti-0.8.6e masked by request.
02 May 2005; Eldad Zack <eldad@gentoo.org> files/postinstall-en.txt,
cacti-0.8.6b.ebuild, cacti-0.8.6c.ebuild, cacti-0.8.6d.ebuild:
diff --git a/net-analyzer/cacti/Manifest b/net-analyzer/cacti/Manifest
index 955d860f9158..3465b75fce3c 100644
--- a/net-analyzer/cacti/Manifest
+++ b/net-analyzer/cacti/Manifest
@@ -1,19 +1,11 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 eb29792b90b350f2cd49623037fe5d42 cacti-0.8.6c.ebuild 1332
+MD5 6cd2602542b2bdc775e4efc9336464d2 cacti-0.8.6e.ebuild 1348
MD5 678f83d4332c7064ed3c3b9f05887a57 cacti-0.8.6b.ebuild 1332
-MD5 3ee120fba5ea8db306180edff5530f36 ChangeLog 6006
+MD5 700100c86f25e565e56fd8898acae82f ChangeLog 6134
MD5 9683bb7323c40d69b48d54ad0eb169ed metadata.xml 221
MD5 8aace6320fe87eaeb6a06eb4986751aa cacti-0.8.6d.ebuild 1332
MD5 cf35c7601be5a748b851ae64487871f2 files/postinstall-en.txt 2062
MD5 5415dc0df13fd1528eb90acce7f44989 files/digest-cacti-0.8.6b 65
MD5 92214d64b7a546022d81ca37cb137262 files/digest-cacti-0.8.6c 65
MD5 e77a5f6b9f7c97f061348312cd9e1004 files/digest-cacti-0.8.6d 65
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.2.6 (GNU/Linux)
-
-iD8DBQFCdg3XT+MN7JbqCpMRAjplAKCAMJB7mqHyex5kc2WoOSLvmHqCyACfbjWY
-Hu6VuNRnpqjkWKIcHWtsqy0=
-=32hf
------END PGP SIGNATURE-----
+MD5 fe719c4967de04070d441c0e6974c6b7 files/digest-cacti-0.8.6e 65
diff --git a/net-analyzer/cacti/cacti-0.8.6e.ebuild b/net-analyzer/cacti/cacti-0.8.6e.ebuild
new file mode 100644
index 000000000000..8ede438a3852
--- /dev/null
+++ b/net-analyzer/cacti/cacti-0.8.6e.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.6e.ebuild,v 1.1 2005/06/16 03:14:29 solar Exp $
+
+inherit eutils webapp
+
+DESCRIPTION="Cacti is a complete frontend to rrdtool"
+HOMEPAGE="http://www.cacti.net/"
+SRC_URI="http://www.cacti.net/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+#KEYWORDS="~x86 ~ppc sparc ~alpha ~amd64"
+KEYWORDS="-*"
+IUSE="snmp"
+
+DEPEND=""
+
+# TODO: RDEPEND Not just apache... but there's no virtual/webserver (yet)
+
+RDEPEND="net-www/apache
+ snmp? ( net-analyzer/net-snmp )
+ net-analyzer/rrdtool
+ dev-db/mysql
+ virtual/cron
+ dev-php/php
+ dev-php/mod_php"
+
+pkg_setup() {
+ webapp_pkg_setup
+ built_with_use dev-php/php mysql || \
+ die "dev-php/php must be compiled with USE=mysql"
+ built_with_use dev-php/mod_php mysql || \
+ die "dev-php/mod_php must be compiled with USE=mysql"
+}
+
+src_compile() {
+ einfo "Nothing to compile."
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc LICENSE
+ rm LICENSE README
+
+ dodoc docs/{CHANGELOG,CONTRIB,INSTALL,README,REQUIREMENTS,UPGRADE}
+ rm -rf docs
+
+ edos2unix `find -type f -name '*.php'`
+
+ dodir ${MY_HTDOCSDIR}
+ cp -r . ${D}${MY_HTDOCSDIR}
+
+ webapp_configfile ${MY_HTDOCSDIR}/include/config.php
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+
+ webapp_src_install
+}
+
diff --git a/net-analyzer/cacti/files/digest-cacti-0.8.6e b/net-analyzer/cacti/files/digest-cacti-0.8.6e
new file mode 100644
index 000000000000..ed97bd1d688e
--- /dev/null
+++ b/net-analyzer/cacti/files/digest-cacti-0.8.6e
@@ -0,0 +1 @@
+MD5 ff43af431f2934f8b50267a307280a72 cacti-0.8.6e.tar.gz 1062006