summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-06-12 05:47:07 +0000
committerJeroen Roovers <jer@gentoo.org>2015-06-12 05:47:07 +0000
commitdb8dab965ec4ade8f522de2e5e5ae97157dbfaed (patch)
treedf9af8a1e2a825c08fe05678cfb941e8490feb94 /net-analyzer/cacti
parentMark ~hppa ~ppc64 (bug #539126). (diff)
downloadgentoo-2-db8dab965ec4ade8f522de2e5e5ae97157dbfaed.tar.gz
gentoo-2-db8dab965ec4ade8f522de2e5e5ae97157dbfaed.tar.bz2
gentoo-2-db8dab965ec4ade8f522de2e5e5ae97157dbfaed.zip
Version bump (bug #551728).
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer/cacti')
-rw-r--r--net-analyzer/cacti/ChangeLog9
-rw-r--r--net-analyzer/cacti/cacti-0.8.8d.ebuild60
2 files changed, 67 insertions, 2 deletions
diff --git a/net-analyzer/cacti/ChangeLog b/net-analyzer/cacti/ChangeLog
index 08f9d8bc0148..a2e5837b96db 100644
--- a/net-analyzer/cacti/ChangeLog
+++ b/net-analyzer/cacti/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/cacti
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.200 2014/07/15 16:31:34 jer Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.201 2015/06/12 05:47:07 jer Exp $
+
+*cacti-0.8.8d (12 Jun 2015)
+
+ 12 Jun 2015; Jeroen Roovers <jer@gentoo.org> +cacti-0.8.8d.ebuild:
+ Version bump (bug #551728).
15 Jul 2014; Jeroen Roovers <jer@gentoo.org> cacti-0.8.8b-r2.ebuild:
Set USE=graph dependency on net-analyzer/rrdtool (bug #509682).
diff --git a/net-analyzer/cacti/cacti-0.8.8d.ebuild b/net-analyzer/cacti/cacti-0.8.8d.ebuild
new file mode 100644
index 000000000000..eaf5f1546790
--- /dev/null
+++ b/net-analyzer/cacti/cacti-0.8.8d.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.8d.ebuild,v 1.1 2015/06/12 05:47:07 jer Exp $
+
+EAPI=5
+
+inherit depend.php eutils webapp
+
+# Support for _p* in version.
+MY_P=${P/_p*/}
+
+DESCRIPTION="Cacti is a complete frontend to rrdtool"
+HOMEPAGE="http://www.cacti.net/"
+SRC_URI="http://www.cacti.net/downloads/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="snmp doc"
+
+need_httpd
+
+RDEPEND="
+ dev-lang/php[cli,mysql,session,sockets,xml]
+ dev-php/adodb
+ net-analyzer/rrdtool[graph]
+ virtual/cron
+ virtual/mysql
+ snmp? ( >=net-analyzer/net-snmp-5.2.0 )
+"
+
+src_prepare() {
+ sed -i -e \
+ 's:$config\["library_path"\] . "/adodb/adodb.inc.php":"adodb/adodb.inc.php":' \
+ "${S}"/include/global.php || die
+
+ rm -rf lib/adodb || die # don't use bundled adodb
+}
+
+src_compile() { :; }
+
+src_install() {
+ webapp_src_preinst
+
+ rm LICENSE README || die
+ dodoc docs/{CHANGELOG,CONTRIB,README,txt/manual.txt}
+ use doc && dohtml -r docs/html/
+ rm -rf docs
+
+ edos2unix `find -type f -name '*.php'`
+
+ dodir ${MY_HTDOCSDIR}
+ cp -r . "${D}"${MY_HTDOCSDIR}
+
+ webapp_serverowned ${MY_HTDOCSDIR}/rra
+ webapp_serverowned ${MY_HTDOCSDIR}/log/cacti.log
+ webapp_configfile ${MY_HTDOCSDIR}/include/config.php
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}