summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2007-11-03 18:53:23 +0000
committerPeter Volkov <pva@gentoo.org>2007-11-03 18:53:23 +0000
commit81b791e81fe3808714b628a1943e69688047db34 (patch)
tree2bf12f335ef96bc3a3162aaa421f02aa28093114 /net-analyzer/cacti
parentVersion bump. (diff)
downloadgentoo-2-81b791e81fe3808714b628a1943e69688047db34.tar.gz
gentoo-2-81b791e81fe3808714b628a1943e69688047db34.tar.bz2
gentoo-2-81b791e81fe3808714b628a1943e69688047db34.zip
Added patches from upstream, fix bug #194166, small changes in 0.8.6j-r6 to shut up repoman.
(Portage version: 2.1.3.16)
Diffstat (limited to 'net-analyzer/cacti')
-rw-r--r--net-analyzer/cacti/ChangeLog9
-rw-r--r--net-analyzer/cacti/cacti-0.8.6j-r6.ebuild4
-rw-r--r--net-analyzer/cacti/cacti-0.8.7-r1.ebuild93
-rw-r--r--net-analyzer/cacti/files/digest-cacti-0.8.7-r19
4 files changed, 111 insertions, 4 deletions
diff --git a/net-analyzer/cacti/ChangeLog b/net-analyzer/cacti/ChangeLog
index 2b9b7bd461d2..c21783003851 100644
--- a/net-analyzer/cacti/ChangeLog
+++ b/net-analyzer/cacti/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/cacti
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.112 2007/10/29 15:03:46 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.113 2007/11/03 18:53:22 pva Exp $
+
+*cacti-0.8.7-r1 (03 Nov 2007)
+
+ 03 Nov 2007; <pva@gentoo.org> cacti-0.8.6j-r6.ebuild,
+ +cacti-0.8.7-r1.ebuild:
+ Added patches from upstream, fix bug #194166, small changes in 0.8.6j-r6 to
+ shut up repoman.
*cacti-0.8.7 (29 Oct 2007)
diff --git a/net-analyzer/cacti/cacti-0.8.6j-r6.ebuild b/net-analyzer/cacti/cacti-0.8.6j-r6.ebuild
index a41ea256d27d..d3f78fd867b6 100644
--- a/net-analyzer/cacti/cacti-0.8.6j-r6.ebuild
+++ b/net-analyzer/cacti/cacti-0.8.6j-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.6j-r6.ebuild,v 1.11 2007/07/19 13:27:37 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.6j-r6.ebuild,v 1.12 2007/11/03 18:53:22 pva Exp $
inherit eutils webapp depend.apache depend.php
@@ -79,9 +79,7 @@ src_compile() {
src_install() {
webapp_src_preinst
- dodoc LICENSE
rm LICENSE README
-
dodoc docs/{CHANGELOG,CONTRIB,INSTALL,README,REQUIREMENTS,UPGRADE}
rm -rf docs
use bundled-adodb || rm -rf lib/adodb
diff --git a/net-analyzer/cacti/cacti-0.8.7-r1.ebuild b/net-analyzer/cacti/cacti-0.8.7-r1.ebuild
new file mode 100644
index 000000000000..4e1daf12b3ae
--- /dev/null
+++ b/net-analyzer/cacti/cacti-0.8.7-r1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.7-r1.ebuild,v 1.1 2007/11/03 18:53:22 pva Exp $
+
+inherit eutils webapp depend.apache depend.php
+
+# Support for _p* in version.
+MY_P=${P/_p*/}
+HAS_PATCHES=1
+
+DESCRIPTION="Cacti is a complete frontend to rrdtool"
+HOMEPAGE="http://www.cacti.net/"
+SRC_URI="http://www.cacti.net/downloads/${MY_P}.tar.gz"
+
+# patches
+if [ $HAS_PATCHES == 1 ] ; then
+ UPSTREAM_PATCHES="graph_create_xml_warning
+ sec_sql_injection-0.8.7"
+ for i in $UPSTREAM_PATCHES ; do
+ SRC_URI="${SRC_URI} http://www.cacti.net/downloads/patches/${PV/_p*}/${i}.patch"
+ done
+fi
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="snmp bundled-adodb"
+
+DEPEND=""
+
+want_apache
+need_php_cli
+need_php_httpd
+
+RDEPEND="!apache2? ( www-servers/lighttpd )
+ snmp? ( net-analyzer/net-snmp )
+ net-analyzer/rrdtool
+ !bundled-adodb? ( dev-php/adodb )
+ virtual/mysql
+ virtual/cron"
+
+src_unpack() {
+ if [ $HAS_PATCHES == 1 ] ; then
+ unpack ${MY_P}.tar.gz
+ [ ! ${MY_P} == ${P} ] && mv ${MY_P} ${P}
+ # patches
+ for i in ${UPSTREAM_PATCHES} ; do
+ EPATCH_OPTS="-p1 -d ${S} -N" epatch "${DISTDIR}"/${i}.patch
+ done ;
+ else
+ unpack ${MY_P}.tar.gz
+ fi
+
+ use bundled-adodb || sed -i -e \
+ 's:$config\["library_path"\] . "/adodb/adodb.inc.php":"adodb/adodb.inc.php":' \
+ "${S}"/include/global.php
+}
+
+pkg_setup() {
+ webapp_pkg_setup
+ has_php
+ if [ $PHP_VERSION = 5 ] ; then
+ phpUseFlags="cli mysql xml session pcre"
+ elif [ $PHP_VERSION = 4 ] ; then
+ phpUseFlags="cli mysql xml session pcre expat"
+ fi
+ use bundled-adodb || phpUseFlags="${phpUseFlags} sockets"
+ require_php_with_use ${phpUseFlags}
+}
+
+src_compile() {
+ einfo "Nothing to compile."
+}
+
+src_install() {
+ webapp_src_preinst
+
+ rm LICENSE README
+ dodoc docs/{CHANGELOG,CONTRIB,INSTALL,README,REQUIREMENTS,UPGRADE}
+ rm -rf docs
+ use bundled-adodb || rm -rf lib/adodb
+
+ edos2unix `find -type f -name '*.php'`
+
+ dodir ${MY_HTDOCSDIR}
+ cp -r . "${D}"${MY_HTDOCSDIR}
+
+ webapp_serverowned ${MY_HTDOCSDIR}/rra
+ webapp_serverowned ${MY_HTDOCSDIR}/log/cacti.log
+ webapp_configfile ${MY_HTDOCSDIR}/include/config.php
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
diff --git a/net-analyzer/cacti/files/digest-cacti-0.8.7-r1 b/net-analyzer/cacti/files/digest-cacti-0.8.7-r1
new file mode 100644
index 000000000000..e09bf91c98d5
--- /dev/null
+++ b/net-analyzer/cacti/files/digest-cacti-0.8.7-r1
@@ -0,0 +1,9 @@
+MD5 d28e8f9fd4b657c2ad79c4bcf1e3694d cacti-0.8.7.tar.gz 2405448
+RMD160 2d7b111fea85c59483621aa5c30056332976b05d cacti-0.8.7.tar.gz 2405448
+SHA256 6a30ef4588f27fd885389710003ead98a229c01d6b355dc958fc61be49eb3545 cacti-0.8.7.tar.gz 2405448
+MD5 ecb0a12c6f3265e1739d07a46894331d graph_create_xml_warning.patch 554
+RMD160 9081954ba486c0c8fb29ed7780253296238294b3 graph_create_xml_warning.patch 554
+SHA256 5b62bb209627ced3e336f12c80a28d2b01a55daa75a01f87c977bb289032f11c graph_create_xml_warning.patch 554
+MD5 6aeea0a9f7e7ff807104d843cec60b6b sec_sql_injection-0.8.7.patch 742
+RMD160 b1bcdc9d76265b208fc697e127ca729b4ec13f57 sec_sql_injection-0.8.7.patch 742
+SHA256 b7c46249e643aca6c7e56311edd55a2c80d0705075001bc5c370abe692cd1549 sec_sql_injection-0.8.7.patch 742