summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2007-06-08 11:47:35 +0000
committerPeter Volkov <pva@gentoo.org>2007-06-08 11:47:35 +0000
commit042b8cf96e77deaf0fa57a1141f2a66711e8a140 (patch)
treeaa6e2b585528ce6619ab69ae110336db13b27915 /net-analyzer/cacti
parentSwap one line in the init script, thanks to Jörg Eitemüller <destotelhorus ... (diff)
downloadgentoo-2-042b8cf96e77deaf0fa57a1141f2a66711e8a140.tar.gz
gentoo-2-042b8cf96e77deaf0fa57a1141f2a66711e8a140.tar.bz2
gentoo-2-042b8cf96e77deaf0fa57a1141f2a66711e8a140.zip
Call require_php_with_use only once. Thank armin76 for the fix.
(Portage version: 2.1.2.9)
Diffstat (limited to 'net-analyzer/cacti')
-rw-r--r--net-analyzer/cacti/ChangeLog5
-rw-r--r--net-analyzer/cacti/cacti-0.8.6j-r6.ebuild9
2 files changed, 9 insertions, 5 deletions
diff --git a/net-analyzer/cacti/ChangeLog b/net-analyzer/cacti/ChangeLog
index e1ea4052e7d1..b8a36fc54e2d 100644
--- a/net-analyzer/cacti/ChangeLog
+++ b/net-analyzer/cacti/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-analyzer/cacti
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.105 2007/06/07 13:55:47 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.106 2007/06/08 11:47:35 pva Exp $
+
+ 08 Jun 2007; <pva@gentoo.org> cacti-0.8.6j-r6.ebuild:
+ Call require_php_with_use only once. Thank armin76 for the fix.
07 Jun 2007; Markus Rothe <corsair@gentoo.org> cacti-0.8.6j-r5.ebuild:
Stable on ppc64; bug #181112
diff --git a/net-analyzer/cacti/cacti-0.8.6j-r6.ebuild b/net-analyzer/cacti/cacti-0.8.6j-r6.ebuild
index a2c77bea0794..d3b9a0240e33 100644
--- a/net-analyzer/cacti/cacti-0.8.6j-r6.ebuild
+++ b/net-analyzer/cacti/cacti-0.8.6j-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.6j-r6.ebuild,v 1.3 2007/06/07 13:47:24 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.6j-r6.ebuild,v 1.4 2007/06/08 11:47:35 pva Exp $
inherit eutils webapp depend.apache depend.php
@@ -64,11 +64,12 @@ pkg_setup() {
webapp_pkg_setup
has_php
if [ $PHP_VERSION = 5 ] ; then
- require_php_with_use cli mysql xml
+ phpUseFlags="cli mysql xml"
elif [ $PHP_VERSION = 4 ] ; then
- require_php_with_use cli mysql xml expat
+ phpUseFlags="cli mysql xml expat"
fi
- use bundled-adodb || require_php_with_use sockets
+ use bundled-adodb || phpUseFlags="${phpUseFlags} sockets"
+ require_php_with_use ${phpUseFlags}
}
src_compile() {