summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-03-22 21:03:44 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-03-22 21:03:44 +0000
commitcc64a88e8d5cacbfd48f11e348865af5b0532a8a (patch)
tree0a97e09b58f45f2df3d91dc38b222eaf7baaf06f /net-analyzer/arpon
parentmarked x86 per bug 408391 (diff)
downloadgentoo-2-cc64a88e8d5cacbfd48f11e348865af5b0532a8a.tar.gz
gentoo-2-cc64a88e8d5cacbfd48f11e348865af5b0532a8a.tar.bz2
gentoo-2-cc64a88e8d5cacbfd48f11e348865af5b0532a8a.zip
revbump to add init script. Thanks to Tobias Wallura <Tobias.Wallura@gmail.com>. Bug #387193
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/arpon')
-rw-r--r--net-analyzer/arpon/ChangeLog11
-rw-r--r--net-analyzer/arpon/arpon-2.7-r1.ebuild43
-rw-r--r--net-analyzer/arpon/files/arpon.confd5
-rw-r--r--net-analyzer/arpon/files/arpon.initd19
4 files changed, 76 insertions, 2 deletions
diff --git a/net-analyzer/arpon/ChangeLog b/net-analyzer/arpon/ChangeLog
index 26d0e6d42895..af494ffef881 100644
--- a/net-analyzer/arpon/ChangeLog
+++ b/net-analyzer/arpon/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/arpon
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/arpon/ChangeLog,v 1.9 2011/10/04 17:19:13 nativemad Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/arpon/ChangeLog,v 1.10 2012/03/22 21:03:44 hwoarang Exp $
+
+*arpon-2.7-r1 (22 Mar 2012)
+
+ 22 Mar 2012; Markos Chandras <hwoarang@gentoo.org> +arpon-2.7-r1.ebuild,
+ +files/arpon.confd, +files/arpon.initd:
+ revbump to add init script. Thanks to Tobias Wallura
+ <Tobias.Wallura@gmail.com>. Bug #387193
04 Oct 2011; Andreas Schuerch <nativemad@gentoo.org> arpon-2.7.ebuild:
x86 stable, bug 384913
diff --git a/net-analyzer/arpon/arpon-2.7-r1.ebuild b/net-analyzer/arpon/arpon-2.7-r1.ebuild
new file mode 100644
index 000000000000..b9a0cb1a5788
--- /dev/null
+++ b/net-analyzer/arpon/arpon-2.7-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/arpon/arpon-2.7-r1.ebuild,v 1.1 2012/03/22 21:03:44 hwoarang Exp $
+
+EAPI="2"
+inherit cmake-utils
+
+DESCRIPTION="ArpON (Arp handler inspectiON) is a portable Arp handler."
+
+MY_PN="ArpON"
+MY_P="${MY_PN}-${PV}"
+HOMEPAGE="http://arpon.sourceforge.net/"
+SRC_URI="mirror://sourceforge/arpon/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/libdnet
+ net-libs/libnet:1.1
+ net-libs/libpcap"
+
+RDEPEND=${DEPEND}
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ sed -i -e "/set(CMAKE_C_FLAGS/d" CMakeLists.txt || die
+}
+
+src_install() {
+ cmake-utils_src_install
+ newinitd "${FILESDIR}"/${PN}.initd ${PM}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+}
+
+pkg_postinst() {
+ elog
+ elog "${PN} now installs an init script. Please edit"
+ elog "the /etc/conf.d/arpon file to match your needs"
+ elog
+}
diff --git a/net-analyzer/arpon/files/arpon.confd b/net-analyzer/arpon/files/arpon.confd
new file mode 100644
index 000000000000..d1ce050fa4cb
--- /dev/null
+++ b/net-analyzer/arpon/files/arpon.confd
@@ -0,0 +1,5 @@
+METHOD="--darpi"
+IFACE="eth0"
+LOGFILE="/var/log/arpon.log"
+
+ARPON_OPTS="${METHOD} --iface ${IFACE} --log-file ${LOGFILE} --log"
diff --git a/net-analyzer/arpon/files/arpon.initd b/net-analyzer/arpon/files/arpon.initd
new file mode 100644
index 000000000000..5f6a1bd8c6e2
--- /dev/null
+++ b/net-analyzer/arpon/files/arpon.initd
@@ -0,0 +1,19 @@
+#!/sbin/runscript
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting arpon"
+ start-stop-daemon --start --background --make-pidfile --pidfile "/var/run/arpon.pid" \
+ --exec /usr/sbin/arpon -- ${ARPON_OPTS} >/dev/null 2>&1
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping arpon"
+ start-stop-daemon --stop --pidfile "/var/run/arpon.pid"
+ eend $?
+}