summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2004-02-06 14:32:06 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2004-02-06 14:32:06 +0000
commitd2f398f6f13e0ef798407a6d6e2a67e03a4b4d88 (patch)
tree8e495014b338ea2f5068a5545fb60886d0a4abf0 /net-analyzer/argus
parentAdd DirectFB, artsc, and cle266 (via hardware MPEG decoder) support. (Manifes... (diff)
downloadgentoo-2-d2f398f6f13e0ef798407a6d6e2a67e03a4b4d88.tar.gz
gentoo-2-d2f398f6f13e0ef798407a6d6e2a67e03a4b4d88.tar.bz2
gentoo-2-d2f398f6f13e0ef798407a6d6e2a67e03a4b4d88.zip
Fix compilation aginst the new libpcap include files.
Diffstat (limited to 'net-analyzer/argus')
-rw-r--r--net-analyzer/argus/ChangeLog7
-rw-r--r--net-analyzer/argus/argus-2.0.5.ebuild13
-rw-r--r--net-analyzer/argus/files/argus-2.0.5-libpcap-include.patch24
3 files changed, 36 insertions, 8 deletions
diff --git a/net-analyzer/argus/ChangeLog b/net-analyzer/argus/ChangeLog
index 197544fa763d..f7af52f58b06 100644
--- a/net-analyzer/argus/ChangeLog
+++ b/net-analyzer/argus/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-analyzer/argus
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus/ChangeLog,v 1.2 2003/02/12 07:43:13 vapier Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus/ChangeLog,v 1.3 2004/02/06 14:32:06 aliz Exp $
+
+ 06 Feb 2004; Daniel Ahlberg <aliz@gentoo.org> argus-2.0.5.ebuild:
+ Fix compilation aginst the new libpcap include files.
*argus-2.0.5 (17 Dec 2002)
diff --git a/net-analyzer/argus/argus-2.0.5.ebuild b/net-analyzer/argus/argus-2.0.5.ebuild
index fa4a9fe16384..67f81676fb8a 100644
--- a/net-analyzer/argus/argus-2.0.5.ebuild
+++ b/net-analyzer/argus/argus-2.0.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus/argus-2.0.5.ebuild,v 1.3 2003/07/13 11:30:10 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus/argus-2.0.5.ebuild,v 1.4 2004/02/06 14:32:06 aliz Exp $
DESCRIPTION="network Audit Record Generation and Utilization System"
HOMEPAGE="http://www.qosient.com/argus/"
@@ -8,7 +8,7 @@ HOMEPAGE="http://www.qosient.com/argus/"
SRC_URI="ftp://ftp.qosient.com/pub/argus/src/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86"
+KEYWORDS="x86 ~amd64"
IUSE=""
RDEPEND="virtual/glibc
>=net-libs/libpcap-0.6.2"
@@ -17,11 +17,12 @@ DEPEND="${RDEPEND}
>=sys-devel/flex-2.4.6"
src_unpack() {
- unpack ${A}
- cd ${S}
+ unpack ${A} ; cd ${S}
+
+ epatch ${FILESDIR}/${P}-libpcap-include.patch
# Fix hardcoded config file
- patch -p0 < ${FILESDIR}/${PF}-gentoo.diff || die
+ epatch ${FILESDIR}/${PF}-gentoo.diff
}
src_install () {
diff --git a/net-analyzer/argus/files/argus-2.0.5-libpcap-include.patch b/net-analyzer/argus/files/argus-2.0.5-libpcap-include.patch
new file mode 100644
index 000000000000..5f5d12c1a597
--- /dev/null
+++ b/net-analyzer/argus/files/argus-2.0.5-libpcap-include.patch
@@ -0,0 +1,24 @@
+diff -ru /tmp/argus-2.0.5/common/argus_filter.c ./common/argus_filter.c
+--- common/argus_filter.c 2002-05-31 12:18:01.000000000 +0000
++++ common/argus_filter.c 2004-02-06 14:28:33.249830776 +0000
+@@ -107,7 +107,7 @@
+
+ #include <sys/param.h>
+ #include <sys/time.h>
+-#include <net/bpf.h>
++#include <pcap.h>
+
+ #include <argus_filter.h>
+
+diff -ru /tmp/argus-2.0.5/common/gencode.c ./common/gencode.c
+--- common/gencode.c 2002-05-16 18:18:12.000000000 +0000
++++ common/gencode.c 2004-02-06 14:27:49.339506160 +0000
+@@ -59,7 +59,7 @@
+ #include <stdlib.h>
+ #include <syslog.h>
+
+-#include <net/bpf.h>
++#include <pcap.h>
+
+ #include <argus_out.h>
+ #include <argus_filter.h>