summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-11-15 20:25:30 +0000
committerJeroen Roovers <jer@gentoo.org>2011-11-15 20:25:30 +0000
commit8d1fa2704c70dcc440207759b4f3865802d8900b (patch)
treec5ebfcafa7239b5026060280b6a21336aa24997a /net-analyzer/argus
parentVersion bump. (diff)
downloadgentoo-2-8d1fa2704c70dcc440207759b4f3865802d8900b.tar.gz
gentoo-2-8d1fa2704c70dcc440207759b4f3865802d8900b.tar.bz2
gentoo-2-8d1fa2704c70dcc440207759b4f3865802d8900b.zip
Version bump.
(Portage version: 2.2.0_alpha74/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/argus')
-rw-r--r--net-analyzer/argus/ChangeLog7
-rw-r--r--net-analyzer/argus/argus-3.0.5.6.ebuild73
2 files changed, 79 insertions, 1 deletions
diff --git a/net-analyzer/argus/ChangeLog b/net-analyzer/argus/ChangeLog
index 5baeea6e83fd..8e54d39f7829 100644
--- a/net-analyzer/argus/ChangeLog
+++ b/net-analyzer/argus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/argus
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus/ChangeLog,v 1.34 2011/08/30 19:35:01 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus/ChangeLog,v 1.35 2011/11/15 20:25:30 jer Exp $
+
+*argus-3.0.5.6 (15 Nov 2011)
+
+ 15 Nov 2011; Jeroen Roovers <jer@gentoo.org> +argus-3.0.5.6.ebuild:
+ Version bump.
*argus-3.0.5.5 (30 Aug 2011)
diff --git a/net-analyzer/argus/argus-3.0.5.6.ebuild b/net-analyzer/argus/argus-3.0.5.6.ebuild
new file mode 100644
index 000000000000..baf306b85e54
--- /dev/null
+++ b/net-analyzer/argus/argus-3.0.5.6.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus/argus-3.0.5.6.ebuild,v 1.1 2011/11/15 20:25:30 jer Exp $
+
+EAPI="4"
+
+inherit autotools eutils
+
+DESCRIPTION="network Audit Record Generation and Utilization System"
+HOMEPAGE="http://www.qosient.com/argus/"
+SRC_URI="http://qosient.com/argus/dev/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="debug tcpd"
+
+# sasl? ( >=dev-libs/cyrus-sasl-2.1.22 )
+RDEPEND="net-libs/libpcap
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/bison-1.28
+ >=sys-devel/flex-2.4.6"
+
+src_prepare() {
+ sed -e 's:/etc/argus.conf:/etc/argus/argus.conf:' \
+ -i argus/argus.c \
+ -i support/Config/argus.conf \
+ -i man/man8/argus.8 \
+ -i man/man5/argus.conf.5 || die
+
+ sed -e 's:#\(ARGUS_SETUSER_ID=\).*:\1argus:' \
+ -e 's:#\(ARGUS_SETGROUP_ID=\).*:\1argus:' \
+ -e 's:\(#ARGUS_CHROOT_DIR=\).*:\1/var/lib/argus:' \
+ -i support/Config/argus.conf || die
+# sed -e 's:.*="-O.*":true:g' -i acsite.m4 || die
+ epatch \
+ "${FILESDIR}"/${PN}-3.0.4-disable-tcp-wrappers-automagic.patch
+ eautoreconf
+}
+
+src_configure() {
+ use debug && touch .debug # enable debugging
+ econf $(use_with tcpd wrappers)
+}
+
+src_compile() {
+ emake CCOPT="${CFLAGS} ${LDFLAGS}"
+}
+
+src_install () {
+ doman man/man5/* man/man8/*
+ dosbin bin/argus{,bug}
+
+ dodoc ChangeLog CREDITS README
+
+ insinto /etc/argus
+ doins support/Config/argus.conf
+
+ newinitd "${FILESDIR}/argus.initd" argus
+ dodir /var/lib/argus
+}
+
+pkg_preinst() {
+ enewgroup argus
+ enewuser argus -1 -1 /var/lib/argus argus
+}
+
+pkg_postinst() {
+ elog "Note, if you modify ARGUS_DAEMON value in argus.conf it's quite"
+ elog "possible that init script will fail to work."
+}