summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-07-06 14:58:25 +0000
committerJeroen Roovers <jer@gentoo.org>2011-07-06 14:58:25 +0000
commit6bffb9c11872a792a48d315818c8de309b964b24 (patch)
tree5736b63384e202d922e320c7b3e871602d654433 /net-analyzer/argus/argus-3.0.5.4.ebuild
parentVersion bump. (diff)
downloadgentoo-2-6bffb9c11872a792a48d315818c8de309b964b24.tar.gz
gentoo-2-6bffb9c11872a792a48d315818c8de309b964b24.tar.bz2
gentoo-2-6bffb9c11872a792a48d315818c8de309b964b24.zip
Version bump.
(Portage version: 2.2.0_alpha43/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/argus/argus-3.0.5.4.ebuild')
-rw-r--r--net-analyzer/argus/argus-3.0.5.4.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/net-analyzer/argus/argus-3.0.5.4.ebuild b/net-analyzer/argus/argus-3.0.5.4.ebuild
new file mode 100644
index 000000000000..3270c8eacf77
--- /dev/null
+++ b/net-analyzer/argus/argus-3.0.5.4.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus/argus-3.0.5.4.ebuild,v 1.1 2011/07/06 14:58:25 jer Exp $
+
+EAPI="2"
+
+inherit autotools eutils
+
+DESCRIPTION="network Audit Record Generation and Utilization System"
+HOMEPAGE="http://www.qosient.com/argus/"
+SRC_URI="http://qosient.com/argus/dev/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="debug tcpd"
+
+# sasl? ( >=dev-libs/cyrus-sasl-2.1.22 )
+RDEPEND="net-libs/libpcap
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/bison-1.28
+ >=sys-devel/flex-2.4.6"
+
+src_prepare() {
+ sed -e 's:/etc/argus.conf:/etc/argus/argus.conf:' \
+ -i argus/argus.c \
+ -i support/Config/argus.conf \
+ -i man/man8/argus.8 \
+ -i man/man5/argus.conf.5 || die
+
+ sed -e 's:#\(ARGUS_SETUSER_ID=\).*:\1argus:' \
+ -e 's:#\(ARGUS_SETGROUP_ID=\).*:\1argus:' \
+ -e 's:\(#ARGUS_CHROOT_DIR=\).*:\1/var/lib/argus:' \
+ -i support/Config/argus.conf || die
+ epatch "${FILESDIR}"/${PN}-3.0.4-disable-tcp-wrappers-automagic.patch
+ eautoreconf
+}
+
+src_configure() {
+ use debug && touch .debug # enable debugging
+ econf $(use_with tcpd wrappers)
+}
+
+src_install () {
+ doman man/man5/* man/man8/*
+ dosbin bin/argus{,bug} || die
+
+ dodoc ChangeLog CREDITS README || die
+
+ insinto /etc/argus
+ doins support/Config/argus.conf || die
+
+ newinitd "${FILESDIR}/argus.initd" argus || die
+ dodir /var/lib/argus
+}
+
+pkg_preinst() {
+ enewgroup argus
+ enewuser argus -1 -1 /var/lib/argus argus
+}
+
+pkg_postinst() {
+ elog "Note, if you modify ARGUS_DAEMON value in argus.conf it's quite"
+ elog "possible that init script will fail to work."
+}