summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-08-10 13:48:29 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-08-10 13:48:29 +0000
commit6bd9cd81bcde6e194db61f847b0c85bdb5847ad0 (patch)
treef27e8d38ac3cb084f264cad31b135b8a25195183 /net-analyzer/argus-clients/argus-clients-3.0.3.8.ebuild
parentDrop unused patch. (diff)
downloadgentoo-2-6bd9cd81bcde6e194db61f847b0c85bdb5847ad0.tar.gz
gentoo-2-6bd9cd81bcde6e194db61f847b0c85bdb5847ad0.tar.bz2
gentoo-2-6bd9cd81bcde6e194db61f847b0c85bdb5847ad0.zip
Respect CFLAGS,LDFLAGS. Bug #331871. Thanks to Diego E. 'Flameeyes' Pettenò <flameeyes@gentoo.org> for reporting
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/argus-clients/argus-clients-3.0.3.8.ebuild')
-rw-r--r--net-analyzer/argus-clients/argus-clients-3.0.3.8.ebuild15
1 files changed, 13 insertions, 2 deletions
diff --git a/net-analyzer/argus-clients/argus-clients-3.0.3.8.ebuild b/net-analyzer/argus-clients/argus-clients-3.0.3.8.ebuild
index 3f043b60a6c7..8d2b1177e2a3 100644
--- a/net-analyzer/argus-clients/argus-clients-3.0.3.8.ebuild
+++ b/net-analyzer/argus-clients/argus-clients-3.0.3.8.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus-clients/argus-clients-3.0.3.8.ebuild,v 1.3 2010/07/18 13:28:42 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus-clients/argus-clients-3.0.3.8.ebuild,v 1.4 2010/08/10 13:48:29 hwoarang Exp $
EAPI="2"
-inherit eutils
+inherit autotools eutils
DESCRIPTION="Clients for net-analyzer/argus"
HOMEPAGE="http://www.qosient.com/argus/"
@@ -29,6 +29,13 @@ DEPEND="${MY_CDEPEND}
>=sys-devel/bison-1.28
>=sys-devel/flex-2.4.6"
+src_prepare() {
+ for x in $(find . -name "Makefile.in"); do
+ sed -i "s:\$(CFLAGS):& \$(LDFLAGS) :" $x
+ done
+ eautomake
+}
+
src_configure() {
use debug && touch .debug
# $(use_with sasl) \
@@ -37,6 +44,10 @@ src_configure() {
$(use_with mysql)
}
+src_compile() {
+ emake CCOPT="${CFLAGS} ${LDFLAGS}" || die "emake failed"
+}
+
src_install() {
# argus_parse.a and argus_common.a are supplied by net-analyzer/argus
dobin bin/ra* || die "Failed to install ra*"