summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-10-09 10:47:02 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-10-09 10:47:02 +0000
commitfd84abe3ee208408fdf13ae32971af2c0798c2db (patch)
tree37b0040357d469a8c8822efcd3b67c4d394b1fe4 /media-video
parentMissing gst-plugins-base depend for -lgstinterfaces-0.10 checked by configure... (diff)
downloadgentoo-2-fd84abe3ee208408fdf13ae32971af2c0798c2db.tar.gz
gentoo-2-fd84abe3ee208408fdf13ae32971af2c0798c2db.tar.bz2
gentoo-2-fd84abe3ee208408fdf13ae32971af2c0798c2db.zip
Version bump wrt #353478 by Thomas Rausch. This will also fix building with recent FFmpeg wrt #374797 by Diego Elio Pettenò.
(Portage version: 2.2.0_alpha63/cvs/Linux x86_64)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/dvdstyler/ChangeLog9
-rw-r--r--media-video/dvdstyler/dvdstyler-2.0_rc1.ebuild59
2 files changed, 67 insertions, 1 deletions
diff --git a/media-video/dvdstyler/ChangeLog b/media-video/dvdstyler/ChangeLog
index bfc88e60d646..d388b6c7c8e8 100644
--- a/media-video/dvdstyler/ChangeLog
+++ b/media-video/dvdstyler/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-video/dvdstyler
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/dvdstyler/ChangeLog,v 1.45 2011/09/16 18:38:04 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/dvdstyler/ChangeLog,v 1.46 2011/10/09 10:47:02 ssuominen Exp $
+
+*dvdstyler-2.0_rc1 (09 Oct 2011)
+
+ 09 Oct 2011; Samuli Suominen <ssuominen@gentoo.org>
+ +dvdstyler-2.0_rc1.ebuild:
+ Version bump wrt #353478 by Thomas Rausch. This will also fix building with
+ recent FFmpeg wrt #374797 by Diego Elio Pettenò.
16 Sep 2011; Steve Dibb <beandog@gentoo.org> dvdstyler-1.7.4.ebuild,
dvdstyler-1.8.1_beta1.ebuild, dvdstyler-1.8.1.ebuild:
diff --git a/media-video/dvdstyler/dvdstyler-2.0_rc1.ebuild b/media-video/dvdstyler/dvdstyler-2.0_rc1.ebuild
new file mode 100644
index 000000000000..c622d39b2558
--- /dev/null
+++ b/media-video/dvdstyler/dvdstyler-2.0_rc1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/dvdstyler/dvdstyler-2.0_rc1.ebuild,v 1.1 2011/10/09 10:47:02 ssuominen Exp $
+
+EAPI=4
+inherit eutils wxwidgets
+
+MY_P=${PN/dvds/DVDS}-${PV/_}
+
+DESCRIPTION="DVDStyler is a cross-platform DVD authoring System"
+HOMEPAGE="http://www.dvdstyler.de"
+SRC_URI="mirror://sourceforge/dvdstyler/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug gnome kernel_linux"
+
+COMMON_DEPEND=">=app-cdr/dvd+rw-tools-7.1
+ >=media-libs/libexif-0.6.16
+ >=media-libs/wxsvg-1.1.2
+ >=media-video/dvdauthor-0.7.0
+ >=media-video/xine-ui-0.99.1
+ virtual/cdrtools
+ >=virtual/ffmpeg-0.6.90[encode]
+ x11-libs/wxGTK:2.8[gstreamer,X]
+ gnome? ( >=gnome-base/libgnomeui-2 )
+ kernel_linux? ( sys-fs/udev )"
+RDEPEND="${COMMON_DEPEND}
+ >=app-cdr/dvdisaster-0.72.2"
+DEPEND="${COMMON_DEPEND}
+ app-arch/zip
+ app-text/xmlto
+ dev-util/pkgconfig
+ >=sys-devel/gettext-0.17"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ use gnome || sed -i -e '/PKG_CONFIG/s:libgnomeui-2.0:dIsAbLeAuToMaGiC&:' configure
+
+ # rmdir: failed to remove `tempfoobar': Directory not empty
+ sed -i -e '/rmdir "$$t"/d' docs/Makefile.in || die
+}
+
+src_configure() {
+ export WX_GTK_VER="2.8"
+ need-wxwidgets unicode
+
+ econf \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_enable debug) \
+ --with-wx-config="${WX_CONFIG}"
+}
+
+src_install() {
+ default
+ rm -f "${ED}"usr/share/doc/${PF}/{COPYING*,INSTALL*}
+}