summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-04-23 15:24:24 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-04-23 15:24:24 +0000
commitf2ed164d91b775008b352408476fae119a26e04e (patch)
treea04517eda8ce0c488493d47e003c91c5235feb5a /media-video
parentVerion bumps (diff)
downloadgentoo-2-f2ed164d91b775008b352408476fae119a26e04e.tar.gz
gentoo-2-f2ed164d91b775008b352408476fae119a26e04e.tar.bz2
gentoo-2-f2ed164d91b775008b352408476fae119a26e04e.zip
Fix some useflag combinations failures reported by andreas schürch <andreas.schuerch@nativenet.ch>, bug #316805 and simplify vlc_use_enable_force
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/vlc/ChangeLog8
-rw-r--r--media-video/vlc/vlc-1.0.6.ebuild36
-rw-r--r--media-video/vlc/vlc-1.0.9999.ebuild36
3 files changed, 53 insertions, 27 deletions
diff --git a/media-video/vlc/ChangeLog b/media-video/vlc/ChangeLog
index 07a71f5bd815..77cdb3301fbc 100644
--- a/media-video/vlc/ChangeLog
+++ b/media-video/vlc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/vlc
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/ChangeLog,v 1.571 2010/04/23 11:08:49 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/ChangeLog,v 1.572 2010/04/23 15:24:24 aballier Exp $
+
+ 23 Apr 2010; Alexis Ballier <aballier@gentoo.org> vlc-1.0.6.ebuild,
+ vlc-1.0.9999.ebuild:
+ Fix some useflag combinations failures reported by andreas schürch
+ <andreas.schuerch@nativenet.ch>, bug #316805 and simplify
+ vlc_use_enable_force
*vlc-1.1.9999 (23 Apr 2010)
diff --git a/media-video/vlc/vlc-1.0.6.ebuild b/media-video/vlc/vlc-1.0.6.ebuild
index dd2abb1eee60..455569b4711c 100644
--- a/media-video/vlc/vlc-1.0.6.ebuild
+++ b/media-video/vlc/vlc-1.0.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-1.0.6.ebuild,v 1.1 2010/04/22 17:56:02 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-1.0.6.ebuild,v 1.2 2010/04/23 15:24:24 aballier Exp $
EAPI="2"
@@ -126,7 +126,11 @@ RDEPEND="
sdl? ( >=media-libs/libsdl-1.2.8
sdl-image? ( media-libs/sdl-image ) )
shout? ( media-libs/libshout )
- skins? ( x11-libs/qt-gui:4 x11-libs/qt-core:4 x11-libs/libXext x11-libs/libX11 )
+ skins? (
+ x11-libs/qt-gui:4 x11-libs/qt-core:4
+ x11-libs/libXext x11-libs/libX11
+ media-libs/freetype media-fonts/dejavu
+ )
speex? ( media-libs/speex )
svg? ( >=gnome-base/librsvg-2.9.0 )
svga? ( media-libs/svgalib )
@@ -179,13 +183,11 @@ vlc_use_force() {
use $1 && use !$2 && ewarn "USE=$1 requires $2, $2 will be enabled."
}
-# Use when $2 depends strictly on $3
-# if use $1 then enable $2 and $3, otherwise disable $2
+# Use when $1 depends strictly on $2
+# if use $1 then enable $2
vlc_use_enable_force() {
if use $1 ; then
- echo "--enable-$2 --enable-$3"
- else
- echo "--disable-$2"
+ echo "--enable-$2"
fi
}
@@ -196,17 +198,20 @@ pkg_setup() {
eerror "the old ${PN} version and will not work."
die "Unmerge vlc 0.9.x first"
fi
- vlc_use_needs skins truetype
- vlc_use_force skins qt4
vlc_use_needs cddax cdio
vlc_use_needs vcdx cdio
vlc_use_needs vcdx vcdinfo
vlc_use_needs vcdinfo cdio
vlc_use_needs bidi truetype
- vlc_use_force remoteosd gcrypt
vlc_use_needs fontconfig truetype
vlc_use_needs libv4l2 v4l2
vlc_use_needs libtiger kate
+ vlc_use_force remoteosd gcrypt
+ vlc_use_force skins truetype
+ vlc_use_force skins qt4
+ vlc_use_force skins X
+ vlc_use_force qt4 X
+ vlc_use_force vlm stream
use cddb && use !cdda && use !cddax && ewarn "USE=cddb requires either cdda or cddax, cddb will be disabled."
if use qt4 || use skins ; then
qt4_pkg_setup
@@ -318,6 +323,7 @@ src_configure() {
$(use_enable pulseaudio pulse) \
$(use_enable pvr) \
$(use_enable qt4) \
+ $(use_enable remoteosd) \
$(use_enable rtsp realrtsp) \
$(use_enable run-as-root) \
$(use_enable samba smb) \
@@ -342,6 +348,7 @@ src_configure() {
$(use_enable v4l2) \
$(use_enable vcdinfo) \
$(use_enable vcdx) \
+ $(use_enable vlm) \
$(use_enable vorbis) \
$(use_enable win32codecs loader) \
$(use_enable wma-fixed) \
@@ -358,9 +365,12 @@ src_configure() {
--disable-growl \
--disable-optimizations \
--enable-fast-install \
- $(vlc_use_enable_force vlm vlm sout) \
- $(vlc_use_enable_force skins skins2 qt4) \
- $(vlc_use_enable_force remoteosd remoteosd libgcrypt)
+ $(vlc_use_enable_force qt4 x11) \
+ $(vlc_use_enable_force vlm sout) \
+ $(vlc_use_enable_force skins qt4) \
+ $(vlc_use_enable_force skins freetype) \
+ $(vlc_use_enable_force skins x11) \
+ $(vlc_use_enable_force remoteosd libgcrypt)
}
src_install() {
diff --git a/media-video/vlc/vlc-1.0.9999.ebuild b/media-video/vlc/vlc-1.0.9999.ebuild
index 3a26106fc7b4..918dcab287dd 100644
--- a/media-video/vlc/vlc-1.0.9999.ebuild
+++ b/media-video/vlc/vlc-1.0.9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-1.0.9999.ebuild,v 1.39 2010/04/07 16:04:46 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-1.0.9999.ebuild,v 1.40 2010/04/23 15:24:24 aballier Exp $
EAPI="2"
@@ -126,7 +126,11 @@ RDEPEND="
sdl? ( >=media-libs/libsdl-1.2.8
sdl-image? ( media-libs/sdl-image ) )
shout? ( media-libs/libshout )
- skins? ( x11-libs/qt-gui:4 x11-libs/qt-core:4 x11-libs/libXext x11-libs/libX11 )
+ skins? (
+ x11-libs/qt-gui:4 x11-libs/qt-core:4
+ x11-libs/libXext x11-libs/libX11
+ media-libs/freetype media-fonts/dejavu
+ )
speex? ( media-libs/speex )
svg? ( >=gnome-base/librsvg-2.9.0 )
svga? ( media-libs/svgalib )
@@ -179,13 +183,11 @@ vlc_use_force() {
use $1 && use !$2 && ewarn "USE=$1 requires $2, $2 will be enabled."
}
-# Use when $2 depends strictly on $3
-# if use $1 then enable $2 and $3, otherwise disable $2
+# Use when $1 depends strictly on $2
+# if use $1 then enable $2
vlc_use_enable_force() {
if use $1 ; then
- echo "--enable-$2 --enable-$3"
- else
- echo "--disable-$2"
+ echo "--enable-$2"
fi
}
@@ -196,17 +198,20 @@ pkg_setup() {
eerror "the old ${PN} version and will not work."
die "Unmerge vlc 0.9.x first"
fi
- vlc_use_needs skins truetype
- vlc_use_force skins qt4
vlc_use_needs cddax cdio
vlc_use_needs vcdx cdio
vlc_use_needs vcdx vcdinfo
vlc_use_needs vcdinfo cdio
vlc_use_needs bidi truetype
- vlc_use_force remoteosd gcrypt
vlc_use_needs fontconfig truetype
vlc_use_needs libv4l2 v4l2
vlc_use_needs libtiger kate
+ vlc_use_force remoteosd gcrypt
+ vlc_use_force skins truetype
+ vlc_use_force skins qt4
+ vlc_use_force skins X
+ vlc_use_force qt4 X
+ vlc_use_force vlm stream
use cddb && use !cdda && use !cddax && ewarn "USE=cddb requires either cdda or cddax, cddb will be disabled."
if use qt4 || use skins ; then
qt4_pkg_setup
@@ -318,6 +323,7 @@ src_configure() {
$(use_enable pulseaudio pulse) \
$(use_enable pvr) \
$(use_enable qt4) \
+ $(use_enable remoteosd) \
$(use_enable rtsp realrtsp) \
$(use_enable run-as-root) \
$(use_enable samba smb) \
@@ -342,6 +348,7 @@ src_configure() {
$(use_enable v4l2) \
$(use_enable vcdinfo) \
$(use_enable vcdx) \
+ $(use_enable vlm) \
$(use_enable vorbis) \
$(use_enable win32codecs loader) \
$(use_enable wma-fixed) \
@@ -358,9 +365,12 @@ src_configure() {
--disable-growl \
--disable-optimizations \
--enable-fast-install \
- $(vlc_use_enable_force vlm vlm sout) \
- $(vlc_use_enable_force skins skins2 qt4) \
- $(vlc_use_enable_force remoteosd remoteosd libgcrypt)
+ $(vlc_use_enable_force qt4 x11) \
+ $(vlc_use_enable_force vlm sout) \
+ $(vlc_use_enable_force skins qt4) \
+ $(vlc_use_enable_force skins freetype) \
+ $(vlc_use_enable_force skins x11) \
+ $(vlc_use_enable_force remoteosd libgcrypt)
}
src_install() {