summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Stelling <blubb@gentoo.org>2005-03-23 14:33:10 +0000
committerSimon Stelling <blubb@gentoo.org>2005-03-23 14:33:10 +0000
commite4f7c00091348cffa0c5b3285f508e21bf6fb61a (patch)
tree28c40362f648b12b5c420e9d1b07de42b05e551f /media-video
parentKeyworded ~sparc wrt #84992 (diff)
downloadgentoo-2-e4f7c00091348cffa0c5b3285f508e21bf6fb61a.tar.gz
gentoo-2-e4f7c00091348cffa0c5b3285f508e21bf6fb61a.tar.bz2
gentoo-2-e4f7c00091348cffa0c5b3285f508e21bf6fb61a.zip
#83996
(Portage version: 2.0.51.19)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/sswf/ChangeLog6
-rw-r--r--media-video/sswf/files/bitsize.patch57
-rw-r--r--media-video/sswf/files/sound_wave_t.patch14
-rw-r--r--media-video/sswf/sswf-1.7.1.ebuild13
4 files changed, 87 insertions, 3 deletions
diff --git a/media-video/sswf/ChangeLog b/media-video/sswf/ChangeLog
index f205c3311603..cdd777dc6f52 100644
--- a/media-video/sswf/ChangeLog
+++ b/media-video/sswf/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/sswf
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/sswf/ChangeLog,v 1.1 2005/01/28 05:56:27 chriswhite Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/sswf/ChangeLog,v 1.2 2005/03/23 14:33:10 blubb Exp $
+
+ 23 Mar 2005; <blubb@gentoo.org> +files/bitsize.patch,
+ +files/sound_wave_t.patch, sswf-1.7.1.ebuild:
+ added Adam Polkosnik's patches to fix bug #83996
*sswf-1.7.1 (28 Jan 2005)
diff --git a/media-video/sswf/files/bitsize.patch b/media-video/sswf/files/bitsize.patch
new file mode 100644
index 000000000000..132a5102ac83
--- /dev/null
+++ b/media-video/sswf/files/bitsize.patch
@@ -0,0 +1,57 @@
+--- src.old/lib/libsswf_tags.c++ 2005-01-14 03:27:39.000000000 -0500
++++ src/lib/libsswf_tags.c++ 2005-03-04 17:04:50.536424560 -0500
+@@ -3211,27 +3211,13 @@
+
+ if(value < 0) {
+ // a special case
+- if(value == -1) {
+- return 1;
+- }
+- cnt = 33;
+- do {
+- cnt--;
+- value *= 2;
+- } while(value < 0);
++ value =~ value;
+ }
+- else {
+- // a special case
+- if(value == 0) {
+- return 1;
+- }
+- cnt = 33;
+- do {
+- cnt--;
+- value *= 2;
+- } while(value > 0);
++ cnt = 1;
++ while(value >0){
++ cnt++;
++ value = value / 2;
+ }
+-
+ return cnt;
+ }
+
+@@ -3240,16 +3226,11 @@
+ {
+ long cnt;
+
+- // a special case
+- if(value == 0) {
+- return 1;
+- }
+- cnt = 32;
+- while((long) value > 0) {
+- cnt--;
+- value *= 2;
+- }
+-
++ cnt = 0;
++ do {
++ cnt++;
++ value = value / 2;
++ }while( value > 0);
+ return cnt;
+ }
+
diff --git a/media-video/sswf/files/sound_wave_t.patch b/media-video/sswf/files/sound_wave_t.patch
new file mode 100644
index 000000000000..f504656f1464
--- /dev/null
+++ b/media-video/sswf/files/sound_wave_t.patch
@@ -0,0 +1,14 @@
+--- include/sswf/libsswf.h.old 2005-01-14 03:27:39.000000000 -0500
++++ include/sswf/libsswf.h 2005-03-08 23:38:40.524934320 -0500
+@@ -2157,8 +2157,9 @@
+ struct sound_wave_t {
+ short format; // the data format (we only support PCM)
+ short channels; // number of channels (1 - mono, 2 - stereo)
+- long rate; // exact sample rate to play the sound at
+- long avarage_rate; // average rate for the entire set of samples (this may vary in compressed files)
++/* rate and average_rate are 4 bytes each, long on some platforms is 8 bytes */
++ int rate; // exact sample rate to play the sound at
++ int avarage_rate; // average rate for the entire set of samples (this may vary in compressed files)
+ short align; // byte alignment of the samples (every char, short, long...)
+ /* the following is format dependent, but at this time doesn't vary for us */
+ short width; // width of the samples (8 or 16)
diff --git a/media-video/sswf/sswf-1.7.1.ebuild b/media-video/sswf/sswf-1.7.1.ebuild
index 89e3cbec3eef..709b31d46145 100644
--- a/media-video/sswf/sswf-1.7.1.ebuild
+++ b/media-video/sswf/sswf-1.7.1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/sswf/sswf-1.7.1.ebuild,v 1.2 2005/03/19 01:12:52 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/sswf/sswf-1.7.1.ebuild,v 1.3 2005/03/23 14:33:10 blubb Exp $
+
+inherit eutils
DESCRIPTION="A C++ Library and a script language tool to create Flash (SWF) movies up to version 6."
HOMEPAGE="http://sswf.sourceforge.net"
@@ -9,7 +11,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.bz2
LICENSE="as-is"
SLOT="0"
-KEYWORDS="~x86 ~ppc"
+KEYWORDS="~x86 ~ppc ~amd64"
IUSE="doc debug"
DEPEND="sys-libs/zlib
media-libs/jpeg
@@ -17,6 +19,13 @@ DEPEND="sys-libs/zlib
sys-devel/flex
sys-devel/bison"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/bitsize.patch
+ epatch ${FILESDIR}/sound_wave_t.patch
+}
+
src_compile() {
econf \
$(use_enable debug) \