summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-04-05 18:14:09 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-04-05 18:14:09 +0000
commitdcffbd333dccef8ac8fc2f7feea62aaf9d5f79db (patch)
treee8d3db001f59728d1525d0c74286e3c276c5524c /media-video
parentStable for ppc64, wrt bug #432282 (diff)
downloadgentoo-2-dcffbd333dccef8ac8fc2f7feea62aaf9d5f79db.tar.gz
gentoo-2-dcffbd333dccef8ac8fc2f7feea62aaf9d5f79db.tar.bz2
gentoo-2-dcffbd333dccef8ac8fc2f7feea62aaf9d5f79db.zip
Include <cstring> for memcpy() because it's no longer implicitly pulled in by libpng since 1.6.0.
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/ffmpegthumbnailer/ChangeLog9
-rw-r--r--media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.8.ebuild5
-rw-r--r--media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.8-memcpy.patch13
3 files changed, 23 insertions, 4 deletions
diff --git a/media-video/ffmpegthumbnailer/ChangeLog b/media-video/ffmpegthumbnailer/ChangeLog
index d8b67dee5c94..934130f6f992 100644
--- a/media-video/ffmpegthumbnailer/ChangeLog
+++ b/media-video/ffmpegthumbnailer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/ffmpegthumbnailer
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ChangeLog,v 1.148 2012/12/01 19:36:00 armin76 Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ChangeLog,v 1.149 2013/04/05 18:14:09 ssuominen Exp $
+
+ 05 Apr 2013; Samuli Suominen <ssuominen@gentoo.org>
+ ffmpegthumbnailer-2.0.8.ebuild, +files/ffmpegthumbnailer-2.0.8-memcpy.patch:
+ Include <cstring> for memcpy() because it's no longer implicitly pulled in by
+ libpng since 1.6.0.
01 Dec 2012; Raúl Porcel <armin76@gentoo.org>
ffmpegthumbnailer-2.0.8.ebuild:
diff --git a/media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.8.ebuild b/media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.8.ebuild
index da10b0e07fdc..0d151adc2112 100644
--- a/media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.8.ebuild
+++ b/media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.8.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.8.ebuild,v 1.7 2012/12/01 19:36:00 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.8.ebuild,v 1.8 2013/04/05 18:14:09 ssuominen Exp $
EAPI=4
inherit eutils libtool
@@ -26,6 +26,7 @@ REQUIRED_USE="gnome? ( gtk )"
DOCS="AUTHORS ChangeLog README"
src_prepare() {
+ epatch "${FILESDIR}"/${P}-memcpy.patch
elibtoolize
}
diff --git a/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.8-memcpy.patch b/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.8-memcpy.patch
new file mode 100644
index 000000000000..5b9c68613e74
--- /dev/null
+++ b/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.8-memcpy.patch
@@ -0,0 +1,13 @@
+libffmpegthumbnailer/pngwriter.cpp: In function 'void ffmpegthumbnailer::writeDataCallback(png_structp, png_bytep, png_size_t)':
+libffmpegthumbnailer/pngwriter.cpp:111:52: error: 'memcpy' was not declared in this scope
+
+--- libffmpegthumbnailer/pngwriter.cpp
++++ libffmpegthumbnailer/pngwriter.cpp
+@@ -17,6 +17,7 @@
+ #include "pngwriter.h"
+ #include <stdexcept>
+ #include <cassert>
++#include <cstring>
+
+ using namespace std;
+