summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-08-03 20:16:15 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-08-03 20:16:15 +0000
commitdb22909757b60bd0714770b0bce4c90e14ea4c74 (patch)
tree26e07dd4932feb636cef30d58466e77fcdb1a9fa /media-video
parentOld. (diff)
downloadgentoo-2-db22909757b60bd0714770b0bce4c90e14ea4c74.tar.gz
gentoo-2-db22909757b60bd0714770b0bce4c90e14ea4c74.tar.bz2
gentoo-2-db22909757b60bd0714770b0bce4c90e14ea4c74.zip
Respect CC and LDFLAGS wrt bug #331105
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/subtitleripper/ChangeLog11
-rw-r--r--media-video/subtitleripper/files/subtitleripper-0.3.4-respect-ldflags.patch28
-rw-r--r--media-video/subtitleripper/subtitleripper-0.3.4-r4.ebuild50
3 files changed, 87 insertions, 2 deletions
diff --git a/media-video/subtitleripper/ChangeLog b/media-video/subtitleripper/ChangeLog
index d5d5f11bf12f..0737fa760863 100644
--- a/media-video/subtitleripper/ChangeLog
+++ b/media-video/subtitleripper/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-video/subtitleripper
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/subtitleripper/ChangeLog,v 1.22 2009/05/31 01:15:44 dirtyepic Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/subtitleripper/ChangeLog,v 1.23 2010/08/03 20:16:15 hwoarang Exp $
+
+*subtitleripper-0.3.4-r4 (03 Aug 2010)
+
+ 03 Aug 2010; Markos Chandras <hwoarang@gentoo.org>
+ +subtitleripper-0.3.4-r4.ebuild,
+ +files/subtitleripper-0.3.4-respect-ldflags.patch:
+ Respect CC and LDFLAGS wrt bug #331105
31 May 2009; Ryan Hill <dirtyepic@gentoo.org>
subtitleripper-0.3.4-r3.ebuild,
diff --git a/media-video/subtitleripper/files/subtitleripper-0.3.4-respect-ldflags.patch b/media-video/subtitleripper/files/subtitleripper-0.3.4-respect-ldflags.patch
new file mode 100644
index 000000000000..2af11d257929
--- /dev/null
+++ b/media-video/subtitleripper/files/subtitleripper-0.3.4-respect-ldflags.patch
@@ -0,0 +1,28 @@
+Index: subtitleripper/Makefile
+===================================================================
+--- subtitleripper.orig/Makefile
++++ subtitleripper/Makefile
+@@ -70,19 +70,19 @@ vobsub2pgm.o: vobsub2pgm.c vobsub.h spud
+ # Target
+ subtitle2pgm: subtitle2pgm.o spudec.o
+ @echo "Linking $@"
+- @$(CC) $^ -o $@ $(LIBS)
++ @$(CC) $(LDFLAGS) $^ -o $@ $(LIBS)
+
+ subtitle2vobsub: subtitle2vobsub.o vobsub.o
+ @echo "Linking $@"
+- @$(CC) $^ -o $@ $(LIBS)
++ @$(CC) $(LDFLAGS) $^ -o $@ $(LIBS)
+
+ srttool: srttool.o
+ @echo "Linking $@"
+- @$(CC) -g $^ -o $@ $(LIBS)
++ @$(CC) $(LDFLAGS) $^ -o $@ $(LIBS)
+
+ vobsub2pgm: vobsub2pgm.o vobsub.o spudec.o
+ @echo "Linking $@"
+- @$(CC) -g $^ -o $@ $(LIBS)
++ @$(CC) $(LDFLAGS) $^ -o $@ $(LIBS)
+
+ .PHONY: clean dist rpm
+ clean:
diff --git a/media-video/subtitleripper/subtitleripper-0.3.4-r4.ebuild b/media-video/subtitleripper/subtitleripper-0.3.4-r4.ebuild
new file mode 100644
index 000000000000..31a6e7408c11
--- /dev/null
+++ b/media-video/subtitleripper/subtitleripper-0.3.4-r4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/subtitleripper/subtitleripper-0.3.4-r4.ebuild,v 1.1 2010/08/03 20:16:15 hwoarang Exp $
+
+inherit versionator eutils toolchain-funcs
+
+MY_PV="$(replace_version_separator 2 "-")"
+
+DESCRIPTION="DVD Subtitle Ripper for Linux"
+HOMEPAGE="http://subtitleripper.sourceforge.net/"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-${MY_PV}.tgz"
+SLOT="0"
+IUSE=""
+RDEPEND=">=media-libs/netpbm-10.41.0
+ media-libs/libpng
+ sys-libs/zlib
+ >=app-text/gocr-0.39"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # PPM library is libnetppm
+ sed -i -e "s:ppm:netpbm:g" Makefile
+ # fix for bug 210435
+ sed -i -e "s:#include <ppm.h>:#include <netpbm/ppm.h>:g" spudec.c subtitle2pgm.c
+ # we will install the gocrfilters into /usr/share/subtitleripper
+ sed -i -e 's:~/sourceforge/subtitleripper/src/:/usr/share/subtitleripper:' pgm2txt
+
+ epatch "${FILESDIR}/${P}-linkingorder.patch"
+ epatch "${FILESDIR}"/${P}-libpng.patch
+ epatch "${FILESDIR}"/${P}-glibc210.patch
+ # respect CC and LDFLAGS
+ sed -i -e "s:CC =.*:CC = $(tc-getCC):" \
+ -e "/^CFLAGS/s: = :& ${CFLAGS} :" "${S}"/Makefile
+ epatch "${FILESDIR}"/${P}-respect-ldflags.patch
+}
+
+src_install () {
+ dobin pgm2txt srttool subtitle2pgm subtitle2vobsub vobsub2pgm
+
+ insinto /usr/share/subtitleripper
+ doins gocrfilter_*.sed
+
+ dodoc ChangeLog README*
+}