summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2006-08-11 08:32:17 +0000
committerAlastair Tse <liquidx@gentoo.org>2006-08-11 08:32:17 +0000
commitd935f26ad0b2bda0eccf167a0909373a3798fd4b (patch)
tree2f74c7ad6375c8a219ea9e65e9cdb0abf5634a7b /media-video
parentBumping vanilla-sources-2.4 to 2.4.33 (diff)
downloadgentoo-2-d935f26ad0b2bda0eccf167a0909373a3798fd4b.tar.gz
gentoo-2-d935f26ad0b2bda0eccf167a0909373a3798fd4b.tar.bz2
gentoo-2-d935f26ad0b2bda0eccf167a0909373a3798fd4b.zip
added patch for makefile to use OUTPUT_DIR when installing. thanks to Sourav Mandal (#135630)
(Portage version: 2.1-r1)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/qc-usb/ChangeLog7
-rw-r--r--media-video/qc-usb/files/digest-qc-usb-0.6.36
-rw-r--r--media-video/qc-usb/files/qc-usb-0.6.4-koutput.patch58
-rw-r--r--media-video/qc-usb/qc-usb-0.6.4.ebuild5
4 files changed, 70 insertions, 6 deletions
diff --git a/media-video/qc-usb/ChangeLog b/media-video/qc-usb/ChangeLog
index 3a1f06ee4776..80f796e8fc1a 100644
--- a/media-video/qc-usb/ChangeLog
+++ b/media-video/qc-usb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/qc-usb
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/qc-usb/ChangeLog,v 1.15 2006/05/29 19:42:58 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/qc-usb/ChangeLog,v 1.16 2006/08/11 08:32:17 liquidx Exp $
+
+ 11 Aug 2006; Alastair Tse <liquidx@gentoo.org>
+ +files/qc-usb-0.6.4-koutput.patch, qc-usb-0.6.4.ebuild:
+ added patch for makefile to use OUTPUT_DIR when installing. thanks to Sourav
+ Mandal (#135630)
*qc-usb-0.6.4 (29 May 2006)
diff --git a/media-video/qc-usb/files/digest-qc-usb-0.6.3 b/media-video/qc-usb/files/digest-qc-usb-0.6.3
index df58dd30fac4..650f31d97caa 100644
--- a/media-video/qc-usb/files/digest-qc-usb-0.6.3
+++ b/media-video/qc-usb/files/digest-qc-usb-0.6.3
@@ -1,3 +1,3 @@
-MD5 3d33380a29a7f92c4eef1f82d61b4ee0 qc-usb-0.6.3.tar.gz 148994
-RMD160 248768b551dc810dea524567e73b591353c0f8ed qc-usb-0.6.3.tar.gz 148994
-SHA256 fee6264949107e5d879525487c1c3b27ea208ea854792d8c87142143cb2f2aa5 qc-usb-0.6.3.tar.gz 148994
+MD5 1bd925cdaafedd0324d0b34b630cd81e qc-usb-0.6.3.tar.gz 3712
+RMD160 d6d450501df1f5679dfe3267d24c67268c747242 qc-usb-0.6.3.tar.gz 3712
+SHA256 11426c7afa1defd404d21b802d4bc2cdac079770dfeef5cf21952a6529db5563 qc-usb-0.6.3.tar.gz 3712
diff --git a/media-video/qc-usb/files/qc-usb-0.6.4-koutput.patch b/media-video/qc-usb/files/qc-usb-0.6.4-koutput.patch
new file mode 100644
index 000000000000..5bf3a7f4bdfa
--- /dev/null
+++ b/media-video/qc-usb/files/qc-usb-0.6.4-koutput.patch
@@ -0,0 +1,58 @@
+diff -urN qc-usb-0.6.4.old/Makefile qc-usb-0.6.4/Makefile
+--- qc-usb-0.6.4.old/Makefile 2006-05-02 06:18:30.000000000 -0700
++++ qc-usb-0.6.4/Makefile 2006-06-05 05:29:25.000000000 -0700
+@@ -41,7 +41,7 @@
+ MODULE_DIR := /lib/modules/$(shell uname -r)
+ else
+ # Note: the brackets on line below contain a space and a _tab_!
+-RELEASE := $(shell awk -F \" '/[ ]*\#[ ]*define[ ]*UTS_RELEASE[ ]*/ { print $$2 }' $(LINUX_DIR)/include/linux/version.h|tail -n 1)
++RELEASE := $(shell awk -F \" '/[ ]*\#[ ]*define[ ]*UTS_RELEASE[ ]*/ { print $$2 }' $(OUTPUT_DIR)/include/linux/version.h|tail -n 1)
+ MODULE_DIR := /lib/modules/$(RELEASE)
+ endif
+ endif
+@@ -51,6 +51,11 @@
+ LINUX_DIR := $(MODULE_DIR)/build
+ endif
+
++# Due to delayed subsitution, can handle OUTPUT_DIR here
++ifndef OUTPUT_DIR
++OUTPUT_DIR := $(LINUX_DIR)
++endif
++
+ ifndef USER_OPT
+ USER_OPT :=
+ endif
+@@ -60,7 +65,7 @@
+ DEPMOD := $(shell which depmod || which /sbin/depmod || echo "true You should now run depmod")
+
+ # Get VERSION_CODE (from version.h in kernel source directory)
+-VERSION_CODE := $(shell awk '/[ ]*\#[ ]*define[ ]*LINUX_VERSION_CODE[ ]*/ { print $$3 }' $(LINUX_DIR)/include/linux/version.h|tail -n 1)
++VERSION_CODE := $(shell awk '/[ ]*\#[ ]*define[ ]*LINUX_VERSION_CODE[ ]*/ { print $$3 }' $(OUTPUT_DIR)/include/linux/version.h|tail -n 1)
+
+ ifeq ($(shell if [ $(VERSION_CODE) -ge 132608 ]; then echo y; fi),y)
+ MODULE_NAME := quickcam.ko # for 2.6.x
+@@ -76,6 +81,7 @@
+ @echo "make all - Compile driver and utilities against current running kernel"
+ @echo "make all USER_OPT=-DDEBUG - Compile with debugging code and messages"
+ @echo "make all LINUX_DIR=/usr/src/linux - Compile against specified kernel source"
++ @echo "make all OUTPUT_DIR=/var/tmp/kernel-output/2.6.13 - Specifiy binary output dir"
+ @echo "make install - Copy driver and utilities into standard locations (needs root)"
+ @echo "make install PREFIX=/usr - Copy utilities to /usr/bin instead of /usr/local/bin"
+ @echo "make install MODULE_DIR=/lib/modules/2.4.0 - Copy module to /lib/modules/2.4.0/misc"
+@@ -93,6 +99,7 @@
+ @echo "Current configuration:"
+ @echo "Driver source directory (PWD): $(PWD)"
+ @echo "Kernel source directory (LINUX_DIR): $(LINUX_DIR)"
++ @echo "Kernel output directory (OUTPUT_DIR): $(OUTPUT_DIR)"
+ @echo "Module install directory (MODULE_DIR): $(MODULE_DIR)"
+ @echo "Utility install directory (PREFIX): $(PREFIX)"
+ @echo "User options (USER_OPT): $(USER_OPT)"
+@@ -115,7 +122,7 @@
+ else
+ # No, 2.4.x or older
+
+-MODULE_INC := -I$(LINUX_DIR)/include -nostdinc -iwithprefix include
++MODULE_INC := -I$(LINUX_DIR)/include -I$(OUTPUT_DIR)/include -nostdinc -iwithprefix include
+ MODULE_DEF := -DMODULE -D__KERNEL__ -DNOKERNEL
+ MODULE_OPT := -O2 -fomit-frame-pointer -fno-strict-aliasing -fno-common
+ MODULE_WARN := -Wall -Wstrict-prototypes -Wno-trigraphs
diff --git a/media-video/qc-usb/qc-usb-0.6.4.ebuild b/media-video/qc-usb/qc-usb-0.6.4.ebuild
index cc120778a61c..f0a3c17899de 100644
--- a/media-video/qc-usb/qc-usb-0.6.4.ebuild
+++ b/media-video/qc-usb/qc-usb-0.6.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/qc-usb/qc-usb-0.6.4.ebuild,v 1.1 2006/05/29 19:42:58 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/qc-usb/qc-usb-0.6.4.ebuild,v 1.2 2006/08/11 08:32:17 liquidx Exp $
inherit linux-mod eutils multilib
@@ -20,13 +20,14 @@ BUILD_TARGETS="all"
pkg_setup() {
ABI=${KERNEL_ABI}
linux-mod_pkg_setup
- BUILD_PARAMS="LINUX_DIR=${KV_DIR}"
+ BUILD_PARAMS="LINUX_DIR=${KV_DIR} OUTPUT_DIR=${KV_OUT_DIR}"
}
src_unpack() {
unpack ${A}
cd ${S}
convert_to_m ${S}/Makefile
+ epatch ${FILESDIR}/${P}-koutput.patch
}
src_install() {