summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-04-20 08:02:35 +0000
committerMike Frysinger <vapier@gentoo.org>2008-04-20 08:02:35 +0000
commitce4c71d3ce2508324fad075daf8699d0d23d17fa (patch)
treee5028f976c459d9c1358b691706e7e305ccb5848 /media-video
parentVersion bump. (diff)
downloadgentoo-2-ce4c71d3ce2508324fad075daf8699d0d23d17fa.tar.gz
gentoo-2-ce4c71d3ce2508324fad075daf8699d0d23d17fa.tar.bz2
gentoo-2-ce4c71d3ce2508324fad075daf8699d0d23d17fa.zip
Fix by Ryan Hill for building with gcc-4.3 #200767.
(Portage version: 2.2_pre5)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/mjpegtools/ChangeLog8
-rw-r--r--media-video/mjpegtools/files/mjpegtools-1.9.0_rc3-gcc43.patch147
-rw-r--r--media-video/mjpegtools/mjpegtools-1.9.0_rc3.ebuild6
3 files changed, 157 insertions, 4 deletions
diff --git a/media-video/mjpegtools/ChangeLog b/media-video/mjpegtools/ChangeLog
index b30165de454b..4a9ca4ceef6a 100644
--- a/media-video/mjpegtools/ChangeLog
+++ b/media-video/mjpegtools/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/mjpegtools
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mjpegtools/ChangeLog,v 1.130 2007/12/04 21:18:16 zzam Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/mjpegtools/ChangeLog,v 1.131 2008/04/20 08:02:34 vapier Exp $
+
+ 20 Apr 2008; Mike Frysinger <vapier@gentoo.org>
+ +files/mjpegtools-1.9.0_rc3-gcc43.patch, mjpegtools-1.9.0_rc3.ebuild:
+ Fix by Ryan Hill for building with gcc-4.3 #200767.
*mjpegtools-1.9.0_rc3 (04 Dec 2007)
diff --git a/media-video/mjpegtools/files/mjpegtools-1.9.0_rc3-gcc43.patch b/media-video/mjpegtools/files/mjpegtools-1.9.0_rc3-gcc43.patch
new file mode 100644
index 000000000000..ae3fc901d880
--- /dev/null
+++ b/media-video/mjpegtools/files/mjpegtools-1.9.0_rc3-gcc43.patch
@@ -0,0 +1,147 @@
+http://bugs.gentoo.org/200767
+http://sourceforge.net/tracker/index.php?func=detail&aid=1947059&group_id=5776&atid=305776
+
+--- mjpegtools-1.9.0rc3/mpeg2enc/encodertypes.h
++++ mjpegtools-1.9.0rc3/mpeg2enc/encodertypes.h
+@@ -25,6 +25,8 @@
+ */
+
+
++#include <stdlib.h>
++
+ class Parity
+ {
+ public:
+--- mjpegtools-1.9.0rc3/mpeg2enc/macroblock.cc
++++ mjpegtools-1.9.0rc3/mpeg2enc/macroblock.cc
+@@ -21,6 +21,7 @@
+
+ #include <stdio.h>
+ #include <cassert>
++#include <limits.h>
+
+ #include "macroblock.hh"
+ #include "mpeg2syntaxcodes.h"
+--- mjpegtools-1.9.0rc3/mpeg2enc/picturereader.cc
++++ mjpegtools-1.9.0rc3/mpeg2enc/picturereader.cc
+@@ -23,6 +23,7 @@
+ #include "picturereader.hh"
+ #include "mpeg2encoder.hh"
+ #include "imageplanes.hh"
++#include <limits.h>
+ //#include <stdio.h>
+ //#include <stdlib.h>
+ //#include <unistd.h>
+--- mjpegtools-1.9.0rc3/mplex/inputstrm.cpp
++++ mjpegtools-1.9.0rc3/mplex/inputstrm.cpp
+@@ -23,6 +23,7 @@
+
+ #include <config.h>
+ #include <assert.h>
++#include <limits.h>
+
+ #include "mjpeg_types.h"
+ #include "inputstrm.hpp"
+--- mjpegtools-1.9.0rc3/mplex/padstrm.cpp
++++ mjpegtools-1.9.0rc3/mplex/padstrm.cpp
+@@ -24,6 +24,7 @@
+ #include "config.h"
+ #endif
+
++#include <string.h>
+ #include "padstrm.hpp"
+
+
+--- mjpegtools-1.9.0rc3/mplex/multiplexor.cpp
++++ mjpegtools-1.9.0rc3/mplex/multiplexor.cpp
+@@ -22,6 +22,7 @@
+ #include <config.h>
+ #include <math.h>
+ #include <stdlib.h>
++#include <string.h>
+
+ #include <mjpeg_types.h>
+ #include <mjpeg_logging.h>
+--- mjpegtools-1.9.0rc3/mplex/main.cpp
++++ mjpegtools-1.9.0rc3/mplex/main.cpp
+@@ -31,6 +31,7 @@
+ #include <getopt.h>
+ #endif
+ #include <string>
++#include <string.h>
+ #include <memory>
+ #include <sys/stat.h>
+ #ifndef _WIN32
+--- mjpegtools-1.9.0rc3/y4mdenoise/Set.hh
++++ mjpegtools-1.9.0rc3/y4mdenoise/Set.hh
+@@ -23,7 +23,7 @@
+ // How we implement ourselves.
+
+ public:
+- typedef typename Imp::Allocator Allocator;
++ typedef typename Imp::Allocator_t Allocator;
+ // The type of allocator to use to allocate items in the set.
+
+ Set (const PRED &a_rPred = PRED(),
+--- mjpegtools-1.9.0rc3/y4mdenoise/SkipList.hh
++++ mjpegtools-1.9.0rc3/y4mdenoise/SkipList.hh
+@@ -57,19 +57,19 @@
+ // Will give good sorting for up to e^10 items.
+
+ public:
+- typedef Allocator<Node,HEADERCHUNK> Allocator;
++ typedef Allocator<Node,HEADERCHUNK> Allocator_t;
+ // The type of node allocator to use.
+
+- static Allocator sm_oNodeAllocator;
++ static Allocator_t sm_oNodeAllocator;
+ // The default node allocator.
+
+ SkipList (const PRED &a_rPred = PRED(),
+- Allocator &a_rAlloc = sm_oNodeAllocator);
++ Allocator_t &a_rAlloc = sm_oNodeAllocator);
+ // Default constructor. Must be followed by Init().
+
+ SkipList (Status_t &a_reStatus, bool a_bAllowDuplicates,
+ uint32_t a_nRandSeed, const PRED &a_rPred = PRED(),
+- Allocator &a_rAlloc = sm_oNodeAllocator);
++ Allocator_t &a_rAlloc = sm_oNodeAllocator);
+ // Constructor. Specify whether or not duplicates are allowed,
+ // and provide a random number seed.
+
+@@ -255,7 +255,7 @@
+
+ private:
+
+- Allocator &m_rNodeAllocator;
++ Allocator_t &m_rNodeAllocator;
+ // Where we get memory to allocate nodes.
+
+ bool m_bAllowDuplicates;
+@@ -337,7 +337,7 @@
+
+ // The default node allocator. Allocates 64K at a time.
+ template <class KEY, class VALUE, class KEYFN, class PRED>
+-typename SkipList<KEY,VALUE,KEYFN,PRED>::Allocator
++typename SkipList<KEY,VALUE,KEYFN,PRED>::Allocator_t
+ SkipList<KEY,VALUE,KEYFN,PRED>::sm_oNodeAllocator (65536);
+
+
+@@ -345,7 +345,7 @@
+ // Default constructor. Must be followed by Init().
+ template <class KEY, class VALUE, class KEYFN, class PRED>
+ SkipList<KEY,VALUE,KEYFN,PRED>::SkipList (const PRED &a_rPred,
+- Allocator &a_rAlloc)
++ Allocator_t &a_rAlloc)
+ : m_rNodeAllocator (a_rAlloc), m_oPred (a_rPred)
+ {
+ // Set up some defaults.
+@@ -371,7 +371,7 @@
+ template <class KEY, class VALUE, class KEYFN, class PRED>
+ SkipList<KEY,VALUE,KEYFN,PRED>::SkipList (Status_t &a_reStatus,
+ bool a_bAllowDuplicates, uint32_t a_nRandSeed,
+- const PRED &a_rPred, Allocator &a_rAlloc)
++ const PRED &a_rPred, Allocator_t &a_rAlloc)
+ : m_rNodeAllocator (a_rAlloc), m_oPred (a_rPred)
+ {
+ // Make sure they didn't start us off with an error.
diff --git a/media-video/mjpegtools/mjpegtools-1.9.0_rc3.ebuild b/media-video/mjpegtools/mjpegtools-1.9.0_rc3.ebuild
index edbce75da9f7..b727ca5bc3b8 100644
--- a/media-video/mjpegtools/mjpegtools-1.9.0_rc3.ebuild
+++ b/media-video/mjpegtools/mjpegtools-1.9.0_rc3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mjpegtools/mjpegtools-1.9.0_rc3.ebuild,v 1.1 2007/12/04 21:18:16 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mjpegtools/mjpegtools-1.9.0_rc3.ebuild,v 1.2 2008/04/20 08:02:35 vapier Exp $
WANT_AUTOMAKE="latest"
WANT_AUTOCONF="latest"
@@ -39,6 +39,8 @@ src_unpack() {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc43.patch #200767
+
# eautoreconf instead of elibtoolize
# as pkg-config-patch changes configure.in
#