summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2003-03-04 22:01:09 +0000
committerArcady Genkin <agenkin@gentoo.org>2003-03-04 22:01:09 +0000
commitc62650f1fd4677c2c47f2b95fd906f55a821b531 (patch)
tree73a2c25cdf2e2e1101a2486067030a1bde2c29c5 /media-video
parentone more chmod command (diff)
downloadgentoo-2-c62650f1fd4677c2c47f2b95fd906f55a821b531.tar.gz
gentoo-2-c62650f1fd4677c2c47f2b95fd906f55a821b531.tar.bz2
gentoo-2-c62650f1fd4677c2c47f2b95fd906f55a821b531.zip
Version bump.
Diffstat (limited to 'media-video')
-rw-r--r--media-video/ogle/ChangeLog6
-rw-r--r--media-video/ogle/files/digest-ogle-0.9.01
-rw-r--r--media-video/ogle/ogle-0.9.0.ebuild59
3 files changed, 65 insertions, 1 deletions
diff --git a/media-video/ogle/ChangeLog b/media-video/ogle/ChangeLog
index 65bdf76fca90..9ca39a5eb384 100644
--- a/media-video/ogle/ChangeLog
+++ b/media-video/ogle/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for media-video/ogle
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ogle/ChangeLog,v 1.11 2003/02/12 07:40:11 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ogle/ChangeLog,v 1.12 2003/03/04 22:01:09 agenkin Exp $
+*ogle-0.9.0 (04 Mar 2003)
+
+ 04 Mar 2003; Arcady Genkin <agenkin@gentoo.org> :
+ Version bump (thanks to Bernardo S. A. Silva <bsaslinux@globo.com>).
*ogle-0.8.5 (21 Sep 2002)
diff --git a/media-video/ogle/files/digest-ogle-0.9.0 b/media-video/ogle/files/digest-ogle-0.9.0
new file mode 100644
index 000000000000..bd4e95c6dd0a
--- /dev/null
+++ b/media-video/ogle/files/digest-ogle-0.9.0
@@ -0,0 +1 @@
+MD5 84276fbe6a3ed2de5ce13589f19b7fc3 ogle-0.9.0.tar.gz 475523
diff --git a/media-video/ogle/ogle-0.9.0.ebuild b/media-video/ogle/ogle-0.9.0.ebuild
new file mode 100644
index 000000000000..2075ebcea26f
--- /dev/null
+++ b/media-video/ogle/ogle-0.9.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/ogle/ogle-0.9.0.ebuild,v 1.1 2003/03/04 22:01:09 agenkin Exp $
+
+inherit libtool
+
+DESCRIPTION="Full featured DVD player that supports DVD menus."
+HOMEPAGE="http://www.dtek.chalmers.se/groups/dvd/"
+SRC_URI="http://www.dtek.chalmers.se/groups/dvd/dist/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+LICENSE="GPL-2"
+IUSE="oss mmx alsa"
+
+DEPEND=">=media-libs/libdvdcss-1.2.2
+ media-libs/jpeg
+ >=media-libs/libdvdread-0.9.4
+ media-sound/mad
+ x11-base/xfree
+ >=dev-libs/libxml2-2.4.19
+ >=media-libs/a52dec-0.7.3
+ alsa? ( media-libs/alsa-lib )"
+
+src_compile() {
+ # STOP! If you make any changes, make sure to unmerge all copies
+ # of ogle and ogle-gui from your system and merge ogle-gui using your
+ # new version of ogle... Changes in this package can break ogle-gui
+ # very very easily -- blocke
+
+ local myconf="`use_enable mmx` `use_enable oss` `use_enable alsa`"
+
+ if [ "${ARCH}" = "ppc" ] ; then
+ # if this user doesn't want altivec, don't compile it in
+ # fixes #14939
+ if [ `echo ${CFLAGS} | grep -e "-maltivec" | wc -l` = "0" ]
+ then
+ einfo "Disabling alitvec support"
+ myconf="${myconf} --disable-altivec"
+ else
+ einfo "Enabling altivec support"
+ myconf="${myconf} --enable-altivec"
+ fi
+ fi
+
+ elibtoolize
+
+ # configure needs access to the updated CFLAGS
+ CFLAGS="${CFLAGS} -I/usr/include/libxml2/libxml -I/usr/include/libxml2"
+
+ econf ${myconf} || die
+ emake CFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ einstall || die
+ dodoc AUTHORS COPYING ChangeLog HISTORY INSTALL NEWS README TODO
+ dodoc doc/liba52.txt
+}