summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-02-21 17:43:40 +0000
committerMike Frysinger <vapier@gentoo.org>2011-02-21 17:43:40 +0000
commitc52c1b1f0568ea3b792cf275ea33db6a14eb8b2a (patch)
tree6e6f282d35dbeee07e00a1b46fdbda2085774605 /media-video
parentmake the blocker slot-specific #355657 (diff)
downloadgentoo-2-c52c1b1f0568ea3b792cf275ea33db6a14eb8b2a.tar.gz
gentoo-2-c52c1b1f0568ea3b792cf275ea33db6a14eb8b2a.tar.bz2
gentoo-2-c52c1b1f0568ea3b792cf275ea33db6a14eb8b2a.zip
Fix for building with libpng-1.5 #355039 by Lars Wendler.
(Portage version: 2.2.0_alpha24/cvs/Linux x86_64)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/dvdauthor/ChangeLog8
-rw-r--r--media-video/dvdauthor/dvdauthor-0.6.14.ebuild12
-rw-r--r--media-video/dvdauthor/files/dvdauthor-0.6.14-libpng-1.5.patch25
3 files changed, 40 insertions, 5 deletions
diff --git a/media-video/dvdauthor/ChangeLog b/media-video/dvdauthor/ChangeLog
index 53708bc766e5..10a681c7677b 100644
--- a/media-video/dvdauthor/ChangeLog
+++ b/media-video/dvdauthor/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/dvdauthor
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/dvdauthor/ChangeLog,v 1.30 2008/12/21 14:51:30 nixnut Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/dvdauthor/ChangeLog,v 1.31 2011/02/21 17:43:40 vapier Exp $
+
+ 21 Feb 2011; Mike Frysinger <vapier@gentoo.org> dvdauthor-0.6.14.ebuild,
+ +files/dvdauthor-0.6.14-libpng-1.5.patch:
+ Fix for building with libpng-1.5 #355039 by Lars Wendler.
21 Dec 2008; nixnut <nixnut@gentoo.org> dvdauthor-0.6.14.ebuild:
Stable on ppc wrt bug 250664
diff --git a/media-video/dvdauthor/dvdauthor-0.6.14.ebuild b/media-video/dvdauthor/dvdauthor-0.6.14.ebuild
index a377fd945cd9..e419b3076c1d 100644
--- a/media-video/dvdauthor/dvdauthor-0.6.14.ebuild
+++ b/media-video/dvdauthor/dvdauthor-0.6.14.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/dvdauthor/dvdauthor-0.6.14.ebuild,v 1.3 2008/12/21 14:51:30 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/dvdauthor/dvdauthor-0.6.14.ebuild,v 1.4 2011/02/21 17:43:40 vapier Exp $
+
+EAPI="2"
inherit eutils
@@ -20,7 +22,11 @@ DEPEND="media-libs/libdvdread
dev-libs/fribidi
media-libs/libpng"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libpng-1.5.patch #355039
+}
+
src_install() {
- make install DESTDIR="${D}" || die "installation failed"
+ emake install DESTDIR="${D}" || die
dodoc README TODO ChangeLog
}
diff --git a/media-video/dvdauthor/files/dvdauthor-0.6.14-libpng-1.5.patch b/media-video/dvdauthor/files/dvdauthor-0.6.14-libpng-1.5.patch
new file mode 100644
index 000000000000..89b43add3cf5
--- /dev/null
+++ b/media-video/dvdauthor/files/dvdauthor-0.6.14-libpng-1.5.patch
@@ -0,0 +1,25 @@
+http://bugs.gentoo.org/355039
+
+$NetBSD: patch-ab,v 1.3 2011/01/14 10:57:50 wiz Exp $
+
+Fix build with png-1.5.
+
+--- src/spuunmux.c
++++ src/spuunmux.c
+@@ -38,6 +38,7 @@
+ #include <netinet/in.h>
+
+ #include <png.h>
++#include <zlib.h>
+
+ #include "rgb.h"
+
+@@ -483,7 +484,7 @@ static int write_png(char *file_name,str
+ return -1;
+ }
+
+- if (setjmp(png_ptr->jmpbuf)) {
++ if (setjmp(png_jmpbuf(png_ptr))) {
+ png_destroy_write_struct(&png_ptr, &info_ptr);
+ fclose(fp);
+ return -1;