summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2009-04-29 10:11:02 +0000
committerDaniel Black <dragonheart@gentoo.org>2009-04-29 10:11:02 +0000
commitb26901d1dca47b998eb5f518a6fea415e84a4153 (patch)
treea19d264c50b900bb510d784ccd20eb7cf43936eb /media-video
parentVersion bump gitg, thanks to voyageur for the notice. (diff)
downloadgentoo-2-b26901d1dca47b998eb5f518a6fea415e84a4153.tar.gz
gentoo-2-b26901d1dca47b998eb5f518a6fea415e84a4153.tar.bz2
gentoo-2-b26901d1dca47b998eb5f518a6fea415e84a4153.zip
version bump - bug #265650 - ebuild by Fabio Correa
(Portage version: 2.2_rc31/cvs/Linux x86_64)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/dvdstyler/ChangeLog8
-rw-r--r--media-video/dvdstyler/dvdstyler-1.7.3_beta2.ebuild55
2 files changed, 62 insertions, 1 deletions
diff --git a/media-video/dvdstyler/ChangeLog b/media-video/dvdstyler/ChangeLog
index ac859016c623..471abdbfe32f 100644
--- a/media-video/dvdstyler/ChangeLog
+++ b/media-video/dvdstyler/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/dvdstyler
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/dvdstyler/ChangeLog,v 1.35 2009/04/29 01:31:23 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/dvdstyler/ChangeLog,v 1.36 2009/04/29 10:11:02 dragonheart Exp $
+
+*dvdstyler-1.7.3_beta2 (29 Apr 2009)
+
+ 29 Apr 2009; Daniel Black <dragonheart@gentoo.org>
+ +dvdstyler-1.7.3_beta2.ebuild:
+ version bump - bug #265650 - ebuild by Fabio Correa
*dvdstyler-1.7.2 (29 Apr 2009)
diff --git a/media-video/dvdstyler/dvdstyler-1.7.3_beta2.ebuild b/media-video/dvdstyler/dvdstyler-1.7.3_beta2.ebuild
new file mode 100644
index 000000000000..e378f1bc8060
--- /dev/null
+++ b/media-video/dvdstyler/dvdstyler-1.7.3_beta2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/dvdstyler/dvdstyler-1.7.3_beta2.ebuild
+
+EAPI=2
+inherit eutils wxwidgets
+
+#Save the following for stable releases
+#MY_P=DVDStyler-${PV}
+#The following is for development releases
+MY_P=DVDStyler-${PV/_beta/b}
+
+DESCRIPTION="DVDStyler is a cross-platform DVD authoring System"
+HOMEPAGE="http://www.dvdstyler.de"
+SRC_URI="mirror://sourceforge/dvdstyler/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug gnome"
+
+COMMON_DEPEND="
+ >=media-video/ffmpeg-0.5[encode]
+ >=media-video/xine-ui-0.99.1
+ x11-libs/wxGTK:2.8
+ >=media-libs/wxsvg-1.0[ffmpeg]
+ >=media-libs/libexif-0.6.16
+ gnome? ( >=gnome-base/libgnomeui-2.0 )"
+RDEPEND="${COMMON_DEPEND}
+ virtual/cdrtools
+ >=media-video/dvdauthor-0.6.14
+ >=app-cdr/dvd+rw-tools-7.1"
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig
+ >=sys-devel/gettext-0.17"
+PDEPEND=">=app-cdr/dvdisaster-0.71.0"
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ ./autogen.sh || die "Source code preparation failed"
+}
+
+src_configure() {
+ export WX_GTK_VER="2.8"
+ need-wxwidgets gtk2
+ myconf="${myconf} --with-wx-config=${WX_CONFIG} $(use_enable debug)"
+ econf ${myconf} || die "Configuration failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Installation failed"
+ rm -rf "${D}usr/share/doc/${PN}"
+ dodoc AUTHORS ChangeLog README TODO || die "Documentation installation failed"
+}