summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-10-26 06:24:22 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-10-26 06:24:22 +0000
commitb26465a2b8e6b0745090910c69089b8b070ba897 (patch)
tree6bfa79dc96bd38c260895da4e0da6e8afbacfe7b /media-video
parentFix handling relative submodule paths. (diff)
downloadgentoo-2-b26465a2b8e6b0745090910c69089b8b070ba897.tar.gz
gentoo-2-b26465a2b8e6b0745090910c69089b8b070ba897.tar.bz2
gentoo-2-b26465a2b8e6b0745090910c69089b8b070ba897.zip
Fix bug #426754 by bailing out on <sys-devel/gcc-4.5. Prepared for version bumps by fixing up SRC_URI to support the a release.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/vlc/ChangeLog7
-rw-r--r--media-video/vlc/vlc-2.0.9999.ebuild12
-rw-r--r--media-video/vlc/vlc-2.1.9999.ebuild10
-rw-r--r--media-video/vlc/vlc-9999.ebuild10
4 files changed, 34 insertions, 5 deletions
diff --git a/media-video/vlc/ChangeLog b/media-video/vlc/ChangeLog
index 56aca88bcfeb..27155e760b89 100644
--- a/media-video/vlc/ChangeLog
+++ b/media-video/vlc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/vlc
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/ChangeLog,v 1.858 2013/10/26 05:53:46 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/ChangeLog,v 1.859 2013/10/26 06:24:22 tomwij Exp $
+
+ 26 Oct 2013; Tom Wijsman <TomWij@gentoo.org> vlc-2.0.9999.ebuild,
+ vlc-2.1.9999.ebuild, vlc-9999.ebuild:
+ Fix bug #426754 by bailing out on <sys-devel/gcc-4.5. Prepared for version
+ bumps by fixing up SRC_URI to support the a release.
*vlc-2.1.9999 (26 Oct 2013)
diff --git a/media-video/vlc/vlc-2.0.9999.ebuild b/media-video/vlc/vlc-2.0.9999.ebuild
index 0ad37e3d3559..42f367fd0178 100644
--- a/media-video/vlc/vlc-2.0.9999.ebuild
+++ b/media-video/vlc/vlc-2.0.9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-2.0.9999.ebuild,v 1.26 2013/10/26 05:53:46 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-2.0.9999.ebuild,v 1.27 2013/10/26 06:24:22 tomwij Exp $
EAPI="5"
@@ -26,7 +26,7 @@ HOMEPAGE="http://www.videolan.org/vlc/"
if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
SRC_URI=""
elif [[ "${MY_P}" == "${P}" ]]; then
- SRC_URI="http://download.videolan.org/pub/videolan/${PN}/${PV}/${P}.tar.xz"
+ SRC_URI="http://download.videolan.org/pub/videolan/${PN}/${PV/a/}/${P}.tar.xz"
else
SRC_URI="http://download.videolan.org/pub/videolan/testing/${MY_P}/${MY_P}.tar.xz"
fi
@@ -186,6 +186,14 @@ REQUIRED_USE="
S="${WORKDIR}/${MY_P}"
+pkg_setup() {
+ if [[ "$(tc-getCC)" == *"gcc"* ]] ; then
+ if [[ $(gcc-major-version) < 4 || ( $(gcc-major-version) == 4 && $(gcc-minor-version) < 5 ) ]] ; then
+ die "You need to have at least >=sys-devel/gcc-4.5 to build and/or have a working vlc, see bug #426754."
+ fi
+ fi
+}
+
src_unpack() {
if [ "${PV%9999}" != "${PV}" ] ; then
git-r3_src_unpack
diff --git a/media-video/vlc/vlc-2.1.9999.ebuild b/media-video/vlc/vlc-2.1.9999.ebuild
index 294cdfd09ab7..d4aa864d3c91 100644
--- a/media-video/vlc/vlc-2.1.9999.ebuild
+++ b/media-video/vlc/vlc-2.1.9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-2.1.9999.ebuild,v 1.1 2013/10/26 05:53:46 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-2.1.9999.ebuild,v 1.2 2013/10/26 06:24:22 tomwij Exp $
EAPI="5"
@@ -183,6 +183,14 @@ REQUIRED_USE="
S="${WORKDIR}/${MY_P}"
+pkg_setup() {
+ if [[ "$(tc-getCC)" == *"gcc"* ]] ; then
+ if [[ $(gcc-major-version) < 4 || ( $(gcc-major-version) == 4 && $(gcc-minor-version) < 5 ) ]] ; then
+ die "You need to have at least >=sys-devel/gcc-4.5 to build and/or have a working vlc, see bug #426754."
+ fi
+ fi
+}
+
src_unpack() {
if [ "${PV%9999}" != "${PV}" ] ; then
git-r3_src_unpack
diff --git a/media-video/vlc/vlc-9999.ebuild b/media-video/vlc/vlc-9999.ebuild
index 6eb7ccb078f8..c05b2ebb066c 100644
--- a/media-video/vlc/vlc-9999.ebuild
+++ b/media-video/vlc/vlc-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-9999.ebuild,v 1.194 2013/10/24 23:34:33 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-9999.ebuild,v 1.195 2013/10/26 06:24:22 tomwij Exp $
EAPI="5"
@@ -185,6 +185,14 @@ REQUIRED_USE="
S="${WORKDIR}/${MY_P}"
+pkg_setup() {
+ if [[ "$(tc-getCC)" == *"gcc"* ]] ; then
+ if [[ $(gcc-major-version) < 4 || ( $(gcc-major-version) == 4 && $(gcc-minor-version) < 5 ) ]] ; then
+ die "You need to have at least >=sys-devel/gcc-4.5 to build and/or have a working vlc, see bug #426754."
+ fi
+ fi
+}
+
src_unpack() {
if [ "${PV%9999}" != "${PV}" ] ; then
git-r3_src_unpack