summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-01-07 19:09:22 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-01-07 19:09:22 +0000
commitb17ee884ec3b2ec07b9c20fb87d0a78f126a77a9 (patch)
treee59696dc3ea6a0ddad400386e16f3888ac7f59eb /media-video
parentMarking ant-swing-1.7.1 ppc64 for bug 250466 (diff)
downloadgentoo-2-b17ee884ec3b2ec07b9c20fb87d0a78f126a77a9.tar.gz
gentoo-2-b17ee884ec3b2ec07b9c20fb87d0a78f126a77a9.tar.bz2
gentoo-2-b17ee884ec3b2ec07b9c20fb87d0a78f126a77a9.zip
Version bump. This version includes upstream fix for GCC 4.4.
(Portage version: 2.1.6.4/cvs/Linux 2.6.28-gentoo i686)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/ffmpegthumbnailer/ChangeLog10
-rw-r--r--media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.4.0.ebuild32
2 files changed, 40 insertions, 2 deletions
diff --git a/media-video/ffmpegthumbnailer/ChangeLog b/media-video/ffmpegthumbnailer/ChangeLog
index b031e7ef01a8..674d87cc8efc 100644
--- a/media-video/ffmpegthumbnailer/ChangeLog
+++ b/media-video/ffmpegthumbnailer/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/ffmpegthumbnailer
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ChangeLog,v 1.60 2008/12/17 14:40:24 beandog Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ChangeLog,v 1.61 2009/01/07 19:09:22 ssuominen Exp $
+
+*ffmpegthumbnailer-1.4.0 (07 Jan 2009)
+
+ 07 Jan 2009; Samuli Suominen <ssuominen@gentoo.org>
+ +ffmpegthumbnailer-1.4.0.ebuild:
+ Version bump. This version includes upstream fix for GCC 4.4.
17 Dec 2008; Steve Dibb <beandog@gentoo.org>
ffmpegthumbnailer-1.3.0.ebuild:
diff --git a/media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.4.0.ebuild b/media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.4.0.ebuild
new file mode 100644
index 000000000000..10193744596a
--- /dev/null
+++ b/media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.4.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ffmpegthumbnailer-1.4.0.ebuild,v 1.1 2009/01/07 19:09:22 ssuominen Exp $
+
+EAPI=2
+
+inherit multilib
+
+DESCRIPTION="Lightweight video thumbnailer that can be used by file managers"
+HOMEPAGE="http://code.google.com/p/ffmpegthumbnailer"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="media-libs/libpng
+ media-libs/jpeg
+ >=media-video/ffmpeg-0.4.9_p20070330"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ econf --disable-dependency-tracking --disable-static
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog README TODO
+ rm -f "${D}"/usr/$(get_libdir)/libffmpegthumbnailer.la
+}