summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-03-09 09:46:50 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-03-09 09:46:50 +0000
commita57ad5b72a4f8f16b9f82fd9f518035765bc1dcd (patch)
tree0803210847a8b06045155ade3584dfda3139d4e1 /media-video
parentx86 stable wrt bug #405981 (diff)
downloadgentoo-2-a57ad5b72a4f8f16b9f82fd9f518035765bc1dcd.tar.gz
gentoo-2-a57ad5b72a4f8f16b9f82fd9f518035765bc1dcd.tar.bz2
gentoo-2-a57ad5b72a4f8f16b9f82fd9f518035765bc1dcd.zip
add bluray useflag
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/ffmpeg/ChangeLog6
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild7
-rw-r--r--media-video/ffmpeg/metadata.xml1
3 files changed, 10 insertions, 4 deletions
diff --git a/media-video/ffmpeg/ChangeLog b/media-video/ffmpeg/ChangeLog
index 6d5d3237a1d8..ca50ba297535 100644
--- a/media-video/ffmpeg/ChangeLog
+++ b/media-video/ffmpeg/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/ffmpeg
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.526 2012/02/28 21:01:41 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.527 2012/03/09 09:46:50 aballier Exp $
+
+ 09 Mar 2012; Alexis Ballier <aballier@gentoo.org> ffmpeg-9999.ebuild,
+ metadata.xml:
+ add bluray useflag
28 Feb 2012; Alexis Ballier <aballier@gentoo.org> ffmpeg-9999.ebuild,
metadata.xml:
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index 0a1c49c0a679..5625056fbc77 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999.ebuild,v 1.79 2012/02/28 21:01:41 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999.ebuild,v 1.80 2012/03/09 09:46:50 aballier Exp $
EAPI="4"
@@ -29,7 +29,7 @@ if [ "${PV#9999}" = "${PV}" ] ; then
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
fi
IUSE="
- aac aacplus alsa amr ass bindist +bzip2 cdio celt cpudetection debug
+ aac aacplus alsa amr ass bindist bluray +bzip2 cdio celt cpudetection debug
dirac doc +encode faac frei0r gnutls gsm +hardcoded-tables ieee1394 jack
jpeg2k libv4l modplug mp3 network openal openssl oss pic pulseaudio
rtmp schroedinger sdl speex static-libs test theora threads
@@ -54,6 +54,7 @@ RDEPEND="
alsa? ( media-libs/alsa-lib )
amr? ( media-libs/opencore-amr )
ass? ( media-libs/libass )
+ bluray? ( media-libs/libbluray )
bzip2? ( app-arch/bzip2 )
cdio? ( dev-libs/libcdio )
celt? ( >=media-libs/celt-0.11.1 )
@@ -180,7 +181,7 @@ src_configure() {
# Decoders
use amr && { myconf="${myconf} --enable-libopencore-amrwb --enable-libopencore-amrnb" ; version3=" --enable-version3" ; }
- for i in celt gsm dirac modplug rtmp schroedinger speex vpx; do
+ for i in bluray celt gsm dirac modplug rtmp schroedinger speex vpx; do
use ${i} && myconf="${myconf} --enable-lib${i}"
done
use jpeg2k && myconf="${myconf} --enable-libopenjpeg"
diff --git a/media-video/ffmpeg/metadata.xml b/media-video/ffmpeg/metadata.xml
index c91c38927fce..69896b73cc3b 100644
--- a/media-video/ffmpeg/metadata.xml
+++ b/media-video/ffmpeg/metadata.xml
@@ -16,6 +16,7 @@
<flag name="amr">Enables Adaptive Multi-Rate Audio support</flag>
<flag name="aviocat">Install aviocat: cat's an URL to another one, useful for dumping streams.</flag>
<flag name="avx">Adds support for Advanced Vector Extensions instructions (Intel Sandy Bridge, AMD Bulldozer and later chips)</flag>
+ <flag name="bluray">Enable playback of Blu-ray filesystems</flag>
<flag name="cdio">Enables audio CD grabbing with <pkg>dev-libs/libcdio</pkg>.</flag>
<flag name="celt">Adds Xiph CELT audio decoding support via <pkg>media-libs/celt</pkg></flag>
<flag name="cpudetection">Enables runtime CPU detection (useful for bindist, compatibility on other CPUs)</flag>