summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2012-11-18 18:53:58 +0000
committerJulian Ospald <hasufell@gentoo.org>2012-11-18 18:53:58 +0000
commit8c85af90fc7079e088dae4e72452e653e616b7be (patch)
tree2735e13ea2ee9c789dc1dd363abb81292d3df0bc /media-video
parentAdd ~amd64 (diff)
downloadgentoo-2-8c85af90fc7079e088dae4e72452e653e616b7be.tar.gz
gentoo-2-8c85af90fc7079e088dae4e72452e653e616b7be.tar.bz2
gentoo-2-8c85af90fc7079e088dae4e72452e653e616b7be.zip
fix compilation with libav9 wrt #443262
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/ffdiaporama/ChangeLog8
-rw-r--r--media-video/ffdiaporama/ffdiaporama-1.4-r1.ebuild56
-rw-r--r--media-video/ffdiaporama/files/ffdiaporama-1.4-libav9.patch16
3 files changed, 79 insertions, 1 deletions
diff --git a/media-video/ffdiaporama/ChangeLog b/media-video/ffdiaporama/ChangeLog
index d5524af1a05b..68767108ac86 100644
--- a/media-video/ffdiaporama/ChangeLog
+++ b/media-video/ffdiaporama/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/ffdiaporama
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffdiaporama/ChangeLog,v 1.2 2012/10/26 18:15:01 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffdiaporama/ChangeLog,v 1.3 2012/11/18 18:53:58 hasufell Exp $
+
+*ffdiaporama-1.4-r1 (18 Nov 2012)
+
+ 18 Nov 2012; Julian Ospald <hasufell@gentoo.org> +ffdiaporama-1.4-r1.ebuild,
+ +files/ffdiaporama-1.4-libav9.patch:
+ fix compilation with libav9 wrt #443262
26 Oct 2012; Julian Ospald <hasufell@gentoo.org> metadata.xml:
add proxy maintainer Olivier Laurantin
diff --git a/media-video/ffdiaporama/ffdiaporama-1.4-r1.ebuild b/media-video/ffdiaporama/ffdiaporama-1.4-r1.ebuild
new file mode 100644
index 000000000000..44ad8a093ccf
--- /dev/null
+++ b/media-video/ffdiaporama/ffdiaporama-1.4-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffdiaporama/ffdiaporama-1.4-r1.ebuild,v 1.1 2012/11/18 18:53:58 hasufell Exp $
+
+EAPI=5
+
+inherit eutils fdo-mime gnome2-utils qt4-r2
+
+DESCRIPTION="Movie creator from photos and video clips"
+HOMEPAGE="http://ffdiaporama.tuxfamily.org"
+SRC_URI="http://download.tuxfamily.org/${PN}/Archives/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-gfx/exiv2
+ media-libs/libsdl[audio]
+ media-libs/taglib
+ virtual/ffmpeg[encode]
+ >=x11-libs/qt-core-4.8:4
+ >=x11-libs/qt-gui-4.8:4"
+DEPEND="${RDEPEND}"
+
+DOCS=( authors.txt )
+PATCHES=( "${FILESDIR}"/${P}-desktopfile.patch "${FILESDIR}"/${P}-libav9.patch )
+
+src_unpack() {
+ # S=${WORKDIR} would result in unremoved files in
+ # ${WORKDIR}/../build
+ mkdir ${P} || die
+ cd ${P} || die
+ unpack ${A}
+}
+
+src_install() {
+ qt4-r2_src_install
+ doicon -s 32 application-ffDiaporama.png
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}
diff --git a/media-video/ffdiaporama/files/ffdiaporama-1.4-libav9.patch b/media-video/ffdiaporama/files/ffdiaporama-1.4-libav9.patch
new file mode 100644
index 000000000000..b0880387eb78
--- /dev/null
+++ b/media-video/ffdiaporama/files/ffdiaporama-1.4-libav9.patch
@@ -0,0 +1,16 @@
+changeset from:
+http://svn.tuxfamily.org/viewvc.cgi/ffdiaporama_ffdiaporama/trunk/ffDiaporama/src/engine/cDeviceModelDef.cpp?r1=349&r2=350
+
+wrt:
+https://bugs.gentoo.org/show_bug.cgi?id=443262
+--- src/engine/cDeviceModelDef.cpp
++++ src/engine/cDeviceModelDef.cpp
+@@ -717,7 +717,7 @@
+ if (
+ #if LIBAVCODEC_VERSION_INT < AV_VERSION_INT(53,35,0)
+ (p->encode!=NULL)
+- #elif LIBAVCODEC_VERSION_INT < AV_VERSION_INT(54,59,0)
++ #elif LIBAVCODEC_VERSION_INT < AV_VERSION_INT(54,27,0)
+ (p->encode!=NULL)||(p->encode2!=NULL)
+ #else
+ (p->encode2!=NULL)