summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-03-20 10:25:16 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-03-20 10:25:16 +0000
commit825002d1dde838ab95d611364faf1bfc0aa9b721 (patch)
tree06c8606cf29abf826bf0eba2cc60d5ba3b9f5bb7 /media-video
parentMask dev-libs/zziplib-0.13.60-r1 on Darwin, broken due to GCC 4.6 patch, bug ... (diff)
downloadgentoo-2-825002d1dde838ab95d611364faf1bfc0aa9b721.tar.gz
gentoo-2-825002d1dde838ab95d611364faf1bfc0aa9b721.tar.bz2
gentoo-2-825002d1dde838ab95d611364faf1bfc0aa9b721.zip
Fix building with linux-headers >= 2.6.38 wrt #359599.
(Portage version: 2.2.0_alpha28/cvs/Linux x86_64)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/camorama/ChangeLog8
-rw-r--r--media-video/camorama/camorama-0.19-r2.ebuild31
-rw-r--r--media-video/camorama/files/camorama-0.19-no-more-videodev_h.patch14
3 files changed, 36 insertions, 17 deletions
diff --git a/media-video/camorama/ChangeLog b/media-video/camorama/ChangeLog
index 0bdb735dd0ac..a806a6e285fb 100644
--- a/media-video/camorama/ChangeLog
+++ b/media-video/camorama/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/camorama
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/camorama/ChangeLog,v 1.20 2010/04/08 16:29:48 ssuominen Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/camorama/ChangeLog,v 1.21 2011/03/20 10:25:16 ssuominen Exp $
+
+ 20 Mar 2011; Samuli Suominen <ssuominen@gentoo.org> camorama-0.19-r2.ebuild,
+ +files/camorama-0.19-no-more-videodev_h.patch:
+ Fix building with linux-headers >= 2.6.38 wrt #359599.
*camorama-0.19-r2 (08 Apr 2010)
diff --git a/media-video/camorama/camorama-0.19-r2.ebuild b/media-video/camorama/camorama-0.19-r2.ebuild
index 3ee64e247d26..6491dfbeaacd 100644
--- a/media-video/camorama/camorama-0.19-r2.ebuild
+++ b/media-video/camorama/camorama-0.19-r2.ebuild
@@ -1,39 +1,40 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/camorama/camorama-0.19-r2.ebuild,v 1.1 2010/04/08 16:29:48 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/camorama/camorama-0.19-r2.ebuild,v 1.2 2011/03/20 10:25:16 ssuominen Exp $
EAPI=2
inherit eutils gnome2
-DESCRIPTION="a webcam application featuring various image filters."
-HOMEPAGE="http://camorama.fixedgear.org"
+DESCRIPTION="A webcam application featuring various image filters"
+HOMEPAGE="http://git.gnome.org/browse/camorama/"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
-RDEPEND=">=x11-libs/gtk+-2.10:2
- >=gnome-base/libgnomeui-2
- >=gnome-base/libgnome-2
- >=gnome-base/gconf-2
+RDEPEND=">=gnome-base/gconf-2
>=gnome-base/libglade-2
- media-libs/libv4l"
+ >=gnome-base/libgnome-2
+ >=gnome-base/libgnomeui-2
+ media-libs/libv4l
+ x11-libs/gtk+:2"
DEPEND="${RDEPEND}
- sys-devel/gettext
+ dev-util/intltool
dev-util/pkgconfig
- dev-util/intltool"
-
-SCROLLKEEPER_UPDATE="0"
+ sys-devel/gettext"
pkg_setup() {
G2CONF="${G2CONF} --disable-schemas-install"
+ SCROLLKEEPER_UPDATE="0"
}
src_prepare() {
- epatch "${FILESDIR}"/${P}-gconf.patch \
+ epatch \
+ "${FILESDIR}"/${P}-gconf.patch \
"${FILESDIR}"/${P}-fixes.patch \
- "${FILESDIR}"/${P}-libv4l.patch
+ "${FILESDIR}"/${P}-libv4l.patch \
+ "${FILESDIR}"/${P}-no-more-videodev_h.patch
gnome2_src_prepare
}
diff --git a/media-video/camorama/files/camorama-0.19-no-more-videodev_h.patch b/media-video/camorama/files/camorama-0.19-no-more-videodev_h.patch
new file mode 100644
index 000000000000..84c8f68ba72b
--- /dev/null
+++ b/media-video/camorama/files/camorama-0.19-no-more-videodev_h.patch
@@ -0,0 +1,14 @@
+http://pkgs.fedoraproject.org/gitweb/?p=camorama.git;a=blob_plain;f=camorama-0.19-no-more-videodev_h.patch;hb=HEAD
+
+--- src/v4l.h
++++ src/v4l.h
+@@ -12,8 +12,7 @@
+ #include <sys/mman.h>
+ #include <fcntl.h>
+ #include <gtk/gtk.h>
+-#include <linux/types.h>
+-#include <linux/videodev.h>
++#include <libv4l1.h>
+ #include <signal.h>
+ #include <png.h>
+ #include <glade/glade.h>