summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-09-06 09:14:07 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-09-06 09:14:07 +0000
commit705c6ee2ee76e1bf8134097f3857b68206d8065b (patch)
tree01eb90c451f44f678368e44e1004d7a14fc82868 /media-video
parentversion bump, by Peter Volkov <pva@gentoo.org>, bug #283746 (diff)
downloadgentoo-2-705c6ee2ee76e1bf8134097f3857b68206d8065b.tar.gz
gentoo-2-705c6ee2ee76e1bf8134097f3857b68206d8065b.tar.bz2
gentoo-2-705c6ee2ee76e1bf8134097f3857b68206d8065b.zip
Add upstream patch to build against ffmpeg trunk
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/kino/ChangeLog8
-rw-r--r--media-video/kino/files/kino-1.3.3-avutil.patch20
-rw-r--r--media-video/kino/kino-1.3.3.ebuild6
3 files changed, 31 insertions, 3 deletions
diff --git a/media-video/kino/ChangeLog b/media-video/kino/ChangeLog
index db5d00d821bd..d4143970c2c5 100644
--- a/media-video/kino/ChangeLog
+++ b/media-video/kino/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/kino
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/kino/ChangeLog,v 1.115 2009/03/29 13:39:42 patrick Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/kino/ChangeLog,v 1.116 2009/09/06 09:14:07 aballier Exp $
+
+ 06 Sep 2009; Alexis Ballier <aballier@gentoo.org> kino-1.3.3.ebuild,
+ +files/kino-1.3.3-avutil.patch:
+ Add upstream patch to build against ffmpeg trunk
*kino-1.3.3 (29 Mar 2009)
diff --git a/media-video/kino/files/kino-1.3.3-avutil.patch b/media-video/kino/files/kino-1.3.3-avutil.patch
new file mode 100644
index 000000000000..ed6df9fb03c1
--- /dev/null
+++ b/media-video/kino/files/kino-1.3.3-avutil.patch
@@ -0,0 +1,20 @@
+Index: src/frame.cc
+===================================================================
+RCS file: /cvsroot/kino/kino/src/frame.cc,v
+retrieving revision 1.74
+retrieving revision 1.75
+diff -u -B -r1.74 -r1.75
+--- src/frame.cc 26 Dec 2008 05:39:29 -0000 1.74
++++ src/frame.cc 11 Apr 2009 03:53:46 -0000 1.75
+@@ -56,6 +56,11 @@
+ #include "frame.h"
+ #include "preferences.h"
+
++#if LIBAVUTIL_VERSION_INT >= (50<<16)
++#define PIX_FMT_YUV422 PIX_FMT_YUYV422
++#endif
++
++
+ VideoInfo::VideoInfo() : width( 0 ), height( 0 ), isPAL( false )
+ {}
+
diff --git a/media-video/kino/kino-1.3.3.ebuild b/media-video/kino/kino-1.3.3.ebuild
index a8fcdc68eadc..275ae3ae0313 100644
--- a/media-video/kino/kino-1.3.3.ebuild
+++ b/media-video/kino/kino-1.3.3.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/kino/kino-1.3.3.ebuild,v 1.1 2009/03/29 13:39:42 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/kino/kino-1.3.3.ebuild,v 1.2 2009/09/06 09:14:06 aballier Exp $
+
+inherit eutils
DESCRIPTION="Kino is a non-linear DV editor for GNU/Linux"
HOMEPAGE="http://www.kinodv.org/"
@@ -90,6 +92,8 @@ src/page_bttv.cc' po/POTFILES.in || die "sed failed"
# Fix compilation with gcc-4.3, see bug #215160
sed -i -e '/C++ includes/ a\
#include <algorithm>' src/playlist.cc || die "sed failed"
+
+ epatch "${FILESDIR}/${P}-avutil.patch"
}
src_compile() {