summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-03-09 12:01:02 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-03-09 12:01:02 +0000
commit57015ad341b7591d050106ad89583ce9ef32f3b2 (patch)
tree89d0ed0aaa8217c5c0baeaf764bb74dcd019a0f2 /media-video
parentbuild up configure options on the ffuse variable that will be fed to use_enab... (diff)
downloadgentoo-2-57015ad341b7591d050106ad89583ce9ef32f3b2.tar.gz
gentoo-2-57015ad341b7591d050106ad89583ce9ef32f3b2.tar.bz2
gentoo-2-57015ad341b7591d050106ad89583ce9ef32f3b2.zip
handle enabling gpl3 the same way we handle non-free: through myconf and remove the version3 variable
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/ffmpeg/ChangeLog6
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild9
2 files changed, 8 insertions, 7 deletions
diff --git a/media-video/ffmpeg/ChangeLog b/media-video/ffmpeg/ChangeLog
index 3b236cc3da67..afdbe79e3792 100644
--- a/media-video/ffmpeg/ChangeLog
+++ b/media-video/ffmpeg/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/ffmpeg
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.615 2013/03/09 11:46:33 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.616 2013/03/09 12:01:02 aballier Exp $
+
+ 09 Mar 2013; Alexis Ballier <aballier@gentoo.org> ffmpeg-9999.ebuild:
+ handle enabling gpl3 the same way we handle non-free: through myconf and
+ remove the version3 variable
09 Mar 2013; Alexis Ballier <aballier@gentoo.org> ffmpeg-9999.ebuild:
build up configure options on the ffuse variable that will be fed to
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index a8d66bdaf649..64711618e3fd 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999.ebuild,v 1.121 2013/03/09 11:46:33 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999.ebuild,v 1.122 2013/03/09 12:01:02 aballier Exp $
EAPI="4"
@@ -138,8 +138,6 @@ src_configure() {
cd "${BUILD_DIR}"
local myconf="${EXTRA_FFMPEG_CONF}"
- # Set to --enable-version3 if (L)GPL-3 is required
- local version3=""
# options to use as use_enable in the foo[:bar] form.
# This will feed configure with $(use_enable foo bar)
@@ -158,7 +156,7 @@ src_configure() {
# Licensing.
if use aac || use amr ; then
- version3=" --enable-version3"
+ myconf="${myconf} --enable-version3"
fi
if use aacplus || use faac || use fdk ; then
myconf="${myconf} --enable-nonfree"
@@ -193,7 +191,7 @@ src_configure() {
# Decoders
ffuse="${ffuse} amr:libopencore-amrwb amr:libopencore-amrnb jpeg2k:libopenjpeg"
- use amr && version3=" --enable-version3"
+ use amr && myconf="${myconf} --enable-version3"
for i in bluray celt gsm modplug opus rtmp schroedinger speex vorbis vpx; do
ffuse="${ffuse} ${i}:lib${i}"
done
@@ -227,7 +225,6 @@ src_configure() {
# Mandatory configuration
myconf="
--enable-gpl
- ${version3}
--enable-postproc
--enable-avfilter
--disable-stripping