summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-11-23 22:57:08 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-11-23 22:57:08 +0000
commit56a63946da21365308b0f0b760050dee862dc3dc (patch)
treef8a0eb8c0b346e7bb4c40395fe9eefc59c24711f /media-video
parentAdd documentation about the snapshot, timezone and aspell USE flags. (diff)
downloadgentoo-2-56a63946da21365308b0f0b760050dee862dc3dc.tar.gz
gentoo-2-56a63946da21365308b0f0b760050dee862dc3dc.tar.bz2
gentoo-2-56a63946da21365308b0f0b760050dee862dc3dc.zip
add a patch to build against libavformat 52.0.0
(Portage version: 2.1.3.19)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/dvbcut/ChangeLog6
-rw-r--r--media-video/dvbcut/dvbcut-0.5.4-r1.ebuild3
-rw-r--r--media-video/dvbcut/files/dvbcut-0.5.4-avformat-api-changes.patch16
3 files changed, 23 insertions, 2 deletions
diff --git a/media-video/dvbcut/ChangeLog b/media-video/dvbcut/ChangeLog
index 0b5c15e02fc4..5ab68983e006 100644
--- a/media-video/dvbcut/ChangeLog
+++ b/media-video/dvbcut/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/dvbcut
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/dvbcut/ChangeLog,v 1.8 2007/10/18 14:37:02 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/dvbcut/ChangeLog,v 1.9 2007/11/23 22:57:07 aballier Exp $
+
+ 23 Nov 2007; Alexis Ballier <aballier@gentoo.org>
+ +files/dvbcut-0.5.4-avformat-api-changes.patch, dvbcut-0.5.4-r1.ebuild:
+ add a patch to build against libavformat 52.0.0
*dvbcut-0.5.4-r1 (18 Oct 2007)
diff --git a/media-video/dvbcut/dvbcut-0.5.4-r1.ebuild b/media-video/dvbcut/dvbcut-0.5.4-r1.ebuild
index 68bdc8a5699b..5dd0249e1600 100644
--- a/media-video/dvbcut/dvbcut-0.5.4-r1.ebuild
+++ b/media-video/dvbcut/dvbcut-0.5.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/dvbcut/dvbcut-0.5.4-r1.ebuild,v 1.1 2007/10/18 14:37:02 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/dvbcut/dvbcut-0.5.4-r1.ebuild,v 1.2 2007/11/23 22:57:07 aballier Exp $
inherit qt3 eutils
@@ -39,6 +39,7 @@ src_unpack() {
epatch "${FILESDIR}/${P}-gcc42.patch"
epatch "${FILESDIR}/${P}-ffmpeg-compat2.patch"
epatch "${FILESDIR}/${P}-ffmpeg-compat3.patch"
+ epatch "${FILESDIR}/${P}-avformat-api-changes.patch"
}
src_compile() {
diff --git a/media-video/dvbcut/files/dvbcut-0.5.4-avformat-api-changes.patch b/media-video/dvbcut/files/dvbcut-0.5.4-avformat-api-changes.patch
new file mode 100644
index 000000000000..e9e7a58b188e
--- /dev/null
+++ b/media-video/dvbcut/files/dvbcut-0.5.4-avformat-api-changes.patch
@@ -0,0 +1,16 @@
+Index: src/lavfmuxer.cpp
+===================================================================
+--- src/lavfmuxer.cpp (revision 101)
++++ src/lavfmuxer.cpp (working copy)
+@@ -120,7 +120,11 @@
+ if (fileopened) {
+ av_write_trailer(avfc);
+ if (!(fmt->flags & AVFMT_NOFILE))
++#if LIBAVFORMAT_VERSION_INT >= ((52<<16)+(0<<8)+0)
++ url_fclose(avfc->pb);
++#else
+ url_fclose(&avfc->pb);
++#endif
+ }
+
+ av_free(avfc);