summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-08-14 20:51:16 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-08-14 20:51:16 +0000
commit565ae760d85134f1b31a00ff3079977c74081494 (patch)
tree5f42ffbfc4827f4db80fafd3a07fa342a48db979 /media-video
parentinstall mp42ts since we build it, bug #459630 by Reuben Martin (diff)
downloadgentoo-2-565ae760d85134f1b31a00ff3079977c74081494.tar.gz
gentoo-2-565ae760d85134f1b31a00ff3079977c74081494.tar.bz2
gentoo-2-565ae760d85134f1b31a00ff3079977c74081494.zip
Respect LDFLAGS and fix underlinkage of the pulse module. Ported from bug #331067
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/gpac/ChangeLog7
-rw-r--r--media-video/gpac/files/gpac-0.5.0-respect_ldflags.patch45
-rw-r--r--media-video/gpac/gpac-0.5.0.ebuild5
3 files changed, 54 insertions, 3 deletions
diff --git a/media-video/gpac/ChangeLog b/media-video/gpac/ChangeLog
index 782837307542..7718ec1adc3a 100644
--- a/media-video/gpac/ChangeLog
+++ b/media-video/gpac/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/gpac
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/gpac/ChangeLog,v 1.110 2013/08/14 20:38:04 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/gpac/ChangeLog,v 1.111 2013/08/14 20:51:16 aballier Exp $
+
+ 14 Aug 2013; Alexis Ballier <aballier@gentoo.org> gpac-0.5.0.ebuild,
+ +files/gpac-0.5.0-respect_ldflags.patch:
+ Respect LDFLAGS and fix underlinkage of the pulse module. Ported from bug
+ #331067
14 Aug 2013; Alexis Ballier <aballier@gentoo.org> gpac-0.5.0.ebuild,
+files/gpac-0.5.0-mp42ts.patch:
diff --git a/media-video/gpac/files/gpac-0.5.0-respect_ldflags.patch b/media-video/gpac/files/gpac-0.5.0-respect_ldflags.patch
new file mode 100644
index 000000000000..3b37cfe0dfc8
--- /dev/null
+++ b/media-video/gpac/files/gpac-0.5.0-respect_ldflags.patch
@@ -0,0 +1,45 @@
+http://bugs.gentoo.org/258331
+http://bugs.gentoo.org/310257
+http://bugs.gentoo.org/331067
+
+Also fix underlinkage of the pulse module.
+
+Index: gpac/modules/jack/Makefile
+===================================================================
+--- gpac.orig/modules/jack/Makefile
++++ gpac/modules/jack/Makefile
+@@ -25,7 +25,7 @@ LIB=gm_jack.$(DYN_LIB_SUFFIX)
+ all: $(LIB)
+
+ $(LIB): $(OBJS)
+- $(CC) $(SHFLAGS) -o ../../bin/gcc/$@ $(OBJS) $(EXTRALIBS) -L../../bin/gcc -lgpac -L/usr/lib -ljack
++ $(CC) $(SHFLAGS) $(LDFLAGS) -o ../../bin/gcc/$@ $(OBJS) $(EXTRALIBS) -L../../bin/gcc -lgpac -L/usr/lib -ljack
+
+
+ %.o: %.c
+Index: gpac/modules/oss_audio/Makefile
+===================================================================
+--- gpac.orig/modules/oss_audio/Makefile
++++ gpac/modules/oss_audio/Makefile
+@@ -35,7 +35,7 @@ LIB=gm_oss_audio.$(DYN_LIB_SUFFIX)
+ all: $(LIB)
+
+ $(LIB): $(OBJS)
+- $(CC) $(SHFLAGS) -o ../../bin/gcc/$@ $(OBJS) $(EXTRALIBS) -L../../bin/gcc -lgpac $(OSS_LDFLAGS)
++ $(CC) $(SHFLAGS) $(LDFLAGS) -o ../../bin/gcc/$@ $(OBJS) $(EXTRALIBS) -L../../bin/gcc -lgpac $(OSS_LDFLAGS)
+ ifeq ($(STATICBUILD),yes)
+ $(CC) $(SHFLAGS) $(LDFLAGS) -o ../../bin/gcc/gm_oss_audio-static.$(DYN_LIB_SUFFIX) $(OBJS) $(EXTRALIBS) -L../../bin/gcc -lgpac_static $(OSS_LDFLAGS)
+ endif
+Index: gpac/modules/pulseaudio/Makefile
+===================================================================
+--- gpac.orig/modules/pulseaudio/Makefile
++++ gpac/modules/pulseaudio/Makefile
+@@ -25,7 +25,7 @@ LIB=gm_pulseaudio.$(DYN_LIB_SUFFIX)
+ all: $(LIB)
+
+ $(LIB): $(OBJS)
+- $(CC) $(SHFLAGS) -o ../../bin/gcc/$@ $(OBJS) $(EXTRALIBS) -L../../bin/gcc -lgpac -L/usr/lib -lpulse-simple
++ $(CC) $(SHFLAGS) $(LDFLAGS) -o ../../bin/gcc/$@ $(OBJS) $(EXTRALIBS) -L../../bin/gcc -lgpac -L/usr/lib -lpulse-simple -lpulse
+
+
+ %.o: %.c
diff --git a/media-video/gpac/gpac-0.5.0.ebuild b/media-video/gpac/gpac-0.5.0.ebuild
index 64999e8ddcaf..a297628ff4a5 100644
--- a/media-video/gpac/gpac-0.5.0.ebuild
+++ b/media-video/gpac/gpac-0.5.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/gpac/gpac-0.5.0.ebuild,v 1.9 2013/08/14 20:38:04 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/gpac/gpac-0.5.0.ebuild,v 1.10 2013/08/14 20:51:16 aballier Exp $
EAPI=4
@@ -62,7 +62,8 @@ src_prepare() {
"${FILESDIR}"/${P}-build-fixes.patch \
"${FILESDIR}"/${P}-libav9.patch \
"${FILESDIR}"/${P}-ffmpeg2.patch \
- "${FILESDIR}"/${P}-mp42ts.patch
+ "${FILESDIR}"/${P}-mp42ts.patch \
+ "${FILESDIR}"/${P}-respect_ldflags.patch
# remove last of internal ogg
sed -i \