summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Hildebrand <zypher@gentoo.org>2004-03-02 15:14:06 +0000
committerMarc Hildebrand <zypher@gentoo.org>2004-03-02 15:14:06 +0000
commit4b121197a1c95f9246d0fb5fd63fcb3aa1c20946 (patch)
tree5630703bd51916e70dbfdaa0d2fe625f933b47bf /media-video
parentFix missing info dir entries, closing bug #43424. (Manifest recommit) (diff)
downloadgentoo-2-4b121197a1c95f9246d0fb5fd63fcb3aa1c20946.tar.gz
gentoo-2-4b121197a1c95f9246d0fb5fd63fcb3aa1c20946.tar.bz2
gentoo-2-4b121197a1c95f9246d0fb5fd63fcb3aa1c20946.zip
initial commit
Diffstat (limited to 'media-video')
-rw-r--r--media-video/gephex/ChangeLog8
-rw-r--r--media-video/gephex/Manifest4
-rw-r--r--media-video/gephex/files/0.0.4-alsa-api-fix.patch29
-rw-r--r--media-video/gephex/files/0.0.4-makefile.in.patch19
-rw-r--r--media-video/gephex/files/digest-gephex-0.0.41
-rw-r--r--media-video/gephex/gephex-0.0.4.ebuild48
-rw-r--r--media-video/gephex/metadata.xml9
7 files changed, 118 insertions, 0 deletions
diff --git a/media-video/gephex/ChangeLog b/media-video/gephex/ChangeLog
new file mode 100644
index 000000000000..96c82d700d90
--- /dev/null
+++ b/media-video/gephex/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for media-video/gephex
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/gephex/ChangeLog,v 1.1 2004/03/02 15:14:06 zypher Exp $
+
+*gephex-0.0.4 (14 Dez 2003)
+
+ 02 Mar 2004; Marc Hildebrand <zypher@gentoo.org>; gephex-0.0.4.ebuild :
+ Initial ebuild.
diff --git a/media-video/gephex/Manifest b/media-video/gephex/Manifest
new file mode 100644
index 000000000000..a3a40d3a7828
--- /dev/null
+++ b/media-video/gephex/Manifest
@@ -0,0 +1,4 @@
+MD5 1bbc08e87e7c533987d3f0e86067152e gephex-0.0.4.ebuild 1093
+MD5 8ce45a490b11be332445c5166c2be858 files/digest-gephex-0.0.4 65
+MD5 d0c894eccb6239538b954cb1d6680c5d files/0.0.4-makefile.in.patch 873
+MD5 0e6024af9a9dd49daca8977ba601c8f5 files/0.0.4-alsa-api-fix.patch 832
diff --git a/media-video/gephex/files/0.0.4-alsa-api-fix.patch b/media-video/gephex/files/0.0.4-alsa-api-fix.patch
new file mode 100644
index 000000000000..513243ffa186
--- /dev/null
+++ b/media-video/gephex/files/0.0.4-alsa-api-fix.patch
@@ -0,0 +1,29 @@
+--- orig/modules/src/audioinmodule/alsadriver.cpp
++++ mod/modules/src/audioinmodule/alsadriver.cpp
+@@ -125,8 +125,8 @@
+ throw std::runtime_error(os.str().c_str());
+ }
+
+- err = snd_pcm_hw_params_set_rate_near(capture_handle, hw_params,
+- sample_rate, 0);
++ err = snd_pcm_hw_params_set_rate(capture_handle, hw_params,
++ sample_rate, 0);
+ if (err < 0)
+ {
+ std::ostringstream os;
+
+
+--- orig/modules/src/audiooutmodule/alsaoutdriver.cpp
++++ mod/modules/src/audiooutmodule/alsaoutdriver.cpp
+@@ -129,7 +129,7 @@
+ throw std::runtime_error(os.str().c_str());
+ }
+
+- err = snd_pcm_hw_params_set_rate_near(handle, hw_params,
++ err = snd_pcm_hw_params_set_rate(handle, hw_params,
+ sample_rate, 0);
+ if (err < 0)
+ {
+
+
+
diff --git a/media-video/gephex/files/0.0.4-makefile.in.patch b/media-video/gephex/files/0.0.4-makefile.in.patch
new file mode 100644
index 000000000000..0809adcbea8f
--- /dev/null
+++ b/media-video/gephex/files/0.0.4-makefile.in.patch
@@ -0,0 +1,19 @@
+--- data/Makefile.in 2003-12-16 02:04:22.000000000 +0100
++++ data/Makefile.in.new 2004-03-02 10:29:54.342726496 +0100
+@@ -284,11 +284,11 @@
+ gephex-wrapper: gephex-wrapper.template
+ cat gephex-wrapper.template | sed s:__PREFIX__:$(prefix):g - > gephex-wrapper
+ install-exec-hook:
+- chmod ug+x $(bindir)/gephex-wrapper
+- rm -rf $(bindir)/gephex-engine
+- rm -rf $(bindir)/gephex-gui
+- ln -s $(bindir)/gephex-wrapper $(bindir)/gephex-engine
+- ln -s $(bindir)/gephex-wrapper $(bindir)/gephex-gui
++ chmod ug+x $(DESTDIR)$(bindir)/gephex-wrapper
++ rm -rf $(DESTDIR)$(bindir)/gephex-engine
++ rm -rf $(DESTDIR)$(bindir)/gephex-gui
++ ln -s gephex-wrapper $(DESTDIR)$(bindir)/gephex-engine
++ ln -s gephex-wrapper $(DESTDIR)$(bindir)/gephex-gui
+
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/media-video/gephex/files/digest-gephex-0.0.4 b/media-video/gephex/files/digest-gephex-0.0.4
new file mode 100644
index 000000000000..2f031f9bb0ac
--- /dev/null
+++ b/media-video/gephex/files/digest-gephex-0.0.4
@@ -0,0 +1 @@
+MD5 2face73cd1316bb9f8e114f62c89b5a8 gephex-0.0.4.tar.gz 1810733
diff --git a/media-video/gephex/gephex-0.0.4.ebuild b/media-video/gephex/gephex-0.0.4.ebuild
new file mode 100644
index 000000000000..cb70e063081b
--- /dev/null
+++ b/media-video/gephex/gephex-0.0.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/gephex/gephex-0.0.4.ebuild,v 1.1 2004/03/02 15:14:06 zypher Exp $
+
+MY_P=${P/_/}
+DESCRIPTION="GePhex is a modular video effect framework."
+HOMEPAGE="http://www.gephex.org"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+IUSE="static mmx aalib"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+S="${WORKDIR}/${MY_P}"
+
+DEPEND="virtual/x11
+ >=x11-libs/qt-3
+ >=media-libs/libsdl-1.2.6-r3
+ >=media-libs/libpng-1.2.5-r4
+ >=media-libs/sdl-ttf-2.0.6
+ >=media-libs/alsa-lib-0.9.8
+ >=media-video/avifile-0.7.38.20030710
+ aalib? ( >=media-libs/aalib-1.4_rc4-r2 )"
+
+RDEPEND=${DEPEND}
+
+src_compile() {
+ cd ${S}
+ epatch ${FILESDIR}/0.0.4-alsa-api-fix.patch || die
+ epatch ${FILESDIR}/0.0.4-makefile.in.patch || die
+ local myconf
+ myconf="--with-gnu-ld"
+ econf \
+ `use_enable mmx` \
+ `use_enable static` \
+ ${myconf} \
+ || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+ einfo "Please read /usr/share/doc/gephex/html/documentation.html to get started."
+
+}
diff --git a/media-video/gephex/metadata.xml b/media-video/gephex/metadata.xml
new file mode 100644
index 000000000000..210f2b0d5ddb
--- /dev/null
+++ b/media-video/gephex/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>video</herd>
+<maintainer>
+ <email>zypher@gentoo.org</email>
+ <name>Marc Hildebrand</name>
+</maintainer>
+</pkgmetadata>