summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2007-04-27 14:13:19 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2007-04-27 14:13:19 +0000
commit49b5a4acb649c222758b6630cf23994e0e3c500a (patch)
tree87916c5cc1e3636fb357a7de20c7333e420b5174 /media-video
parentslotting 2->1 (diff)
downloadgentoo-2-49b5a4acb649c222758b6630cf23994e0e3c500a.tar.gz
gentoo-2-49b5a4acb649c222758b6630cf23994e0e3c500a.tar.bz2
gentoo-2-49b5a4acb649c222758b6630cf23994e0e3c500a.zip
Version bumped. Added depend to virtual/opengl.
(Portage version: 2.1.2.5)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/ttcut/ChangeLog7
-rw-r--r--media-video/ttcut/files/digest-ttcut-0.19.23
-rw-r--r--media-video/ttcut/ttcut-0.19.2.ebuild51
3 files changed, 60 insertions, 1 deletions
diff --git a/media-video/ttcut/ChangeLog b/media-video/ttcut/ChangeLog
index f23beb564b66..0fd55d2e1b81 100644
--- a/media-video/ttcut/ChangeLog
+++ b/media-video/ttcut/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/ttcut
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ttcut/ChangeLog,v 1.1 2007/04/21 12:26:43 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ttcut/ChangeLog,v 1.2 2007/04/27 14:13:19 zzam Exp $
+
+*ttcut-0.19.2 (27 Apr 2007)
+
+ 27 Apr 2007; Matthias Schwarzott <zzam@gentoo.org> +ttcut-0.19.2.ebuild:
+ Version bumped. Added depend to virtual/opengl.
*ttcut-0.11.4_alpha (21 Apr 2007)
diff --git a/media-video/ttcut/files/digest-ttcut-0.19.2 b/media-video/ttcut/files/digest-ttcut-0.19.2
new file mode 100644
index 000000000000..77f9f5e25375
--- /dev/null
+++ b/media-video/ttcut/files/digest-ttcut-0.19.2
@@ -0,0 +1,3 @@
+MD5 77b6abf5279d2adbe1421e313125402f ttcut-0.19.2.tar.gz 373326
+RMD160 d6c5f3586172a0788390ffb99ff7e37b63dc4022 ttcut-0.19.2.tar.gz 373326
+SHA256 85dacf949985785cbbfbcf8d5116a549cee6bcebfa356026de447ffe24757d85 ttcut-0.19.2.tar.gz 373326
diff --git a/media-video/ttcut/ttcut-0.19.2.ebuild b/media-video/ttcut/ttcut-0.19.2.ebuild
new file mode 100644
index 000000000000..0b0832e3521b
--- /dev/null
+++ b/media-video/ttcut/ttcut-0.19.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/ttcut/ttcut-0.19.2.ebuild,v 1.1 2007/04/27 14:13:19 zzam Exp $
+
+inherit eutils qt4
+
+DESCRIPTION="Tool for removing advertisements from recorded MPEG files"
+HOMEPAGE="http://ttcut.tritime.org/"
+SRC_URI="mirror://berlios/${PN}/${P/_/-}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="ttmpeg2"
+
+DEPEND="$(qt4_min_version 4.1)
+ >=media-libs/libmpeg2-0.4.0
+ virtual/opengl"
+
+RDEPEND="${DEPEND}
+ media-video/mplayer
+ media-video/transcode
+ media-video/ffmpeg"
+
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ if use ttmpeg2 ; then
+
+ qmake ttmpeg2.pro -o Makefile.ttmpeg2 || \
+ die "configuring ttpmeg2 failed"
+ make -f Makefile.ttmpeg2 || die "emake ttmpeg2 failed"
+ fi
+
+ qmake ttcut.pro -o Makefile.ttcut || \
+ die "configuring ttcut failed"
+ emake -f Makefile.ttcut || die "emake failed"
+}
+
+src_install() {
+ if use ttmpeg2 ; then
+ dobin ttmpeg2 || die "Couldn't install ttmpeg2"
+ make_desktop_entry ttmpeg2 TTMpeg2 "" "AudioVideo;Video;AudioVideoEditing" || \
+ die "Couldn't make ttmpeg2 desktop entry"
+ fi
+
+ dobin ttcut || die "Couldn't install ttcut"
+ make_desktop_entry ttcut TTCut "" "AudioVideo;Video;AudioVideoEditing" || \
+ die "Couldn't make ttcut desktop entry"
+ dodoc AUTHORS BUGS CHANGELOG COPYING INSTALL README TODO || die "Couldn't install documentation"
+}