summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-03-31 21:26:12 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-03-31 21:26:12 +0000
commit34cbb1f20b9ec962449f15fcdd5ff1c9313e1143 (patch)
tree0a93a7d2b306e40b98d2e17ac82a80ffef28eb72 /media-video
parentSmall cleanup, fixes #184510 again. Finally. For the last time. (diff)
downloadgentoo-2-34cbb1f20b9ec962449f15fcdd5ff1c9313e1143.tar.gz
gentoo-2-34cbb1f20b9ec962449f15fcdd5ff1c9313e1143.tar.bz2
gentoo-2-34cbb1f20b9ec962449f15fcdd5ff1c9313e1143.zip
Bump to 0.24
(Portage version: 2.2_rc28/cvs/Linux x86_64)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/ffmpeg2theora/ChangeLog8
-rw-r--r--media-video/ffmpeg2theora/ffmpeg2theora-0.24.ebuild36
2 files changed, 43 insertions, 1 deletions
diff --git a/media-video/ffmpeg2theora/ChangeLog b/media-video/ffmpeg2theora/ChangeLog
index 1a1c37105def..52f3524238a9 100644
--- a/media-video/ffmpeg2theora/ChangeLog
+++ b/media-video/ffmpeg2theora/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/ffmpeg2theora
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg2theora/ChangeLog,v 1.32 2009/03/10 19:40:59 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg2theora/ChangeLog,v 1.33 2009/03/31 21:26:12 patrick Exp $
+
+*ffmpeg2theora-0.24 (31 Mar 2009)
+
+ 31 Mar 2009; Patrick Lauer <patrick@gentoo.org>
+ +ffmpeg2theora-0.24.ebuild:
+ Bump to 0.24
*ffmpeg2theora-0.23-r1 (10 Mar 2009)
diff --git a/media-video/ffmpeg2theora/ffmpeg2theora-0.24.ebuild b/media-video/ffmpeg2theora/ffmpeg2theora-0.24.ebuild
new file mode 100644
index 000000000000..4c49b99d17de
--- /dev/null
+++ b/media-video/ffmpeg2theora/ffmpeg2theora-0.24.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg2theora/ffmpeg2theora-0.24.ebuild,v 1.1 2009/03/31 21:26:12 patrick Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="A simple converter to create Ogg Theora files."
+HOMEPAGE="http://www.v2v.cc/~j/ffmpeg2theora/index.html"
+SRC_URI="http://www.v2v.cc/~j/ffmpeg2theora/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="
+ || ( <media-video/ffmpeg-9999[vhook]
+ >=media-video/ffmpeg-9999 )
+ >=media-libs/libvorbis-1.1
+ >=media-libs/libogg-1.1
+ >=media-libs/libtheora-1.0_beta1[encode]
+ media-libs/libkate"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=dev-util/scons-1.0.0"
+
+src_compile() {
+ scons APPEND_CFLAGS="${CFLAGS}" APPEND_LINKFLAGS="${LDFLAGS}" || die "scons failed"
+}
+
+src_install() {
+ scons destdir="${D}" prefix=/usr mandir=PREFIX/share/man install || die "install failed"
+ dodoc AUTHORS ChangeLog README TODO || die
+}