summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2011-12-02 23:32:34 +0000
committerSteve Dibb <beandog@gentoo.org>2011-12-02 23:32:34 +0000
commit30216a77213fe4993c5cfbebec67129af9937442 (patch)
treec5d703ffe7570c74a4a3afcaf04b1642a5a85fb1 /media-video
parentDelete custom pulseaudio/mousewarp patches that are obsolete in newer versions. (diff)
downloadgentoo-2-30216a77213fe4993c5cfbebec67129af9937442.tar.gz
gentoo-2-30216a77213fe4993c5cfbebec67129af9937442.tar.bz2
gentoo-2-30216a77213fe4993c5cfbebec67129af9937442.zip
Cleanup ebuild, patch makefile, QA variables
(Portage version: 2.1.10.11/cvs/Linux i686)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/makemkv/files/makemkv-1.6.16-makefile.linux.patch20
-rw-r--r--media-video/makemkv/makemkv-1.6.16.ebuild6
2 files changed, 25 insertions, 1 deletions
diff --git a/media-video/makemkv/files/makemkv-1.6.16-makefile.linux.patch b/media-video/makemkv/files/makemkv-1.6.16-makefile.linux.patch
new file mode 100644
index 000000000000..72faa15faa98
--- /dev/null
+++ b/media-video/makemkv/files/makemkv-1.6.16-makefile.linux.patch
@@ -0,0 +1,20 @@
+--- makemkv_v1.6.16_oss/makefile.linux.orig 2011-12-02 15:26:10.997323145 -0700
++++ makemkv_v1.6.16_oss/makefile.linux 2011-12-02 16:28:26.966323351 -0700
+@@ -8,7 +8,7 @@
+ MOC=moc
+ endif
+
+-CXXOPTS=-Os -D_GNU_SOURCE -D_linux_
++CXXOPTS=-D_GNU_SOURCE -D_linux_
+
+ BUILDINFO_ARCH_NAME=$(shell $(GCC) -dumpmachine)
+ BUILDINFO_BUILD_DATE=$(shell date)
+@@ -33,7 +33,7 @@
+ install -t $(DESTDIR)/usr/bin out/makemkv
+
+ out/%: out/%.full
+- objcopy --strip-all --strip-debug --strip-unneeded --discard-all $< $@
++ objcopy --discard-all $< $@
+
+ out/libdriveio.so.0.full:
+ mkdir -p out
diff --git a/media-video/makemkv/makemkv-1.6.16.ebuild b/media-video/makemkv/makemkv-1.6.16.ebuild
index 5897c5f35ef7..65be47056f51 100644
--- a/media-video/makemkv/makemkv-1.6.16.ebuild
+++ b/media-video/makemkv/makemkv-1.6.16.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/makemkv/makemkv-1.6.16.ebuild,v 1.2 2011/12/02 20:50:54 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/makemkv/makemkv-1.6.16.ebuild,v 1.3 2011/12/02 23:32:34 beandog Exp $
EAPI=3
@@ -27,7 +27,11 @@ DEPEND="x11-libs/qt-gui:4
x11-libs/qt-dbus:4"
RDEPEND="${DEPEND}"
+QA_PRESTRIPPED="/usr/bin/makemkvcon"
+QA_EXECSTACK="usr/bin/makemkvcon"
+
src_prepare() {
+ epatch "${FILESDIR}/${P}-makefile.linux.patch"
cd "${MY_P}"
}