summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-04-04 18:36:30 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-04-04 18:36:30 +0000
commit2e1d97693e9c335fb28162586f4cafe7832b7ef8 (patch)
treec1a57f5873adf64a993aca5bdac78897b59080b9 /media-video
parentDelete older ebuild. (diff)
downloadgentoo-2-2e1d97693e9c335fb28162586f4cafe7832b7ef8.tar.gz
gentoo-2-2e1d97693e9c335fb28162586f4cafe7832b7ef8.tar.bz2
gentoo-2-2e1d97693e9c335fb28162586f4cafe7832b7ef8.zip
Fix building with media-libs/libpng >= 1.5.
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/ffmpegthumbnailer/ChangeLog7
-rw-r--r--media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.6.ebuild6
-rw-r--r--media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.6-libpng15.patch11
3 files changed, 20 insertions, 4 deletions
diff --git a/media-video/ffmpegthumbnailer/ChangeLog b/media-video/ffmpegthumbnailer/ChangeLog
index 9aedb39ed80e..4473034f43eb 100644
--- a/media-video/ffmpegthumbnailer/ChangeLog
+++ b/media-video/ffmpegthumbnailer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/ffmpegthumbnailer
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ChangeLog,v 1.118 2011/04/02 14:25:17 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ChangeLog,v 1.119 2011/04/04 18:36:30 ssuominen Exp $
+
+ 04 Apr 2011; Samuli Suominen <ssuominen@gentoo.org>
+ ffmpegthumbnailer-2.0.6.ebuild,
+ +files/ffmpegthumbnailer-2.0.6-libpng15.patch:
+ Fix building with media-libs/libpng >= 1.5.
02 Apr 2011; Raúl Porcel <armin76@gentoo.org>
ffmpegthumbnailer-2.0.6.ebuild:
diff --git a/media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.6.ebuild b/media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.6.ebuild
index 2e2e3ad40510..6ce151eb259d 100644
--- a/media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.6.ebuild
+++ b/media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.6.ebuild,v 1.7 2011/04/02 14:25:17 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.6.ebuild,v 1.8 2011/04/04 18:36:30 ssuominen Exp $
EAPI=2
inherit autotools eutils
@@ -23,7 +23,7 @@ DEPEND="${COMMON_DEPEND}
dev-util/pkgconfig"
src_prepare() {
- epatch "${FILESDIR}"/${P}-{asneeded,flags,gcc46}.patch
+ epatch "${FILESDIR}"/${P}-{asneeded,flags,gcc46,libpng15}.patch
eautoreconf
}
@@ -39,5 +39,5 @@ src_configure() {
src_install() {
emake DESTDIR="${D}" install || die
dodoc AUTHORS ChangeLog README
- find "${D}" -name '*.la' -delete
+ find "${D}" -name '*.la' -exec rm -f {} +
}
diff --git a/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.6-libpng15.patch b/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.6-libpng15.patch
new file mode 100644
index 000000000000..893f2277951b
--- /dev/null
+++ b/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.6-libpng15.patch
@@ -0,0 +1,11 @@
+--- libffmpegthumbnailer/pngwriter.cpp
++++ libffmpegthumbnailer/pngwriter.cpp
+@@ -49,7 +49,7 @@
+ , m_InfoPtr(NULL)
+ {
+ init();
+- png_set_write_fn(m_PngPtr, (voidp) &outputBuffer, writeDataCallback, NULL);
++ png_set_write_fn(m_PngPtr, (png_voidp) &outputBuffer, writeDataCallback, NULL);
+ }
+
+ PngWriter::~PngWriter()