summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomás Touceda <chiiph@gentoo.org>2010-10-05 22:15:07 +0000
committerTomás Touceda <chiiph@gentoo.org>2010-10-05 22:15:07 +0000
commit2b847f134d0bc96fd54c427fb15f122d4b71a323 (patch)
treec0f116f04d19d63692d0d9f85ae0142b7e40b6b2 /media-video
parentMask KDE SC 4.5.2 because of unkeyworded deps bug #336158 (diff)
downloadgentoo-2-2b847f134d0bc96fd54c427fb15f122d4b71a323.tar.gz
gentoo-2-2b847f134d0bc96fd54c427fb15f122d4b71a323.tar.bz2
gentoo-2-2b847f134d0bc96fd54c427fb15f122d4b71a323.zip
Add myself as co-maintainer and version bump
(Portage version: 2.2_rc86/cvs/Linux i686)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/2mandvd/2mandvd-1.4.ebuild77
-rw-r--r--media-video/2mandvd/ChangeLog8
-rw-r--r--media-video/2mandvd/metadata.xml18
3 files changed, 95 insertions, 8 deletions
diff --git a/media-video/2mandvd/2mandvd-1.4.ebuild b/media-video/2mandvd/2mandvd-1.4.ebuild
new file mode 100644
index 000000000000..1dfbb53360c7
--- /dev/null
+++ b/media-video/2mandvd/2mandvd-1.4.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/2mandvd/2mandvd-1.4.ebuild,v 1.1 2010/10/05 22:15:07 chiiph Exp $
+
+EAPI="2"
+LANGS="de en he it pl pt ru"
+
+inherit qt4-r2
+
+MY_PN="2ManDVD"
+
+DESCRIPTION="The successor of ManDVD"
+HOMEPAGE="http://kde-apps.org/content/show.php?content=99450"
+SRC_URI="http://download.tuxfamily.org/${PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="dev-lang/perl
+ media-video/dvdauthor
+ media-video/ffmpegthumbnailer
+ media-fonts/dejavu
+ media-sound/sox
+ media-video/mplayer
+ media-libs/netpbm
+ media-video/mjpegtools
+ || ( app-cdr/cdrkit app-cdr/cdrtools )
+ media-libs/xine-lib
+ x11-libs/qt-gui:4
+ x11-libs/qt-webkit:4"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-fix-const-char-concatenation.patch"
+)
+
+S="${WORKDIR}/${MY_PN}"
+
+src_prepare() {
+ # fix installation path
+ for file in mainfrm.cpp media_browser.cpp rendering.cpp; do
+ sed -i "s:qApp->applicationDirPath().\?+.\?\":\"/usr/share/${PN}/:" \
+ ${file} || die "sed failed"
+ done
+
+ sed -i "s:qApp->applicationDirPath():\"/usr/share/${PN}/\":" \
+ mainfrm.cpp || die "sed failed"
+
+ qt4-r2_src_prepare
+}
+
+src_configure() {
+ eqmake4 ${MY_PN}.pro
+}
+
+src_install() {
+ newbin 2ManDVD ${PN} || die "newbin failed"
+ dodoc README.txt || die "dodoc failed"
+ insinto /usr/share/${PN}/
+ doins -r Bibliotheque || die "failed to install Bibliotheque"
+ doins -r Interface || die "failed to install Interface"
+ #bug 305625
+ doins fake.pl || die "failed to install fake.pl"
+ doicon Interface/mandvdico.png || die "doicon failed"
+ # Desktop icon
+ make_desktop_entry ${PN} 2ManDVD mandvdico "Qt;AudioVideo;Video" \
+ || die "make_desktop_entry failed"
+ insinto /usr/share/${PN}
+ for lang in ${LINGUAS}; do
+ for x in ${LANGS}; do
+ [[ ${lang} == ${x} ]] && doins ${PN}_${x}.qm
+ done
+ done
+ [[ -z ${LINGUAS} ]] && doins ${PN}_en.qm
+}
diff --git a/media-video/2mandvd/ChangeLog b/media-video/2mandvd/ChangeLog
index 42da121fff8e..0ff229a926d3 100644
--- a/media-video/2mandvd/ChangeLog
+++ b/media-video/2mandvd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/2mandvd
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/2mandvd/ChangeLog,v 1.13 2010/09/12 07:10:20 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/2mandvd/ChangeLog,v 1.14 2010/10/05 22:15:07 chiiph Exp $
+
+*2mandvd-1.4 (05 Oct 2010)
+
+ 05 Oct 2010; Tomas Touceda <chiiph@gentoo.org> +2mandvd-1.4.ebuild,
+ metadata.xml:
+ Add myself as co-maintainer and version bump
12 Sep 2010; Torsten Veller <tove@gentoo.org> 2mandvd-1.3.5.ebuild:
Add missing die: || "..." -> || die "..."
diff --git a/media-video/2mandvd/metadata.xml b/media-video/2mandvd/metadata.xml
index d5f9562e2df2..5b479157f149 100644
--- a/media-video/2mandvd/metadata.xml
+++ b/media-video/2mandvd/metadata.xml
@@ -1,12 +1,16 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>qt</herd>
-<maintainer>
-<email>hwoarang@gentoo.org</email>
-<name>Markos Chandras</name>
-</maintainer>
-<longdescription lang="en">
-</longdescription>
+ <herd>qt</herd>
+ <maintainer>
+ <email>hwoarang@gentoo.org</email>
+ <name>Markos Chandras</name>
+ </maintainer>
+ <maintainer>
+ <email>chiiph@gentoo.org</email>
+ <name>Tomas Touceda</name>
+ </maintainer>
+ <longdescription lang="en">
+ </longdescription>
</pkgmetadata>