summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeff Horelick <jdhore@gentoo.org>2012-12-26 17:07:25 +0000
committerJeff Horelick <jdhore@gentoo.org>2012-12-26 17:07:25 +0000
commit1a1ac2cefd65058d2b9091de642216053dc11b1c (patch)
tree657c688595fab82c06c77ccd307a6ce3af6a7383 /media-video
parentmarked x86 per bug 447572 (diff)
downloadgentoo-2-1a1ac2cefd65058d2b9091de642216053dc11b1c.tar.gz
gentoo-2-1a1ac2cefd65058d2b9091de642216053dc11b1c.tar.bz2
gentoo-2-1a1ac2cefd65058d2b9091de642216053dc11b1c.zip
Version bump. Closes bug #448668
(Portage version: 2.2.0_alpha149/cvs/Linux i686, signed Manifest commit with key 23E9E900)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/miro/ChangeLog8
-rw-r--r--media-video/miro/miro-5.0.4.ebuild96
2 files changed, 102 insertions, 2 deletions
diff --git a/media-video/miro/ChangeLog b/media-video/miro/ChangeLog
index 72925e97bfac..ae97429132b2 100644
--- a/media-video/miro/ChangeLog
+++ b/media-video/miro/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/miro
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/miro/ChangeLog,v 1.19 2012/06/17 01:52:39 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/miro/ChangeLog,v 1.20 2012/12/26 17:07:25 jdhore Exp $
+
+*miro-5.0.4 (26 Dec 2012)
+
+ 26 Dec 2012; Jeff Horelick <jdhore@gentoo.org> +miro-5.0.4.ebuild:
+ Version bump. Closes bug #448668
17 Jun 2012; Jeff Horelick <jdhore@gentoo.org> miro-5.0.1.ebuild:
Depend on the avahi mdnsresponder-compat USE flag being set, not JUST avahi.
@@ -94,4 +99,3 @@
+files/miro-2.5.3-remove-unittest-option.patch, +metadata.xml:
Initial commit. Fix bug 131527
Thanks to wayne work on the bug.
-
diff --git a/media-video/miro/miro-5.0.4.ebuild b/media-video/miro/miro-5.0.4.ebuild
new file mode 100644
index 000000000000..72e2c8ede934
--- /dev/null
+++ b/media-video/miro/miro-5.0.4.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/miro/miro-5.0.4.ebuild,v 1.1 2012/12/26 17:07:25 jdhore Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="2:2.7"
+PYTHON_USE_WITH="sqlite"
+inherit eutils fdo-mime gnome2-utils distutils
+
+DESCRIPTION="Open source video player and podcast client"
+HOMEPAGE="http://www.getmiro.com/"
+SRC_URI="http://ftp.osuosl.org/pub/pculture.org/${PN}/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="libnotify aac musepack xvid"
+
+CDEPEND="
+ dev-libs/glib:2
+ >=dev-python/pyrex-0.9.6.4
+ dev-python/pygtk:2
+ dev-python/pygobject:2
+ >=virtual/ffmpeg-0.6.90"
+
+RDEPEND="${CDEPEND}
+ dev-python/dbus-python
+ dev-python/pycairo
+ dev-python/gconf-python
+ dev-python/gst-python:0.10
+ dev-python/pyrex
+ >=dev-python/pywebkitgtk-1.1.5
+ dev-python/pycurl
+ >=net-libs/rb_libtorrent-0.14.1[python]
+ media-libs/mutagen
+ media-plugins/gst-plugins-meta:0.10
+ media-plugins/gst-plugins-pango:0.10
+ aac? ( media-plugins/gst-plugins-faad:0.10 )
+ libnotify? ( dev-python/notify-python )
+ musepack? ( media-plugins/gst-plugins-musepack:0.10 )
+ xvid? ( media-plugins/gst-plugins-xvid:0.10 )
+ net-dns/avahi[mdnsresponder-compat]"
+
+DEPEND="${CDEPEND}"
+
+# 2 unexpected failures, requires a running gconf which MAY not exist
+# but failing tests not a regression from 4.0.6
+RESTRICT="test"
+
+S="${WORKDIR}/${P}/linux"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ distutils_src_prepare
+}
+
+src_install() {
+ # doing the mv now otherwise, distutils_src_install will install it
+ mv README README.gtk || die "mv failed"
+
+ distutils_src_install
+
+ # installing docs
+ dodoc README.gtk ../{CREDITS,README} || die "dodoc failed"
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+
+ ewarn
+ ewarn "If miro doesn't play some video or audio format, please"
+ ewarn "check your USE flags on media-plugins/gst-plugins-meta"
+ ewarn
+ elog "Miro for Linux doesn't support Adobe Flash, therefore you"
+ elog "you will not see any embedded video player on MiroGuide."
+ elog
+}
+
+pkg_postrm() {
+ distutils_pkg_postrm
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}