summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-08-10 09:57:39 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-08-10 09:57:39 +0000
commit16b5724497a87b52ee7d37587f5b3c844c2249d6 (patch)
tree4e3dfdf23029cb7eb97126709918b23e8b36bb63 /media-video
parentVersion bump (diff)
downloadgentoo-2-16b5724497a87b52ee7d37587f5b3c844c2249d6.tar.gz
gentoo-2-16b5724497a87b52ee7d37587f5b3c844c2249d6.tar.bz2
gentoo-2-16b5724497a87b52ee7d37587f5b3c844c2249d6.zip
USE="qt-faststart" to replace separate media-video/qt-faststart package.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/ffmpeg/ChangeLog5
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild23
-rw-r--r--media-video/ffmpeg/metadata.xml1
3 files changed, 20 insertions, 9 deletions
diff --git a/media-video/ffmpeg/ChangeLog b/media-video/ffmpeg/ChangeLog
index f9f871171d86..ec4bfeae423e 100644
--- a/media-video/ffmpeg/ChangeLog
+++ b/media-video/ffmpeg/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-video/ffmpeg
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.365 2010/08/02 05:12:05 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.366 2010/08/10 09:57:39 ssuominen Exp $
+
+ 10 Aug 2010; Samuli Suominen <ssuominen@gentoo.org> ffmpeg-9999.ebuild:
+ USE="qt-faststart" to replace separate media-video/qt-faststart package.
02 Aug 2010; Alexis Ballier <aballier@gentoo.org> ffmpeg-9999.ebuild:
avfilter-lavf doesnt exist, bug #330247
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index 6a5c28f29c77..d2c9e05b4970 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999.ebuild,v 1.18 2010/08/02 05:12:05 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999.ebuild,v 1.19 2010/08/10 09:57:39 ssuominen Exp $
EAPI="2"
@@ -30,10 +30,7 @@ if [ "${PV#9999}" != "${PV}" ] ; then
else
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
fi
-IUSE="+3dnow +3dnowext alsa altivec amr bindist +bzip2 cpudetection custom-cflags
-debug dirac doc +encode faac gsm +hardcoded-tables ieee1394 jack jpeg2k
-+mmx +mmxext mp3 network oss pic rtmp schroedinger sdl speex +ssse3 static-libs test theora
-threads v4l v4l2 vaapi vdpau vorbis vpx X x264 xvid +zlib"
+IUSE="+3dnow +3dnowext alsa altivec amr bindist +bzip2 cpudetection custom-cflags debug dirac doc +encode faac gsm +hardcoded-tables ieee1394 jack jpeg2k +mmx +mmxext mp3 network oss pic qt-faststart rtmp schroedinger sdl speex +ssse3 static-libs test theora threads v4l v4l2 vaapi vdpau vorbis vpx X x264 xvid +zlib"
VIDEO_CARDS="nvidia"
@@ -67,6 +64,7 @@ RDEPEND="
vpx? ( media-libs/libvpx )
X? ( x11-libs/libX11 x11-libs/libXext )
zlib? ( sys-libs/zlib )
+ !media-video/qt-faststart
"
DEPEND="${RDEPEND}
@@ -230,19 +228,28 @@ src_configure() {
--mandir=/usr/share/man \
--enable-static --enable-shared \
--cc="$(tc-getCC)" \
- ${myconf} || die "configure failed"
+ ${myconf} || die
}
src_compile() {
emake version.h || die #252269
- emake || die "make failed"
+ emake || die
+
+ if use qt-faststart; then
+ tc-export CC
+ emake -C tools qt-faststart || die
+ fi
}
src_install() {
- emake DESTDIR="${D}" install install-man || die "Install Failed"
+ emake DESTDIR="${D}" install install-man || die
dodoc Changelog README INSTALL
dodoc doc/*
+
+ if use qt-faststart; then
+ dobin tools/qt-faststart || die
+ fi
}
src_test() {
diff --git a/media-video/ffmpeg/metadata.xml b/media-video/ffmpeg/metadata.xml
index 8e4dbae27162..59048585e3db 100644
--- a/media-video/ffmpeg/metadata.xml
+++ b/media-video/ffmpeg/metadata.xml
@@ -20,6 +20,7 @@
<flag name="mmxext">Enables mmx2 support</flag>
<flag name="network">Enables network streaming support</flag>
<flag name="pic">Force shared libraries to be built as PIC (this is slower)</flag>
+ <flag name="qt-faststart">Build and install qt-faststart application</flag>
<flag name="rtmp">Enable Real Time Messaging Protocol using librtmp</flag>
<flag name="schroedinger">Enable Dirac video support (an advanced royalty-free video compression format) via libschroedinger (high-speed implementation in C of the Dirac codec).</flag>
<flag name="ssse3">faster floating point optimization for SSSE3 capable chips (Intel Core 2 and later chips)</flag>