summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-09-01 18:54:38 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-09-01 18:54:38 +0000
commit142624bad73623e36e50c4b9927791c16c086076 (patch)
tree054160629a7800a630918bab7712b1ddc7da9f15 /media-video
parentRemove unused autotools eclass. (diff)
downloadgentoo-2-142624bad73623e36e50c4b9927791c16c086076.tar.gz
gentoo-2-142624bad73623e36e50c4b9927791c16c086076.tar.bz2
gentoo-2-142624bad73623e36e50c4b9927791c16c086076.zip
Revision bump. Import the install fix I did for avidemux-plugins to bring back avidemux3_cli, as that executable went lost after making more use of the eclass; the cmake-utils.eclass currently doesn't support calling cmake-utils_src_install multiple times with different BUILD_DIR locations, see bug #483294 for more details. Thanks to Nikoli on IRC for reporting the missing executable.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/avidemux/ChangeLog12
-rw-r--r--media-video/avidemux/avidemux-2.6.5-r1.ebuild132
2 files changed, 143 insertions, 1 deletions
diff --git a/media-video/avidemux/ChangeLog b/media-video/avidemux/ChangeLog
index cf9f958051e9..a003d4b70139 100644
--- a/media-video/avidemux/ChangeLog
+++ b/media-video/avidemux/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for media-video/avidemux
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/avidemux/ChangeLog,v 1.225 2013/09/01 11:53:13 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/avidemux/ChangeLog,v 1.226 2013/09/01 18:54:38 tomwij Exp $
+
+*avidemux-2.6.5-r1 (01 Sep 2013)
+
+ 01 Sep 2013; Tom Wijsman <TomWij@gentoo.org> +avidemux-2.6.5-r1.ebuild:
+ Revision bump. Import the install fix I did for avidemux-plugins to bring back
+ avidemux3_cli, as that executable went lost after making more use of the
+ eclass; the cmake-utils.eclass currently doesn't support calling cmake-
+ utils_src_install multiple times with different BUILD_DIR locations, see bug
+ #483294 for more details. Thanks to Nikoli on IRC for reporting the missing
+ executable.
*avidemux-2.6.5 (01 Sep 2013)
diff --git a/media-video/avidemux/avidemux-2.6.5-r1.ebuild b/media-video/avidemux/avidemux-2.6.5-r1.ebuild
new file mode 100644
index 000000000000..16d2dfba721e
--- /dev/null
+++ b/media-video/avidemux/avidemux-2.6.5-r1.ebuild
@@ -0,0 +1,132 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/avidemux/avidemux-2.6.5-r1.ebuild,v 1.1 2013/09/01 18:54:38 tomwij Exp $
+
+EAPI="5"
+
+PLOCALES="ca cs de el es fr it ja pt_BR ru sr sr@latin tr"
+
+inherit cmake-utils eutils flag-o-matic l10n
+
+SLOT="2.6"
+
+DESCRIPTION="Video editor designed for simple cutting, filtering and encoding tasks."
+HOMEPAGE="http://fixounet.free.fr/${PN}"
+
+# Multiple licenses because of all the bundled stuff.
+LICENSE="GPL-1 GPL-2 MIT PSF-2 public-domain"
+IUSE="debug opengl nls qt4 sdl vaapi vdpau video_cards_fglrx xv"
+KEYWORDS="~amd64 ~x86"
+
+if [[ ${PV} == *9999* ]] ; then
+ KEYWORDS=""
+ EGIT_REPO_URI="git://gitorious.org/${PN}2-6/${PN}2-6.git https://git.gitorious.org/${PN}2-6/${PN}2-6.git"
+
+ inherit git-2
+else
+ MY_P="${PN}_${PV}"
+ SRC_URI="mirror://sourceforge/${PN}/${PV}/${MY_P}.tar.gz"
+fi
+
+DEPEND="
+ ~media-libs/avidemux-core-${PV}:${SLOT}[nls?,sdl?,vaapi?,vdpau?,video_cards_fglrx?,xv?]
+ opengl? ( virtual/opengl:0 )
+ qt4? ( >=dev-qt/qtgui-4.8.3:4 )
+ vaapi? ( x11-libs/libva:0 )
+ video_cards_fglrx? ( x11-libs/xvba-video:0 )
+"
+RDEPEND="$DEPEND"
+PDEPEND="~media-libs/avidemux-plugins-${PV}:${SLOT}[opengl?,qt4?]"
+
+S="${WORKDIR}/${MY_P}"
+
+processes="buildCli:avidemux/cli"
+use qt4 && processes+=" buildQt4:avidemux/qt4"
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # Fix icon name -> avidemux-2.6.png
+ sed -i -e "/^Icon/ s:${PN}:${PN}-2.6:" ${PN}2.desktop || die "Icon name fix failed."
+
+ # The desktop file is broken. It uses avidemux2 instead of avidemux3
+ # so it will actually launch avidemux-2.5 if it is installed.
+ sed -i -e "/^Exec/ s:${PN}2:${PN}3:" ${PN}2.desktop || die "Desktop file fix failed."
+ sed -i -re '/^Exec/ s:(avidemux3_)gtk:\1qt4:' ${PN}2.desktop || die "Desktop file fix failed."
+
+ # Fix QA warnings that complain a trailing ; is missing and Application is deprecated.
+ sed -i -e 's/Application;AudioVideo/AudioVideo;/g' ${PN}2.desktop || die "Desktop file fix failed."
+
+ # Now rename the desktop file to not collide with 2.5.
+ mv ${PN}2.desktop ${PN}-2.6.desktop || die "Collision rename failed."
+
+ # Remove "Build Option" dialog because it doesn't reflect what the GUI can or has been built with. (Bug #463628)
+ sed -i -e '/Build Option/d' avidemux/common/ADM_commonUI/myOwnMenu.h || die "Couldn't remove \"Build Option\" dialog."
+}
+
+src_configure() {
+ local mycmakeargs="
+ -DAVIDEMUX_SOURCE_DIR='${S}'
+ $(cmake-utils_use nls GETTEXT)
+ $(cmake-utils_use sdl)
+ $(cmake-utils_use vaapi LIBVA)
+ $(cmake-utils_use vdpau)
+ $(cmake-utils_use video_cards_fglrx XVBA)
+ $(cmake-utils_use xv XVIDEO)
+ "
+
+ if use debug ; then
+ mycmakeargs+=" -DVERBOSE=1 -DCMAKE_BUILD_TYPE=Debug -DADM_DEBUG=1"
+ fi
+
+ for process in ${processes} ; do
+ local build="${process%%:*}"
+
+ mkdir "${S}"/${build} || die "Can't create build folder."
+ cd "${S}"/${build} || die "Can't enter build folder."
+ CMAKE_USE_DIR="${S}"/${process#*:} BUILD_DIR="${S}"/${build} cmake-utils_src_configure
+ done
+
+ # Add lax vector typing for PowerPC.
+ if use ppc || use ppc64 ; then
+ append-cflags -flax-vector-conversions
+ fi
+
+ # See bug 432322.
+ use x86 && replace-flags -O0 -O1
+}
+
+src_compile() {
+ for process in ${processes} ; do
+ BUILD_DIR="${S}/${process%%:*}" cmake-utils_src_compile
+ done
+}
+
+DOCS=( AUTHORS README )
+
+src_install() {
+ for process in ${processes} ; do
+ # cmake-utils_src_install doesn't respect BUILD_DIR
+ # and there sometimes is a preinstall phase present.
+ pushd "${S}/${process%%:*}" > /dev/null || die
+ grep '^preinstall/fast' Makefile && emake DESTDIR="${D}" preinstall/fast
+ grep '^install/fast' Makefile && emake DESTDIR="${D}" install/fast
+ popd > /dev/null || die
+ done
+
+ if [[ -f "${ED}"/usr/bin/avidemux3_cli ]] ; then
+ fperms +x /usr/bin/avidemux3_cli
+ fi
+
+ if [[ -f "${ED}"/usr/bin/avidemux3_jobs ]] ; then
+ fperms +x /usr/bin/avidemux3_jobs
+ fi
+
+ cd "${S}" || die "Can't enter source folder."
+ newicon ${PN}_icon.png ${PN}-2.6.png
+
+ if use qt4 ; then
+ fperms +x /usr/bin/avidemux3_qt4
+ domenu ${PN}-2.6.desktop
+ fi
+}