summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-09-30 11:54:16 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-09-30 11:54:16 +0000
commit8d043fb1127b6eded453c2e10c8b8db08c807f2b (patch)
treea3548d66e3c45c4cf224b2c1934bf675b16e91b2 /media-video/vlc
parentAdded Gnome menu entries for AbiWord. A KDE user should just add for kde if ... (diff)
downloadgentoo-2-8d043fb1127b6eded453c2e10c8b8db08c807f2b.tar.gz
gentoo-2-8d043fb1127b6eded453c2e10c8b8db08c807f2b.tar.bz2
gentoo-2-8d043fb1127b6eded453c2e10c8b8db08c807f2b.zip
don't use ALSA until a stable alsa >= 0.90 is released
Diffstat (limited to 'media-video/vlc')
-rw-r--r--media-video/vlc/vlc-0.2.73.ebuild17
-rw-r--r--media-video/vlc/vlc-0.2.80.ebuild16
-rw-r--r--media-video/vlc/vlc-0.2.83.ebuild17
3 files changed, 29 insertions, 21 deletions
diff --git a/media-video/vlc/vlc-0.2.73.ebuild b/media-video/vlc/vlc-0.2.73.ebuild
index d772d693f6a0..233c8bcbf413 100644
--- a/media-video/vlc/vlc-0.2.73.ebuild
+++ b/media-video/vlc/vlc-0.2.73.ebuild
@@ -1,6 +1,6 @@
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Nathaniel Hirsch <nh2@njit.edu> Achim Gottinge <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-0.2.73.ebuild,v 1.2 2001/05/01 18:29:06 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-0.2.73.ebuild,v 1.3 2001/09/30 11:54:16 hallski Exp $
S=${WORKDIR}/${P}
DESCRIPTION="DVD / video player"
@@ -13,7 +13,7 @@ DEPEND=">=media-libs/libsdl-1.1.8-r1
ggi? ( >=media-libs/libggi-2.0_beta3 )
qt? ( >=x11-libs/qt-x11-2.3.0 )
gtk? ( >=x11-libs/gtk+-1.2.9 )
- alsa? ( >=media-libs/alsa-lib-0.5.10 )
+ #alsa? ( >=media-libs/alsa-lib-0.5.10 )
X? ( virtual/x11 )"
#kde? ( >=kde-base/kdelibs-2.1.1 )
@@ -57,11 +57,14 @@ src_compile(){
else
myconf="$myconf --disable-x11"
fi
- if [ "`use alsa`" ]
- then
- myconf="$myconf --enable-alsa"
- fi
- try ./configure --prefix=/usr $myconf --with-sdl
+
+# Currently alsa support in vlc requires Alsa 0.90 (which is unstable).
+# Until some release of alsa is released which works with vlc don't use it.
+# if [ "`use alsa`" ]
+# then
+# myconf="$myconf --enable-alsa"
+# fi
+ try ./configure --prefix=/usr $myconf --with-sdl --disable-alsa
try make
}
src_install(){
diff --git a/media-video/vlc/vlc-0.2.80.ebuild b/media-video/vlc/vlc-0.2.80.ebuild
index a106069cfcf8..714157e97df3 100644
--- a/media-video/vlc/vlc-0.2.80.ebuild
+++ b/media-video/vlc/vlc-0.2.80.ebuild
@@ -1,6 +1,6 @@
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Nathaniel Hirsch <nh2@njit.edu> Achim Gottinge <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-0.2.80.ebuild,v 1.1 2001/06/20 13:47:39 darks Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-0.2.80.ebuild,v 1.2 2001/09/30 11:54:16 hallski Exp $
S=${WORKDIR}/${P}
DESCRIPTION="DVD / video player"
@@ -13,7 +13,7 @@ DEPEND=">=media-libs/libsdl-1.1.8-r1
ggi? ( >=media-libs/libggi-2.0_beta3 )
qt? ( >=x11-libs/qt-x11-2.3.0 )
gtk? ( >=x11-libs/gtk+-1.2.9 )
- alsa? ( >=media-libs/alsa-lib-0.5.10 )
+ #alsa? ( >=media-libs/alsa-lib-0.5.10 )
X? ( virtual/x11 )"
#kde? ( >=kde-base/kdelibs-2.1.1 )
@@ -57,11 +57,13 @@ src_compile(){
else
myconf="$myconf --disable-x11"
fi
- if [ "`use alsa`" ]
- then
- myconf="$myconf --enable-alsa"
- fi
- try ./configure --prefix=/usr $myconf --with-sdl
+# Currently alsa support in vlc requires Alsa 0.90 (which is unstable).
+# Until some release of alsa is released which works with vlc don't use it.
+# if [ "`use alsa`" ]
+# then
+# myconf="$myconf --enable-alsa"
+# fi
+ try ./configure --prefix=/usr $myconf --with-sdl --disable-alsa
try make
}
src_install(){
diff --git a/media-video/vlc/vlc-0.2.83.ebuild b/media-video/vlc/vlc-0.2.83.ebuild
index 2d4ad9f33d73..7a53d3ca3668 100644
--- a/media-video/vlc/vlc-0.2.83.ebuild
+++ b/media-video/vlc/vlc-0.2.83.ebuild
@@ -1,6 +1,6 @@
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Nathaniel Hirsch <nh2@njit.edu> Achim Gottinge <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-0.2.83.ebuild,v 1.1 2001/09/25 03:27:06 hallski Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-0.2.83.ebuild,v 1.2 2001/09/30 11:54:16 hallski Exp $
S=${WORKDIR}/${P}
DESCRIPTION="DVD / video player"
@@ -13,7 +13,7 @@ DEPEND=">=media-libs/libsdl-1.1.8-r1
ggi? ( >=media-libs/libggi-2.0_beta3 )
qt? ( >=x11-libs/qt-x11-2.3.0 )
gtk? ( >=x11-libs/gtk+-1.2.9 )
- alsa? ( >=media-libs/alsa-lib-0.5.10 )
+ #alsa? ( >=media-libs/alsa-lib-0.5.10 )
X? ( virtual/x11 )"
#kde? ( >=kde-base/kdelibs-2.1.1 )
@@ -57,12 +57,15 @@ src_compile(){
else
myconf="$myconf --disable-x11"
fi
- if [ "`use alsa`" ]
- then
- myconf="$myconf --enable-alsa"
- fi
- try ./configure --prefix=/usr $myconf --with-sdl
+# Currently alsa support in vlc requires Alsa 0.90 (which is unstable).
+# Until some release of alsa is released which works with vlc don't use it.
+# if [ "`use alsa`" ]
+# then
+# myconf="$myconf --enable-alsa"
+# fi
+
+ try ./configure --prefix=/usr $myconf --with-sdl --disable-alsa
try make
}