summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-10-22 18:13:34 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-10-22 18:13:34 +0000
commit4ea8157d8d56a42ce455963556d3bb1268a4902a (patch)
tree117ba8d2d8d67387bbaf81ed70507b7251bc021f /media-video/vlc
parentfixed typo, thanks tchan for reporting (diff)
downloadgentoo-2-4ea8157d8d56a42ce455963556d3bb1268a4902a.tar.gz
gentoo-2-4ea8157d8d56a42ce455963556d3bb1268a4902a.tar.bz2
gentoo-2-4ea8157d8d56a42ce455963556d3bb1268a4902a.zip
updated to 0.2.90, thanks duckx for notifying
Diffstat (limited to 'media-video/vlc')
-rw-r--r--media-video/vlc/files/digest-vlc-0.2.901
-rw-r--r--media-video/vlc/vlc-0.2.90.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/media-video/vlc/files/digest-vlc-0.2.90 b/media-video/vlc/files/digest-vlc-0.2.90
new file mode 100644
index 000000000000..b6cd8a6cb3bd
--- /dev/null
+++ b/media-video/vlc/files/digest-vlc-0.2.90
@@ -0,0 +1 @@
+MD5 1b9a13bd56fee27892c97257fab11cc9 vlc-0.2.90.tar.gz
diff --git a/media-video/vlc/vlc-0.2.90.ebuild b/media-video/vlc/vlc-0.2.90.ebuild
new file mode 100644
index 000000000000..977022727aa5
--- /dev/null
+++ b/media-video/vlc/vlc-0.2.90.ebuild
@@ -0,0 +1,78 @@
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Nathaniel Hirsch <nh2@njit.edu> Achim Gottinge <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-0.2.90.ebuild,v 1.1 2001/10/22 18:13:34 hallski Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="DVD / video player"
+SRC_URI="http://www.videolan.org/pub/videolan/${PN}/${PV}/${P}.tar.gz"
+HOMEPAGE="http://www.videolan.org"
+
+DEPEND=">=media-libs/libsdl-1.1.8-r1
+ gnome? ( >=gnome-base/gnome-libs-1.4.1.2-r1 )
+ esd? ( >=media-sound/esound-0.2.22 )
+ ggi? ( >=media-libs/libggi-2.0_beta3 )
+ qt? ( >=x11-libs/qt-x11-2.3.0 )
+ gtk? ( >=x11-libs/gtk+-1.2.10-r4 )
+ #alsa? ( >=media-libs/alsa-lib-0.5.10 )
+ X? ( virtual/x11 )"
+ #kde? ( >=kde-base/kdelibs-2.1.1 )
+
+src_compile(){
+ local myconf
+ if [ "`use fbdev`" ]
+ then
+ myconf="--enable-fb"
+ fi
+ if [ -z "`use mmx`" ]
+ then
+ myconf="$myconf --disable-mmx"
+ fi
+ if [ "`use esd`" ]
+ then
+ myconf="$myconf --enable-esd"
+ fi
+ if [ "`use ggi`" ]
+ then
+ myconf="$myconf --with-ggi"
+ fi
+ if [ "`use qt`" ]
+ then
+ myconf="$myconf --enable-qt"
+ fi
+ #if [ "`use kde`" ]
+ #then
+ # myconf="$myconf --enable-kde"
+ #fi
+ if [ "`use gnome`" ]
+ then
+ myconf="$myconf --enable-gnome"
+ fi
+ if [ -z "`use gtk`" ]
+ then
+ myconf="$myconf --disable-gtk"
+ fi
+ if [ "`use X`" ]
+ then
+ myconf="$myconf --enable-xvideo"
+ else
+ myconf="$myconf --disable-x11"
+ fi
+
+# Currently alsa support in vlc requires Alsa 0.90 (which is unstable).
+# Until some release of alsa is released which works with vlc don't use it.
+# if [ "`use alsa`" ]
+# then
+# myconf="$myconf --enable-alsa"
+# fi
+
+ try ./configure --prefix=/usr $myconf --with-sdl --disable-alsa
+ try make
+}
+
+src_install() {
+
+ dodir /usr/{bin,lib}
+ try make DESTDIR=${D} install
+
+}
+