summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Bornkessel <hd_brummy@gentoo.org>2006-06-28 12:34:00 +0000
committerJörg Bornkessel <hd_brummy@gentoo.org>2006-06-28 12:34:00 +0000
commitf47ac1e236c7b35098cb4b10ecb23635bfd0e11a (patch)
treea88c678c2ba7f12fdb42103d6a6cd35b7cc27dcc /media-video/vdrsync/vdrsync-0.1.3_pre050322-r1.ebuild
parentUse multilib.eclass for installation of xine-plugin. (diff)
downloadgentoo-2-f47ac1e236c7b35098cb4b10ecb23635bfd0e11a.tar.gz
gentoo-2-f47ac1e236c7b35098cb4b10ecb23635bfd0e11a.tar.bz2
gentoo-2-f47ac1e236c7b35098cb4b10ecb23635bfd0e11a.zip
fix for not founded Path included
(Portage version: 2.1-r1)
Diffstat (limited to 'media-video/vdrsync/vdrsync-0.1.3_pre050322-r1.ebuild')
-rw-r--r--media-video/vdrsync/vdrsync-0.1.3_pre050322-r1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/media-video/vdrsync/vdrsync-0.1.3_pre050322-r1.ebuild b/media-video/vdrsync/vdrsync-0.1.3_pre050322-r1.ebuild
new file mode 100644
index 000000000000..9def01df2b2f
--- /dev/null
+++ b/media-video/vdrsync/vdrsync-0.1.3_pre050322-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/vdrsync/vdrsync-0.1.3_pre050322-r1.ebuild,v 1.1 2006/06/28 12:34:00 hd_brummy Exp $
+
+inherit eutils
+
+MY_P="${PN}-${PV#*_pre}"
+
+S=${WORKDIR}/vdrsync-${MY_SNAPSHOT}
+
+DESCRIPTION="converting vdr-recordings to mpeg2, dvd or other similar formats"
+HOMEPAGE="http://vdrsync.vdr-portal.de/"
+SRC_URI="http://vdrsync.vdr-portal.de/releases/${MY_P}.tgz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64"
+IUSE="dvdr"
+
+DEPEND=""
+RDEPEND=">=dev-lang/perl-5.8.0
+ media-fonts/corefonts
+ dvdr? (
+ >=media-libs/gd-2.0.15
+ >=dev-perl/GD-2.0.7
+ >=dev-perl/GDTextUtil-0.86
+ >=media-video/dvdauthor-0.6.8
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ sed -e "s:/usr/X11R6/lib/X11/fonts/truetype/arial.ttf:/usr/share/fonts/corefonts/arial.ttf:g" \
+ -i dvd-menu.pl
+
+ epatch ${FILESDIR}/${P}-path.diff
+}
+# vdrsync/dvd-menu use hardcoded tmp-directory for large (up to and
+# greater than 1G). Uncomment and change the next two lines to your
+# needs if you need another tmp-Dir
+#sed -e 's:"/tmp/":"/temp/":g' /usr/bin/dvd-menu.pl
+#sed -e 's:"/tmp/":"/temp/":g' /usr/bin/vdrsync.pl
+
+src_install() {
+ dobin check-vdrsync.pl vdrsync.pl vdrsync_buffer.pl
+ use dvdr && dobin dvd-menu.pl
+ dodoc CHANGES
+}
+